A/C quit :( - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-13-2012, 03:48 PM   #1
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
A/C quit :(

My a/c quit without warning today. It blows air but even on regular and max it is still air temp(98 degrees today) any suggestions of where to start since I have no warranty
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2012, 03:56 PM   #2
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
This happened to me check all the fuses and relays that have to do worth the ac and ac clutch, its probably out
05MUSTANG4.0L is offline   Reply With Quote
Old 08-13-2012, 04:02 PM   #3
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Also...I have no bumper. Could it be the line as well. Did the fuse switch fix it
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2012, 04:17 PM   #4
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Mine just went out the first mechanic I took it to ended up stealing my ac switch fuse when I wasn't looking..... But I'm curious why don't u have a bumper, if its crashed and it damaged the line then check how much freon u have in there maybe u got a leak .
05MUSTANG4.0L is offline   Reply With Quote
Old 08-13-2012, 04:43 PM   #5
Registered Member
Regular
 
NicholasP's Avatar
 
Join Date: Apr 2012
Region: Georgia
Posts: 1,161
Quote:
Originally Posted by Whitelightning
My a/c quit without warning today. It blows air but even on regular and max it is still air temp(98 degrees today) any suggestions of where to start since I have no warranty
You get the front fixed?!
NicholasP is offline   Reply With Quote
Old 08-13-2012, 04:59 PM   #6
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by 05MUSTANG4.0L
Mine just went out the first mechanic I took it to ended up stealing my ac switch fuse when I wasn't looking..... But I'm curious why don't u have a bumper, if its crashed and it damaged the line then check how much freon u have in there maybe u got a leak .
I hit a truck at ten mph and the trailor hit did a number on my bumper and grille. It was not as cold as it once was and today it just blows hot air. Even on the max AC button
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 08-13-2012, 05:35 PM   #7
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by 05MUSTANG4.0L
Mine just went out the first mechanic I took it to ended up stealing my ac switch fuse when I wasn't looking..... But I'm curious why don't u have a bumper, if its crashed and it damaged the line then check how much freon u have in there maybe u got a leak .
Wow what the heck that's an honest mechanic.
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 08-13-2012, 06:17 PM   #8
Registered Member
Regular
 
Join Date: Aug 2012
Region: Georgia
Posts: 525
Re: A/C quit :(

Quote:
Originally Posted by Whitelightning View Post
I hit a truck at ten mph and the trailor hit did a number on my bumper and grille. It was not as cold as it once was and today it just blows hot air. Even on the max AC button
You may have a leak in the condensor,,in the front of the car..
__________________
mymustang is offline   Reply With Quote
Old 08-13-2012, 06:35 PM   #9
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by mymustang

You may have a leak in the condensor,,in the front of the car..
+ 1
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 08-13-2012, 09:40 PM   #10
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by mymustang

You may have a leak in the condensor,,in the front of the car..
Nope. Me and my dad checked it about an hour ago. It all is there. Freon and everything is fine. It blowed a little colder than earlier today. But still not up to par. Then again a duct tape grille still doesn't protect like it should. But I get nice air flow
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 08-14-2012, 06:58 AM   #11
Registered Member
Regular
 
05MUSTANG4.0L's Avatar
 
Join Date: Apr 2012
Region: Texas
Posts: 729
Quote:
Originally Posted by 99ford

Wow what the heck that's an honest mechanic.
I know I even paid him $25 to check it for me and didn't even put a finger on it bc he said he knew what it was, that all the mustangs had the same problem

---------- Post added at 06:58 AM ---------- Previous post was at 06:56 AM ----------

Quote:
Originally Posted by Whitelightning

Nope. Me and my dad checked it about an hour ago. It all is there. Freon and everything is fine. It blowed a little colder than earlier today. But still not up to par. Then again a duct tape grille still doesn't protect like it should. But I get nice air flow
does the ac compressor turn on and start spinning when u turn on the ac?
05MUSTANG4.0L is offline   Reply With Quote
Old 08-14-2012, 11:58 AM   #12
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by 05MUSTANG4.0L

I know I even paid him $25 to check it for me and didn't even put a finger on it bc he said he knew what it was, that all the mustangs had the same problem

---------- Post added at 06:58 AM ---------- Previous post was at 06:56 AM ----------



does the ac compressor turn on and start spinning when u turn on the ac?
Yes. But the lines aren't getting as cold. But hey it blows slightly colder now. When I replace my front end is when we will work on it. Just nawwing away at the parts list for a GT front end. I'm going all out. 302 grille and valence
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:08 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.