cabin exhaust smell. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-24-2012, 04:53 PM   #1
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
cabin exhaust smell.

Hello everyone, ever follow a car after they open it up and you get that smelly rotten egg smell? Well i notice when i sometimes open my 3.7 up i can smell it in the cabin? Ive read other forums with different cars, not fords, and say that it sometimes happens. What causes this? The sound tubes maybe?
MrMike is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2012, 04:56 PM   #2
Registered Member
Regular
 
Rm360's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 1,140
I know of two things that cause this smell , bad cats , or a dirty cabin air filter , if you don't have any codes I would start by changing the filter
Rm360 is offline   Reply With Quote
Old 09-24-2012, 04:58 PM   #3
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Really? Its a 2013 three months old!
MrMike is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2012, 05:06 PM   #4
Registered Member
Regular
 
Rm360's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 1,140
Do you smell the smell all the time or do you smell it when your using the AC or heat ?
Rm360 is offline   Reply With Quote
Old 09-24-2012, 05:11 PM   #5
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by MrMike
Really? Its a 2013 three months old!
No your issue is something else.

Has this been going since you bought it?
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 09-24-2012, 05:13 PM   #6
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Sorry, Only at 6000 rpm, when i really push it.

---------- Post added at 06:13 PM ---------- Previous post was at 06:11 PM ----------

Never smell it under normal use. Ac, heater, etc.
MrMike is offline   Reply With Quote
Old 09-24-2012, 05:35 PM   #7
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Is this a normal thing? Or should i be making a trip to the dealer?
MrMike is offline   Reply With Quote
Old 09-24-2012, 06:55 PM   #8
Registered Member
Regular
 
Rm360's Avatar
 
Join Date: Feb 2012
Region: Illinois
Posts: 1,140
I did a little reading and it seems sometimes gas has to much sulfer in it as an additive, the engine doesn't burn it completely and the cat stores and then releases as hydrogen sulfide when you add enough load to the engine and force more air through the exhaust, a quick thing to try is buying gas from a different station and see if it stops, if not then the cat may be defective and you should take it to the dealer.
Rm360 is offline   Reply With Quote
Old 09-24-2012, 09:13 PM   #9
Registered Member
Regular
 
NickAP12589's Avatar
 
Join Date: Jan 2012
Region: Maryland
Posts: 107
Do you notice any sound difference when your up in the 6k's? Could be a bad exhaust manifold gasket. When you get those RPM's up there, theres a lot more pressure pushing out on that manifold and if the gasket is bad or the bolts aren't tight enough there could be a leak. Obviously if it's either of those, a new gasket is needed as gaskets are not reusable.
NickAP12589 is offline   Reply With Quote
Old 09-24-2012, 09:45 PM   #10
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Thx ill try different gas, i usually go to shell but ill try something else. I have to gas up tomorrow so ill keep you posted!

---------- Post added at 10:45 PM ---------- Previous post was at 10:43 PM ----------

The sound is good, not any louder than the norm would be, but ill also keep a close eye on it tomorrow! Thx guys and ill keep you posted.
MrMike is offline   Reply With Quote
Old 09-24-2012, 10:10 PM   #11
Registered Member
Regular
 
Schram1's Avatar
 
Join Date: Sep 2012
Region: Texas
Posts: 289
It's the smell of victory my car smells like pure gas
__________________
Borla catback s-type Borla Long tube off road x pipe
Jlt carbon fiber intake / BBk TB
J&M panhard bar J&M extreme lower control arm /relo
koni STR.T RTR wheels NT555/ Shelby Baer 6P
DSS Aluminum 3.5/3.73 gears
https://www.youtube.com/watch?v=1cm4Di-zmZA
Schram1 is offline   Reply With Quote
Old 09-25-2012, 06:55 AM   #12
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by Rm360
I did a little reading and it seems sometimes gas has to much sulfer in it as an additive, the engine doesn't burn it completely and the cat stores and then releases as hydrogen sulfide when you add enough load to the engine and force more air through the exhaust, a quick thing to try is buying gas from a different station and see if it stops, if not then the cat may be defective and you should take it to the dealer.
^ yeah that makes the most sense to me
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 09-25-2012, 12:57 PM   #13
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Different gas this morning, ran it hard till 6000 in third and got that smell again. Any ideas? Some people say its normal when you drive it hard.
MrMike is offline   Reply With Quote
Old 09-25-2012, 01:09 PM   #14
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Are you sure you're smelling carbon? When my '11 GT was new I used to get this smell, it was almost like carbon but had a plastic burning after smell. It only happened when I would go WOT and after about 15K miles the smell has gone away. I've got 32k on it now and still rip the throttle every chance I get and no smell.
primer2tone is offline   Reply With Quote
Old 09-25-2012, 01:26 PM   #15
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Im not sure its a carbon smell, the best way i can describe it is when the car in front of you pushes his car and you can smell his almost like burning hair from a hairdryer smell or rotten egg exhaust smell. Sometimes when i get out of the car in the garage i smell a faint plasticy or rubbery smell. The car has 5300km on it now.just started pushing it in the last 2000k...was getting used to clutch, and allowed a good 2500km for the break in. Engine sounds good pulling at high rpm, i just get that smell that normally the guy behide me should get. Lol
MrMike is offline   Reply With Quote
Old 09-25-2012, 01:29 PM   #16
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
It's fine man. Just check your fluids and periodically check under to hood for anything that might be out of place.
primer2tone is offline   Reply With Quote
Old 09-25-2012, 01:33 PM   #17
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Quote:
Originally Posted by primer2tone
It's fine man. Just check your fluids and periodically check under to hood for anything that might be out of place.
O.k thanks, I'll be sure to keep an eye on them.
MrMike is offline   Reply With Quote
Old 09-26-2012, 12:30 AM   #18
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
primer2tone is offline   Reply With Quote
Old 09-27-2012, 10:20 PM   #19
Registered Member
Regular
 
NicholasP's Avatar
 
Join Date: Apr 2012
Region: Georgia
Posts: 1,161
Quote:
Originally Posted by MrMike
Sorry, Only at 6000 rpm, when i really push it.

---------- Post added at 06:13 PM ---------- Previous post was at 06:11 PM ----------

Never smell it under normal use. Ac, heater, etc.
Trust me did the same thing with my car I think it might be the exhaust breaking in mine went away
NicholasP is offline   Reply With Quote
Old 09-27-2012, 10:34 PM   #20
Staff
Blogger
Staff
 
99ford's Avatar
 
Join Date: Jan 2009
Region: Georgia
Posts: 6,120
Send a message via Skype™ to 99ford
Quote:
Originally Posted by NicholasP

Trust me did the same thing with my car I think it might be the exhaust breaking in mine went away

When did you finally notice it was gone?
__________________
Check out the Official ME gear page for site t-shirts, decals, and bottle openers: http://www.mustangevolution.com/foru...2/#post1670281
99ford is offline   Reply With Quote
Old 09-28-2012, 04:46 PM   #21
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
Quote:
Originally Posted by NicholasP

Trust me did the same thing with my car I think it might be the exhaust breaking in mine went away
So how long did it take to go away?
MrMike is offline   Reply With Quote
Old 09-30-2012, 05:45 PM   #22
Registered Member
Regular
 
NicholasP's Avatar
 
Join Date: Apr 2012
Region: Georgia
Posts: 1,161
Quote:
Originally Posted by 99ford

When did you finally notice it was gone?
I mean I honestly don't remember when but I do remember it gradually going away to where it would only happend if I really was booking it
NicholasP is offline   Reply With Quote
Old 10-01-2012, 06:32 AM   #23
Registered Member
Regular
 
MrMike's Avatar
 
Join Date: Aug 2012
Region: Canada
Posts: 730
O.k thanks. I hope its sooner than later.
MrMike is offline   Reply With Quote
Old 10-01-2012, 08:40 AM   #24
Registered Member
Regular
 
wheelman's Avatar
 
Join Date: Feb 2012
Region: Connecticut
Posts: 1,187
Quote:
Originally Posted by NicholasP

I mean I honestly don't remember when but I do remember it gradually going away to where it would only happend if I really was booking it
Same here, no issue
wheelman is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Tags
exhaust

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:58 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.