header stocks rust? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-22-2013, 02:40 PM   #1
Registered Member
Regular
 
arturo55's Avatar
 
Join Date: Jan 2013
Location: Houston
Region: Texas
Posts: 452
header stocks rust?

okay i pop my hood for the first time and i looked at my headers and the one on my driver side has a heat shield but the one on the passenger does and there both rusted
i dont know what to do help





arturo55 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2013, 03:07 PM   #2
Registered Member
Regular
 
2011 Kona Blue's Avatar
 
Join Date: Nov 2011
Region: Maryland
Posts: 7,653
Good grief?
2011 Kona Blue is offline   Reply With Quote
Old 02-22-2013, 03:13 PM   #3
Legacy Member
Legacy
 
lowflyn's Avatar
 
Join Date: Aug 2003
Region: Mississippi
Posts: 19,890
Send a message via AIM to lowflyn
Its part of cast metal, they're gonna do that
__________________
"I'm not driving too fast...just flying too low"
Mine:
-03 SB Cobra vert- 2552 of 5082 Born 02/25/03
Our's:
90 7up vert - new project-07 DSG Focus -DD
335
lowflyn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2013, 03:16 PM   #4
Registered Member
Regular
 
Venomouz831's Avatar
 
Join Date: Dec 2011
Location: Seaside
Region: California
Posts: 8,133
...
__________________
)02 Gt, Founder of WE2G
Venomouz831 is offline   Reply With Quote
Old 02-22-2013, 03:28 PM   #5
Registered Member
Regular
 
arturo55's Avatar
 
Join Date: Jan 2013
Location: Houston
Region: Texas
Posts: 452
I don't know it just doesn't look right and why would one side only have a shield ?
arturo55 is offline   Reply With Quote
Old 02-22-2013, 04:14 PM   #6
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by arturo55 View Post
I don't know it just doesn't look right and why would one side only have a shield ?
Road vibrations knocked one off probably. Last oil change I checked mine. They were rusted, so is my driveshaft and one shield only has 2 nuts left.
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 02-22-2013, 04:34 PM   #7
Registered Member
Regular
 
arturo55's Avatar
 
Join Date: Jan 2013
Location: Houston
Region: Texas
Posts: 452
so what do i do i just got the car? do i go back to where i got my car and telll them that one of the heat shield fell off?
arturo55 is offline   Reply With Quote
Old 02-23-2013, 07:42 AM   #8
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by arturo55 View Post
so what do i do i just got the car? do i go back to where i got my car and telll them that one of the heat shield fell off?
Yeah I would. You have a warranty so any little problem you have take it back and complain. I haven't had any major problems with mine. Therefore I haven't took it back. I just went to Home Depot and bough nuts for the missing screws and I tightened them all down
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 02-23-2013, 08:02 AM   #9
Registered Member
Regular
 
Blu13stang's Avatar
 
Join Date: Sep 2012
Region: Oklahoma
Posts: 264
Quote:
Originally Posted by arturo55 View Post
okay i pop my hood for the first time and i looked at my headers and the one on my driver side has a heat shield but the one on the passenger does and there both rusted
i dont know what to do help
Yep I'd go back the Dealer, they may warranty that, thanks for posting ill keep an eye on mine now. & I hope they fix you up!
Blu13stang is offline   Reply With Quote
Old 02-24-2013, 03:37 PM   #10
Registered Member
Regular
 
arturo55's Avatar
 
Join Date: Jan 2013
Location: Houston
Region: Texas
Posts: 452
thank yall
arturo55 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



04:00 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.