need helpful comments and suggestion - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-10-2013, 04:28 PM   #1
Registered User
Newbie
 
pony_'s Avatar
 
Join Date: Oct 2012
Region: Canada
Posts: 5
need helpful comments and suggestion

hi. i've got my stang last april. 12000k on it.

very first time, got some noise on wheels, so replace lower arm control both side.

now,
1. knocking noise on both rear wheels
2. bumping noise on front right wheel when i cross speed bump.
3. door knob is loose
4. seat belt sign light in not back on when it took off.
5. engine rpm drops down while idling

i sent her to service center for repair.
is it usual defects that on my 2012 mustang?
how is yours? it is very stressful to me...
pony_ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-10-2013, 07:54 PM   #2
Registered Member
Regular
 
sprdave's Avatar
 
Join Date: Jan 2013
Location: GTA
Region: Canada
Posts: 148
Mines been great.I assume yours is under warranty still.
You just need to keep on the dealership to fix these
problems.It sounds like you have some defective
bushings that need replacing.
sprdave is offline   Reply With Quote
Old 03-10-2013, 08:37 PM   #3
Registered User
Newbie
 
pony_'s Avatar
 
Join Date: Oct 2012
Region: Canada
Posts: 5
yes.. but i have no idea why the engine rpm drop down and up. it sounds like almost the engine stalled..
pony_ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-10-2013, 08:50 PM   #4
Registered User
Newbie
 
pony_'s Avatar
 
Join Date: Oct 2012
Region: Canada
Posts: 5
thnks for the post
pony_ is offline   Reply With Quote
Old 03-10-2013, 09:17 PM   #5
Moderator Emeritus
Regular
 
deadsp0t's Avatar
 
Join Date: Aug 2011
Location: MidWorld
Region: Other
Posts: 4,786
Quote:
Originally Posted by pony_ View Post
yes.. but i have no idea why the engine rpm drop down and up. it sounds like almost the engine stalled..
Mods on your car, at all?
__________________
That's unimpressive
deadsp0t is offline   Reply With Quote
Old 03-10-2013, 10:32 PM   #6
Registered Member
Regular
 
sprdave's Avatar
 
Join Date: Jan 2013
Location: GTA
Region: Canada
Posts: 148
Does your car have a tune?
If it does you need to get it adjusted
for the idle problem.
sprdave is offline   Reply With Quote
Old 03-10-2013, 11:17 PM   #7
Registered User
Newbie
 
pony_'s Avatar
 
Join Date: Oct 2012
Region: Canada
Posts: 5
Quote:
Originally Posted by sprdave View Post
Does your car have a tune?
If it does you need to get it adjusted
for the idle problem.
never tuned.
pony_ is offline   Reply With Quote
Old 03-10-2013, 11:41 PM   #8
Registered Member
Regular
 
Sanguin's Avatar
 
Join Date: Jun 2012
Location: London
Region: Kentucky
Posts: 1,623
A loose intake coupling can cause idle issues, basically unmetered air inlets. I have some clunking from the A-arms if I hit a speed bump too fast (makes the a-arm extend and pop). It never happens enough for me to even worry about it.

Besides small annoyances related to the wreck I had and the MT82 transmission's known issues, I can say the car has been really good. I've got one rattle coming from a gauge bezel I intend to fix, but it's a simple thing and only happens in cold weather.
__________________
'13 'Stang V6 - MT82 - GHIG Ordered: 5/31 Pickup: 7/3
35% Tint, Homemade Intake (1, 2), GT500 Heat Extractor/Splash Guards, Custom Gas Cap
Barton Shifter Bracket, GHIG Shift Knob


'98 Grand Prix GTP - New Project for DD
Sanguin is offline   Reply With Quote
Old 03-11-2013, 12:37 AM   #9
Registered User
Newbie
 
pony_'s Avatar
 
Join Date: Oct 2012
Region: Canada
Posts: 5
Quote:
Originally Posted by Sanguin View Post
A loose intake coupling can cause idle issues, basically unmetered air inlets. I have some clunking from the A-arms if I hit a speed bump too fast (makes the a-arm extend and pop). It never happens enough for me to even worry about it.

Besides small annoyances related to the wreck I had and the MT82 transmission's known issues, I can say the car has been really good. I've got one rattle coming from a gauge bezel I intend to fix, but it's a simple thing and only happens in cold weather.
i heard that intake couple rings can make idle issues. i checked it is tightened.
i've got that noise(knocking sounds) last summer.
i've tried other mustang, i was not happened. makes me so stressful..
thank you for the post.
pony_ is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.