help needed for gas issue - Page 2 - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-06-2013, 08:39 PM   #36
Registered Member
Regular
 
Join Date: Jun 2013
Location: Albuquerque
Region: New Mexico
Posts: 484
Sounds like you have a very aggressive (and thirsty) tune.
Six7One is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-08-2013, 12:13 AM   #37
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
50 ft of rubber in a 4.0 Automatic? Maybe you have 4:10s in that thing and its throwing your odometer off.
Midnight2012 is offline   Reply With Quote
Old 08-08-2013, 12:23 AM   #38
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
I dunno what that means sorry. Noob to muscle cars. Is the ratio about the diff? I know it's only the right rear wheel that spins when it does. I've got Pirelli p6000 tires on 17" rims. Rear right is ruined already... 50 feet with advance trak off. Only about 20 with it on... Real easy to kick the rear end out.. accidentally...
romeshs1983 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-08-2013, 12:43 AM   #39
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
18" rims.. not 17
romeshs1983 is offline   Reply With Quote
Old 08-08-2013, 01:28 AM   #40
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by romeshs1983 View Post
I dunno what that means sorry. Noob to muscle cars. Is the ratio about the diff? I know it's only the right rear wheel that spins when it does. I've got Pirelli p6000 tires on 17" rims. Rear right is ruined already... 50 feet with advance trak off. Only about 20 with it on... Real easy to kick the rear end out.. accidentally...
Yes lower gear ratio. What's your rpms at 70 mph. Do you have a smart phone with GPS?
Midnight2012 is offline   Reply With Quote
Old 08-08-2013, 01:39 AM   #41
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Yup. An HTC one. What do I do bro?
romeshs1983 is offline   Reply With Quote
Old 08-08-2013, 06:00 AM   #42
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
If you or no one else (previous owner) did not change the rear gearing, then there should be a code on the sticker at the door jamb I think.

It used to be this way with the Ford trucks; I don't have my Mustang today, but I think there's a code for the axle as it left the factory. This code can translate to the gear ratio.

Or, see your nearest Ford dealership parts department. Give them your VIN number, and they can check as well.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 08-08-2013, 08:39 AM   #43
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by romeshs1983 View Post
Yup. An HTC one. What do I do bro?
Download an app called car performance. It's free. It will track your speed and is very accurate doing so.

See if it matches your speedometer.
Midnight2012 is offline   Reply With Quote
Old 08-09-2013, 10:27 PM   #44
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Hi again guys.. getting the spark plugs changed today. Will update if there's a change. Motorcraft plugs r ok I hope.. also planning to get a stock exhaust off a 5.0 gt put on. I hope it's not a bad idea. Any suggestions?

---------- Post added at 07:27 AM ---------- Previous post was at 07:26 AM ----------

Dual exhausts
romeshs1983 is offline   Reply With Quote
Old 08-10-2013, 05:01 AM   #45
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
This is what the obd 2 report says after plug change

Mode $06 report generated by Torque for Android
================================================

Vehicle VIN: Not present
Vehicle Manufacturer: Unknown
Vehicle Calibration ID: Not present
----
MID:$31 TID:$24
- EGR Monitor Bank 1
Max: 574.19A Min: 225.44A
Test result value: 655.20001A
FAIL
----
MID:$3a TID:$80
- EVAP Monitor (cap off)
Test incomplete or dependant test failed
--
MID:$3a TID:$81
- EVAP Monitor (cap off)
Test incomplete or dependant test failed
--
MID:$3a TID:$82
- EVAP Monitor (cap off)
Test incomplete or dependant test failed
----
MID:$3c TID:$80
- EVAP Monitor (0.040")
Test incomplete or dependant test failed
--
MID:$41 TID:$24
- O2 Heater Monitor Bank 1 - Sensor 1
Max: 574.17999A Min: 61.6A
Test result value: 655.20001A
FAIL
----
MID:$50 TID:$1d
- O2 Heater Monitor Bank 4 - Sensor 4
Max: 0ms Min: 0ms
Test result value: 48,000ms
FAIL
----
romeshs1983 is offline   Reply With Quote
Old 08-10-2013, 12:52 PM   #46
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
Say What ??????????????????/??????????????????????????

????????????????????????????????????????????

All of that for a spark plug change. DUH!

Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 08-10-2013, 01:21 PM   #47
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Umm.. no. That's the report the obd2 sensor gave me. I didn't post it before... Just that the spark plug change, was before i got the report...
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 01:16 AM   #48
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Can anyone make sense of the failed tests?
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 09:22 AM   #49
Registered Member
Regular
 
Join Date: Jun 2013
Location: Albuquerque
Region: New Mexico
Posts: 484
My guess, someone did an evap canister and egr delete. Pretty much removed the emissions related components. But I can't be sure with what you've shared thus far.

You may be chasing a ghost bud. You bought it used with little to no history. Just bad fuel economy? You've stated you put down 50ft of rubber and it runs 20ft with advancetrak on.

It really reads like you have a modified vehicle AND you don't "baby" it. Learn what that car should have been or should be...then identify what's changed. Make sure its in good shape to help you deduce what might need attention. Depending on what may have been done and your stated driving style, you may be getting expected fuel economy.
Six7One is offline   Reply With Quote
Old 08-11-2013, 09:52 AM   #50
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
About the rubber, since I have never owned a muscle car before. I thought it's normal.. about driving style, most of the time, I drive around 70.. I only floor it if someone irritates me.. which is not too common. The other thing is, most of the time when I gas it, the dash tells me I have about 320 miles before E, but I only get about 160 to 170...
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 10:09 AM   #51
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by romeshs1983 View Post
About the rubber, since I have never owned a muscle car before. I thought it's normal.. about driving style, most of the time, I drive around 70.. I only floor it if someone irritates me.. which is not too common. The other thing is, most of the time when I gas it, the dash tells me I have about 320 miles before E, but I only get about 160 to 170...
Still sounds like one problem is the gear ratio has been changed without a Speedometer reset.
Midnight2012 is offline   Reply With Quote
Old 08-11-2013, 10:18 AM   #52
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
The Speedo n the Garmin GPS I use pretty much matches until I go over 80.. then the GPS is about 3mph behind...
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 10:25 AM   #53
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Im not comparing but one my buddies has a 5.0, 2011 and he gets over 400 miles on a full tank.. and even my previous car, a ricer (shamefully) 1999 eclipse 2.0 with over 450hp, got better mpg.. almost twice what I'm getting on the pony.. thinking I shud have gone for. 2011 but the price was over 5000$ more..
Anyway, I wud be pretty happy if I can 250 to 300 per full tank...
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 10:29 AM   #54
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Click image for larger version

Name:	ForumRunner_20130811_192904.png
Views:	125
Size:	352.2 KB
ID:	123174



Click image for larger version

Name:	ForumRunner_20130811_192916.png
Views:	116
Size:	352.7 KB
ID:	123175



Click image for larger version

Name:	ForumRunner_20130811_192925.png
Views:	111
Size:	365.8 KB
ID:	123176
romeshs1983 is offline   Reply With Quote
Old 08-11-2013, 03:56 PM   #55
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by romeshs1983 View Post
15.5 mpg, 50 ft of rubber. Have you counted the cylinders in your car. Lol
Midnight2012 is offline   Reply With Quote
Old 08-11-2013, 04:02 PM   #56
Registered User
Newbie
 
Stangmanwisco69's Avatar
 
Join Date: Aug 2013
Location: Milwaukee
Region: Wisconsin
Posts: 3
What compression is it? Try 87 or 89 octane. Unless you have 10 to 1 compression or more or you have a tune 93 won't work for you.... The higher the compression the higher octane you need....
Stangmanwisco69 is offline   Reply With Quote
Old 08-12-2013, 05:23 AM   #57
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Where did this car come from? Do you have access to CarFax? See if you have a way to trace the previous ownership. In the states, we can run the VIN within a state, and find the previous owner.

If you have a way of doing this, then you can find the previous owner and talk with them to discover what mods have been performed on this Mustang.

Something is very strange with this setup. I have a 93 tune, and do not think I can lay a 50 foot "track". Which is a good thing, as I paid a good chunk of cash for my new tires.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 08-12-2013, 05:49 AM   #58
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
The choices for gas are only 95 and 98 octane. Don't have anything lower here...

---------- Post added at 02:48 PM ---------- Previous post was at 02:45 PM ----------

I spoke to the owner when I bought it. She bought it from the ford dealer her brand new. And she says nothing other than service has been done. About the rubber, it only burns out the right rear.. not both... Thinking of taking apart the TB and having a look.. maybe it's clogged or something? Checked everything else I can think of.. maf sensor seems fine too. As per torque n obd 2. Sensor I've got... Gonna run it on a pc today and see if it throws any codes.

---------- Post added at 02:49 PM ---------- Previous post was at 02:48 PM ----------

Also, the car beeps every once in a while. 3 beeps together, 3 times... About every half hour or so...
romeshs1983 is offline   Reply With Quote
Old 08-12-2013, 08:41 AM   #59
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by bucko View Post
Where did this car come from? Do you have access to CarFax? See if you have a way to trace the previous ownership. In the states, we can run the VIN within a state, and find the previous owner.

If you have a way of doing this, then you can find the previous owner and talk with them to discover what mods have been performed on this Mustang.

Something is very strange with this setup. I have a 93 tune, and do not think I can lay a 50 foot "track". Which is a good thing, as I paid a good chunk of cash for my new tires.
Maybe there's so much oil in Dubai it's all over the roads.
Midnight2012 is offline   Reply With Quote
Old 08-12-2013, 09:10 AM   #60
Registered Member
Regular
 
Join Date: Jun 2013
Location: Albuquerque
Region: New Mexico
Posts: 484
Quote:
Originally Posted by romeshs1983 View Post
The choices for gas are only 95 and 98 octane. Don't have anything lower here...

---------- Post added at 02:48 PM ---------- Previous post was at 02:45 PM ----------

I spoke to the owner when I bought it. She bought it from the ford dealer her brand new. And she says nothing other than service has been done. About the rubber, it only burns out the right rear.. not both... Thinking of taking apart the TB and having a look.. maybe it's clogged or something? Checked everything else I can think of.. maf sensor seems fine too. As per torque n obd 2. Sensor I've got... Gonna run it on a pc today and see if it throws any codes.

---------- Post added at 02:49 PM ---------- Previous post was at 02:48 PM ----------

Also, the car beeps every once in a while. 3 beeps together, 3 times... About every half hour or so...
And the list just keeps growing...
Not trying to scare you off or anything, but maybe these folks may help you out? When I first got into airplanes, I sought out a local club.
https://www.facebook.com/pages/Musta...06758286025363
Or these folks
Dubai Mustang Club
Six7One is offline   Reply With Quote
Old 08-18-2013, 12:14 PM   #61
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Hi Ya'll. Ive noticed that if the coolant in the radiator/reservoir is full or rather not empty, the mpg seems to be better. Although the car has never overheated.. could the water thing affect mpg by a huge amount? Like a drop or gain of about 5mpg??
romeshs1983 is offline   Reply With Quote
Old 08-18-2013, 03:46 PM   #62
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by romeshs1983 View Post
Hi Ya'll. Ive noticed that if the coolant in the radiator/reservoir is full or rather not empty, the mpg seems to be better. Although the car has never overheated.. could the water thing affect mpg by a huge amount? Like a drop or gain of about 5mpg??
No
Midnight2012 is offline   Reply With Quote
Old 08-19-2013, 12:28 AM   #63
Registered Member
Regular
 
crashkid500's Avatar
 
Join Date: Feb 2013
Location: little neck, ny
Region: New York
Posts: 78
Not sure wut ur ptoblem may be but i also have a 2010 v6 mustang and i use to get very bad mpg like urs 10mpg even 9mpg one time. My car is modified though. I got a 8.8 rear axle with 3.73 gears and my gas has seemed to improve alot after i retuned it. Even before the install i got a new 93 octane tune an the mpg went up alot. Try getting a performance tune for ur octane. Sometimes it seems asthough the car doesnt respond well to a really high octane without a tune. My mpg is around 15-19mpg now. If i floor it, it will quickly go down to like 12-13 lol but it goes back up. Anyways i really think a tune would help. It helped me alot. When i got the car it used 87 octane an the mpg was horrible i didnt really kno why and i didnt have the money to find out so im happy its a little bit better now. Are 2010 v6s only get around 17mpg ar peak around town if u drive like a grandma lolso if ur around there then its ok. But if ur still at 10 thats bad. Hope u find out wuts wrong!
crashkid500 is offline   Reply With Quote
Old 08-19-2013, 01:46 AM   #64
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Thanks bro.. will try getting a tune done... And will post the results soon..
romeshs1983 is offline   Reply With Quote
Old 08-19-2013, 07:20 AM   #65
Registered Member
Regular
 
Join Date: Jul 2013
Location: Chicago
Region: Illinois
Posts: 83
Quote:
Originally Posted by Midnight2012 View Post
Maybe there's so much oil in Dubai it's all over the roads.
Ha!
kutch is offline   Reply With Quote
Old 10-12-2013, 03:04 PM   #66
Registered Member
Regular
 
romeshs1983's Avatar
 
Join Date: Aug 2013
Location: dubai
Region: Asia
Posts: 59
Hi Guys .. further to my previous posts,

the MPG has been reducing with every tank i fill! now i get about 250kms or less per tank.. i changed the air filter with motorcraft filter, changed the plugs with motorcraft OEM ones, changed oil WITH MOTORCRAFT, Thermostat valve was stuck so changed that, cleaned the MAF sensor, did damn near everything i can think of.. bought an OBD11 bluetooth device to check on codes and nothing.. took it for emmision testing thinking i must be burning gas like hell and turns out im more close to perfect on emissions on the mustang than i am on my Brand new lancer.. even though Gas is considered cheap here, its still driving me crazy! oh and also ran STP injector cleaner about twice....
friend suggested getting the FUEL map checked/ ecu remapped but one or 2 places i checked are quoting upwards of 2500k! cant afford that.. anyone know of a solution to this? DIY if possible coz im pretty good at that.. (used to tinker around on my previous weekend car - 1999 eclipse2.0T)
romeshs1983 is offline   Reply With Quote
Old 10-13-2013, 07:46 AM   #67
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
I think you need to change gas stations or something.

If the car was running rich it would pour out black exhaust smoke.
Find some other 2010 V6 Mustang owners and see what they are getting.
I know it is probably very hot there and cars don't ever get the better mileage when over 100 Degrees out. My Harley was getting 45/50 MPG until I went to Mexico. It dropped down to 15/20 MPG because of the crap gas and the over 100 degree temperature.
Also, If you drive like my friend Shari ( Like a speed demon) you will never get good MPG.
Heat plus crap gas plus flooring it all the time ===== lousy MPG.

Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 10-13-2013, 09:28 AM   #68
Registered Member
Regular
 
Midnight2012's Avatar
 
Join Date: Sep 2012
Location: So Cal
Region: California
Posts: 790
Quote:
Originally Posted by ronnie948 View Post
If the car was running rich it would pour out black exhaust smoke. Find some other 2010 V6 Mustang owners and see what they are getting. I know it is probably very hot there and cars don't ever get the better mileage when over 100 Degrees out. My Harley was getting 45/50 MPG until I went to Mexico. It dropped down to 15/20 MPG because of the crap gas and the over 100 degree temperature. Also, If you drive like my friend Shari ( Like a speed demon) you will never get good MPG. Heat plus crap gas plus flooring it all the time ===== lousy MPG. Ronnie

I find that curious as summer 2012 we had a heat wave here. 110 many days. My mpg didn't change at all.
Midnight2012 is offline   Reply With Quote
Old 10-13-2013, 10:22 AM   #69
Registered Member
Regular
 
crashkid500's Avatar
 
Join Date: Feb 2013
Location: little neck, ny
Region: New York
Posts: 78
I got a 2010 an im gettin about 13.5 mpg now i use to get 10mpg before. It comes and goes so im not sure why.
crashkid500 is offline   Reply With Quote
Old 10-13-2013, 10:30 AM   #70
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
OP is in Dubai at 120/125 degrees all day and night

He may be getting his gas from a station that has crap gas without the additives we get here in the USA for the summer. Like I said, He stated he drives aggressively and you know that uses more gas. His engine is a 2010 and not the 3.7. He may be getting the same MPG other early V6 Mustangs are getting. We will never know because we are not there. I was at one time. (NEVER AGAIN) Way toooo HOT for me.

As you probably already know. Our 2012 3.7 V6 engines are not the same as the one's they had in 2010. The heat or cold or different elevation does not effect our performance at all.

Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.