Burning Smell? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-08-2013, 05:36 PM   #1
Registered Member
Regular
 
TheBlackStang's Avatar
 
Join Date: Sep 2013
Location: Central
Region: Texas
Posts: 91
Burning Smell?

Hello again everyone
When driving on the highway (75-80 mph) everything is fine, however, if I floor it to pass someone I get a "burning" smell from the front of the car. It doesn't smell like gasoline or anything in particular.
I expressed my concerns at my local dealer when I got the oil changed and they said that they didn't see anything but to keep an eye on it.
So have any of you guys experienced anything similar or have any idea what it might be?
TheBlackStang is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2013, 05:43 PM   #2
Registered Member
Regular
 
Jmusc16's Avatar
 
Join Date: May 2012
Location: Buffalo, NY
Region: New York
Posts: 39
I have that same smell no clue
Jmusc16 is offline   Reply With Quote
Old 10-08-2013, 05:44 PM   #3
Registered Member
Regular
 
mark_ash0426's Avatar
 
Join Date: Sep 2013
Location: California
Region: California
Posts: 443
This happens to mine but when i floor it and then when i get home and park it i can smell that burning odor. I don't pay too much attention because i figure it's just from straining my engine so much at times
mark_ash0426 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2013, 07:11 PM   #4
Registered Member
Regular
 
alrefire's Avatar
 
Join Date: Jul 2012
Region: Alabama
Posts: 3,713
That happened to me too...
but that's when I pushed it really hard.
REALLY REALLY HARD!!!
It used to do it a lot (mainly when the car was breaking in)
I'm at 12k now, and it never happens when I floor it.
unless i take it as hard as I did yesterday
alrefire is offline   Reply With Quote
Old 10-08-2013, 07:20 PM   #5
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
It's the oil going into the engine from the valve hose thing on the passenger side. Very hard and aggressive driving did that to mine. The solution is to get the oil catch can and the problem stops. Also if auto it's the transmission kinda burning a little lol just my experience.
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 10-08-2013, 11:58 PM   #6
Registered Member
Regular
 
Join Date: Jun 2013
Location: Albuquerque
Region: New Mexico
Posts: 484
Oil catch can has not resolved it. It smells like burned oil/charcoal. I can get the smell EVERY SINGLE TIME that I accelerate hard to pass or merge.
Six7One is offline   Reply With Quote
Old 10-09-2013, 08:30 AM   #7
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
Mine don't have any smell at all

I'm wondering if you may have a slight exhaust leak. It will be fine around town but when you are up in the high RPM the extra pressure allows the exhaust to escape at a connecting point causing the smell you describe.

Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 10-09-2013, 08:33 AM   #8
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Quote:
Originally Posted by Six7One View Post
Oil catch can has not resolved it. It smells like burned oil/charcoal. I can get the smell EVERY SINGLE TIME that I accelerate hard to pass or merge.
If you're auto it's the tranny. I cruised my car at 100 and then kept redlining it to pass people. It had this funky smell. The oil catch can resolved it but I noticed also my tranny shifted like absolute slush when I was doing that.
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 10-09-2013, 08:53 AM   #9
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
Your transmission has a problem.

If your having that problem something is very wrong. The transmissions in our 3.7 Mustangs are the exact same one's they use in the GT's, And The Roush stage three also uses this automatic if you order it. It is a very sturdy transmission and really hard to mess up.

You may have hurt it when you had your accident a while back.

Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 10-09-2013, 10:22 AM   #10
Registered Member
Regular
 
Join Date: Jun 2013
Location: Albuquerque
Region: New Mexico
Posts: 484
Quote:
Originally Posted by ronnie948 View Post
I'm wondering if you may have a slight exhaust leak. It will be fine around town but when you are up in the high RPM the extra pressure allows the exhaust to escape at a connecting point causing the smell you describe.

Ronnie
I think that may be it. Explorers had a similar issue
Six7One is offline   Reply With Quote
Old 10-09-2013, 11:20 AM   #11
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,019
OP, is your car new? Often new (< 6 months) cars will smell when burning off sealants/greases/paint from assembly.
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 10-09-2013, 11:33 AM   #12
Registered Member
Regular
 
FastFord13's Avatar
 
Join Date: Apr 2013
Location: Montreal
Region: Canada
Posts: 4,259
This is true as mine had a hairdryer smell to it when she was new. It has completely gone now (15000km) later but the first 8-10 it would almost always happen when I'd push her.
FastFord13 is offline   Reply With Quote
Old 10-09-2013, 11:40 AM   #13
Registered Member
Regular
 
TheBlackStang's Avatar
 
Join Date: Sep 2013
Location: Central
Region: Texas
Posts: 91
Wow I definitely wasn't expecting this many replies! I'm glad that I'm not the only one that's experiencing it
I didn't consider it being oil haha
It definitely only happens when I push it hard, and it usually goes away within a minute or two.
My car is fairly new. I got it at the end of May, so it's not brand new but it's not old
TheBlackStang is offline   Reply With Quote
Old 10-09-2013, 07:47 PM   #14
Registered Member
Regular
 
CandyRed11's Avatar
 
Join Date: Oct 2013
Location: Indianapolis
Region: Indiana
Posts: 95
As another data point: I've noticed it too when I really get on it but I have a manual so it supports the theory that it isn't the transmission.
CandyRed11 is offline   Reply With Quote
Old 10-09-2013, 07:55 PM   #15
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
It has to be oil or something getting into the top manifold. Mine stopped mainly when I got the oil catch can. Which is 1/2 full and I've only had it for 2 weeks!
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 10-09-2013, 10:43 PM   #16
Registered Member
Regular
 
TheBlackStang's Avatar
 
Join Date: Sep 2013
Location: Central
Region: Texas
Posts: 91
Quote:
Originally Posted by CandyRed11 View Post
As another data point: I've noticed it too when I really get on it but I have a manual so it supports the theory that it isn't the transmission.
Also good to know it's not my transmission haha
TheBlackStang is offline   Reply With Quote
Old 10-10-2013, 05:31 AM   #17
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
I have the 3.7 V6, and automatic transmission. I drive 300 to 450 miles a week on my Mustang, and I have no oil smelling issues. I drive at constant highway speeds, and "push it" to pass vehicles. Again, no oil or other smells when I do this. I too have a catch can, but even before that was installed, I did not experience these smells.

I'd inspect the area around the oil filter for spills. That filter likes to spill off oil when it's removed (you know this if you do your own oil changes). Perhaps there's some oil on the frame, or engine in this area that's burning a bit when the engine is warm.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 10-10-2013, 06:41 AM   #18
Registered Member
Regular
 
Taylorations's Avatar
 
Join Date: Oct 2012
Region: Arkansas
Posts: 333
I used to get this smell, but mine stopped at around 10k miles. I too thought it was oil, but it doesn't do it anymore so I believe that it's the sealants and whatnot from when it's new.
Taylorations is offline   Reply With Quote
Old 10-10-2013, 08:19 AM   #19
Registered Member
Regular
 
Join Date: Sep 2013
Location: Athens, GA
Region: Georgia
Posts: 20
Burning coolant makes a weird smell, so does transmission fluid...
01LaserCobra is offline   Reply With Quote
Old 10-10-2013, 08:50 AM   #20
Registered Member
Regular
 
Whitelightning's Avatar
 
Join Date: Apr 2012
Location: Tuscaloosa
Region: Alabama
Posts: 3,463
Well also check your coolant guys, when I checked mine last after this little incident, my top reservoir was bone dry and it took 1 whole bottle to fill it back up. Now my car runs correctly and also no burning smell. It wasn't oil, but to me was a weird material like burning but with all that I did at the same time; the new modifications
__________________
Any Speed over 55 mph may kill you... that's why i drive 60
Whitelightning is offline   Reply With Quote
Old 10-10-2013, 10:38 AM   #21
Registered Member
Regular
 
TheBlackStang's Avatar
 
Join Date: Sep 2013
Location: Central
Region: Texas
Posts: 91
It's not leaking oil because the smell started before the first oil change
Hmm... I didn't think about it being coolant. I will check it when I get the chance

Thank you everyone for the advice!
TheBlackStang is offline   Reply With Quote
Old 10-10-2013, 10:43 AM   #22
Registered Member
Regular
 
ironsurvivor's Avatar
 
Join Date: Jun 2013
Location: Norman
Region: Oklahoma
Posts: 332
In noticed it for a while on mine even with the oil catch can. I just changed my oil at 5000 miles and im at 5500 right now and i havent noticed it at all under hard acceleration.
__________________
Stark 30 huper optik tint, jlt oil separator, mmd window louvers, airaid cold air intake.
ironsurvivor is offline   Reply With Quote
Old 10-10-2013, 11:24 AM   #23
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,019
Mr White, w/o insulting keep an eye on it...it's going somewhere.
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Old 10-10-2013, 01:13 PM   #24
Registered Member
Regular
 
alrefire's Avatar
 
Join Date: Jul 2012
Region: Alabama
Posts: 3,713
Quote:
Originally Posted by Whitelightning View Post
Well also check your coolant guys, when I checked mine last after this little incident, my top reservoir was bone dry and it took 1 whole bottle to fill it back up. Now my car runs correctly and also no burning smell. It wasn't oil, but to me was a weird material like burning but with all that I did at the same time; the new modifications
Your welcome...,
alrefire is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:49 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.