Suspension issue - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-17-2014, 03:48 PM   #1
Registered Member
Regular
 
13 stang22's Avatar
 
Join Date: Feb 2013
Location: fort worth
Region: Texas
Posts: 1,006
Suspension issue

Lately, my springs/shocks have been making an annoying squeezing sound along with my control arms making a rattling sound. It feels like pieces and karts are loose but when I check under the car, everything seems fine. Any ideas or reasons why this may be and how I can fix this?
13 stang22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2014, 04:03 PM   #2
ME Bloodhound
Staff
 
Soccerluvr4's Avatar
 
Join Date: Feb 2012
Location: Sacramento/Bay Area
Region: California
Posts: 14,672
Did you check all the bushings?
__________________

Bullitt build paused pending graduation

HID end all thread
Soccerluvr4 is offline   Reply With Quote
Old 02-17-2014, 04:45 PM   #3
Registered Member
Regular
 
13 stang22's Avatar
 
Join Date: Feb 2013
Location: fort worth
Region: Texas
Posts: 1,006
I did. I have to take my car in to my friends shop cause it's making a weird noise in the engine bay so I'll have them look at it but it's so annoying. every single bump and sometimes on turns it squeaks
13 stang22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2014, 06:34 PM   #4
Registered Member
Regular
 
13 stang22's Avatar
 
Join Date: Feb 2013
Location: fort worth
Region: Texas
Posts: 1,006
Anyone got any other ideas?
13 stang22 is offline   Reply With Quote
Old 02-17-2014, 06:43 PM   #5
Registered Member
Regular
 
colemaneric's Avatar
 
Join Date: Jun 2013
Location: Austin
Region: Texas
Posts: 196
I had a same sort of problem turns out I had a cracked lower control arm
colemaneric is offline   Reply With Quote
Old 02-17-2014, 10:27 PM   #6
Registered Member
Regular
 
silvrbullet2012's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 622
Most likely it's your front control arms. Mine was replaced under warranty.y rear sway bar bushings went out as well and I just replaced it with a steeda one.
silvrbullet2012 is offline   Reply With Quote
Old 02-17-2014, 10:32 PM   #7
Registered Member
Regular
 
13 stang22's Avatar
 
Join Date: Feb 2013
Location: fort worth
Region: Texas
Posts: 1,006
hmm...I see. I hope it's not something serious
13 stang22 is offline   Reply With Quote
Old 02-18-2014, 02:08 PM   #8
Registered Member
Regular
 
sunnytan06's Avatar
 
Join Date: Jan 2014
Posts: 233
I have the sound too when I go over bumps. Only the front left end tho.
sunnytan06 is offline   Reply With Quote
Old 02-18-2014, 09:08 PM   #9
Registered Member
Regular
 
13 stang22's Avatar
 
Join Date: Feb 2013
Location: fort worth
Region: Texas
Posts: 1,006
what do you think it is?
13 stang22 is offline   Reply With Quote
Old 02-18-2014, 09:16 PM   #10
Registered Member
Regular
 
AJcruz1's Avatar
 
Join Date: Feb 2014
Location: OKC
Region: Oklahoma
Posts: 503
Best to get it on a rack or jack stands and put pressure on each corner to see if you can find it. I had some rattling and found out it was one of the lock nuts on my BMR panhard bar was loose.
AJcruz1 is offline   Reply With Quote
Old 02-19-2014, 10:48 AM   #11
Registered Member
Regular
 
sunnytan06's Avatar
 
Join Date: Jan 2014
Posts: 233
At first I thought it was just a break in stage. But it continues till now that I already have almost 5k miles. So I think probably is the spring or shock. Not really a big deal for normal driving tho. Without the sound. The performance is balance
sunnytan06 is offline   Reply With Quote
Old 02-19-2014, 11:35 AM   #12
Registered Member
Regular
 
sunnytan06's Avatar
 
Join Date: Jan 2014
Posts: 233
At first I thought it was just a break in stage. But it continues till now that I already have almost 5k miles. So I think probably is the spring or shock. Not really a big deal for normal driving tho. Without the sound. The performance is balance
sunnytan06 is offline   Reply With Quote
Old 02-20-2014, 12:16 AM   #13
Registered Member
Regular
 
mpachal's Avatar
 
Join Date: Sep 2012
Region: Canada
Posts: 22
I had the squeak. After three times at the dealer they finally heard it ( would not happen in wet weather) and they replaced the rear sway bar bushings. Also had a bang sound in the front over speed bumps. They replaced the lower control arms but it still happens.
mpachal is offline   Reply With Quote
Old 02-20-2014, 07:35 AM   #14
Registered Member
Regular
 
ArtU's Avatar
 
Join Date: Dec 2012
Location: NW Ohio
Region: Ohio
Posts: 1,067
Quote:
Originally Posted by sunnytan06 View Post
I have the sound too when I go over bumps. Only the front left end tho.
This exact issue is a TSB Ford has but when I had my dealer look at it, they said it would only cover 2011-2012; that 2013 did not have the issue. Its strarting to look like 2013 does, as mine will only do it if I go over a speed bump with one tire avoiding the bump and the other over the bump. [squeek]

Both over the bump, no noise. The 2011-2012 resolution was to replace the LCAs with new ones. It seems the bushing in the original is melting somewhat from what I heard others say.
ArtU is offline   Reply With Quote
Old 02-22-2014, 01:50 AM   #15
Registered User
Newbie
 
Join Date: Oct 2013
Location: socal
Region: California
Posts: 6
Quote:
Originally Posted by ArtU View Post
This exact issue is a TSB Ford has but when I had my dealer look at it, they said it would only cover 2011-2012; that 2013 did not have the issue. Its strarting to look like 2013 does, as mine will only do it if I go over a speed bump with one tire avoiding the bump and the other over the bump. [squeek]

Both over the bump, no noise. The 2011-2012 resolution was to replace the LCAs with new ones. It seems the bushing in the original is melting somewhat from what I heard others say.
Interesting. My '14 makes that noise. I have 5k miles on mine. I'll take it to ford and see what they say.
jrexer is offline   Reply With Quote
Old 02-22-2014, 07:18 AM   #16
Registered Member
Regular
 
cmegnin1's Avatar
 
Join Date: May 2013
Location: New Providence
Region: New Jersey
Posts: 151
My rear passenger side squeaked when. I hit bumps and the car moved laterally. I replaced the lower control arms with new bushings, old bushings were shot. Squeak went away and car hooks up better now. Also replaced the old leaking rear shocks with Bilsteins. The live rear axle which I despise, is under much better control now.
cmegnin1 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Suspension MythlinMasterdo General Mustang Discussion 4 01-26-2014 02:17 PM
Suspension Write Ups ! Slow4V 1996-2004 Mustang GT 8 04-15-2013 09:51 PM
NMRA "Super 'Stang" rules and regulations rebeltx At the Track 4 03-06-2013 12:02 PM
Stearing Issue... lConnerl 1996-2004 Mustang GT 9 01-12-2012 02:34 PM
EVAP issue plaguing Mustangs! fluffyGT06 General Mustang Discussion 2 12-01-2011 12:56 PM

» Like Us On Facebook



12:16 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.