License plate bulbs. - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-12-2014, 12:56 PM   #1
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
License plate bulbs.

I just uninstalled my factory license plate lights with the lights below and they worked for a little and now they do not work. Then I put the factory ones in again and they no longer work. Can I get some advice?
WipeYourEyes is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-12-2014, 12:56 PM   #2
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
Quote:
Originally Posted by WipeYourEyes View Post
I just uninstalled my factory license plate lights with the lights below and they worked for a little and now they do not work. Then I put the factory ones in again and they no longer work. Can I get some advice?

Click image for larger version

Name:	ImageUploadedByMustang Evolution1402595805.442443.jpg
Views:	99
Size:	792.2 KB
ID:	159112 new lights
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 01:02 PM   #3
Registered Member
Regular
 
Join Date: Nov 2013
Location: College Station
Region: Texas
Posts: 130
You probably broke one of the posts that touch the ends of the bulb, so it's not getting contact. I did this.. The thing that holds the bulbs is a huge piece of junk that breaks far too easily. More than likely you'll have to buy a new assembly from ford which is about $30, but don't worry im sure they'll have them in stock..my dealer did because i'm assuming they sell a ton of these replacements because they are junk to begin with and alot of people break them switching bulbs.
__________________
2013 DIB 3.7-Pypes Pype Bomb black axlebacks, BBK shorty headers, Bama & MPT tunes, Steeda Ultralite Springs, J&M steel adj. panhard, Roush hood scoop, Street scene Gen 2 chin spoiler painted to match, Custom billet grille, painted side mirror covers, 20" gloss black AMR wheels wrapped in Nitto Motivos.

Follow me on instagram @that_deep_impact
Deep_Impact is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-12-2014, 01:05 PM   #4
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
Quote:
Originally Posted by Deep_Impact View Post
You probably broke one of the posts that touch the ends of the bulb, so it's not getting contact. I did this.. The thing that holds the bulbs is a huge piece of junk that breaks far too easily. More than likely you'll have to buy a new assembly from ford which is about $30, but don't worry im sure they'll have them in stock..my dealer did because i'm assuming they sell a ton of these replacements because they are junk to begin with and alot of people break them switching bulbs.

Nope. They look fine to me. Click image for larger version

Name:	ImageUploadedByMustang Evolution1402596335.536968.jpg
Views:	86
Size:	465.4 KB
ID:	159113
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 01:05 PM   #5
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
I would first check the fuse.
rringler is offline   Reply With Quote
Old 06-12-2014, 01:06 PM   #6
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
If I blew a fuse replacing a light bulb I'll be pissed off...
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 01:08 PM   #7
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
Lol. I would too, just would be the quickest and easiest to check. I doubt that it is but it's always better to check the easiest things first.
rringler is offline   Reply With Quote
Old 06-12-2014, 01:16 PM   #8
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
If It is a fuse would I be safe trying those same bulbs again?
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 01:22 PM   #9
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
I myself would just put the factory ones back in for a few days and see what happens. If it seems ok try the new ones again. Like the other guy said it is probably the posts but just worth checking the fuse anyway.
rringler is offline   Reply With Quote
Old 06-12-2014, 01:26 PM   #10
Registered Member

Regular
 
Socal Stangman's Avatar
 
Join Date: Mar 2014
Location: Temecula Ca.
Region: California
Posts: 1,872
Quote:
Originally Posted by rringler View Post
I myself would just put the factory ones back in for a few days and see what happens. If it seems ok try the new ones again. Like the other guy said it is probably the posts but just worth checking the fuse anyway.

He said the stocks dont work either.
Socal Stangman is offline   Reply With Quote
Old 06-12-2014, 01:29 PM   #11
Registered Member

Regular
 
Socal Stangman's Avatar
 
Join Date: Mar 2014
Location: Temecula Ca.
Region: California
Posts: 1,872
This is a weird issue. Check some of your other lights (trunk and visor). Do they work? If not it will be a fuse for sure. If they work try to find some thing that isnt working, and try every thing. The way manufacturers do fuses is some times strange.
Socal Stangman is offline   Reply With Quote
Old 06-12-2014, 01:30 PM   #12
Site Sponsor
 
Join Date: May 2014
Location: Malvern, PA
Region: Pennsylvania
Posts: 2,510
Quote:
Originally Posted by rringler View Post
I would first check the fuse.
OP-Sounding like it could be a fuse! I would head down to an Autozone/PepBoys and get that swapped out!

-Alex
__________________
Alex Lazarus | AmericanMuscle.com
Toll Free: 1-866-363-4591
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A SUPERCHARGED MUSTANG & 2017 RAPTOR!
Free Same-Day Shipping!
AMAlexLazarus is offline   Reply With Quote
Old 06-12-2014, 01:30 PM   #13
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
Thanks guys getting it looked at now
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 01:34 PM   #14
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
Quote:
Originally Posted by Socal Stangman View Post
He said the stocks dont work either.

Yeah I saw that. He was asking if it was the fuse. So if it was the fuse then no lights would work there regardless. So if he replaced the fuse then the factory ones should work again. Either way just hope it's an easy fix for the OP.
rringler is offline   Reply With Quote
Old 06-12-2014, 02:30 PM   #15
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
It was in fact a fuse. My friend looked at it and gave me a spare one out of his broken down car. They are now functioning and looking good!
WipeYourEyes is offline   Reply With Quote
Old 06-12-2014, 02:31 PM   #16
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
Quote:
Originally Posted by WipeYourEyes View Post
It was in fact a fuse. My friend looked at it and gave me a spare one out of his broken down car. They are now functioning and looking good!

Great news! Glad to hear that. You did put the new ones back in right?
rringler is offline   Reply With Quote
Old 06-12-2014, 04:07 PM   #17
Registered Member
Regular
 
smurf stang's Avatar
 
Join Date: Mar 2014
Location: Miami
Region: Florida
Posts: 1,341
The new or old bulbs?


And who's bulbs are those?
__________________
2016 VW GTI 2.0 Turbo

1989 Sonic Blue LX Coupe, 349 ci, TW heads, TFS Track Heat Intake, 75mm Accufab TB, 80mm ProM, 30 lb. inj, TKO, 3.73, 31 spline w/ TruTrac, MAC 1-5/8" LT headers w/ H pipe, Flowmaster, electric fan Moates QH
391 rwhp & 424 rwtq...Mustang Dyno 11.5@122mph
smurf stang is offline   Reply With Quote
Old 06-13-2014, 10:15 AM   #18
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
So the blue LEDs are illegal in my
State 😔 I cant use them even know they look sick! If you guys wanna buy them off me I'll sell them cheap. Haha Click image for larger version

Name:	ImageUploadedByMustang Evolution1402672511.887598.jpg
Views:	165
Size:	662.2 KB
ID:	159172
WipeYourEyes is offline   Reply With Quote
Old 06-13-2014, 10:25 AM   #19
Registered Member

Regular
 
Socal Stangman's Avatar
 
Join Date: Mar 2014
Location: Temecula Ca.
Region: California
Posts: 1,872
Quote:
Originally Posted by WipeYourEyes View Post
So the blue LEDs are illegal in my
State 😔 I cant use them even know they look sick! If you guys wanna buy them off me I'll sell them cheap. Haha Attachment 159172

External blue and reds lights are pretty much illegal in all states.
Socal Stangman is offline   Reply With Quote
Old 06-13-2014, 10:36 AM   #20
Registered Member
Regular
 
rringler's Avatar
 
Join Date: Jan 2014
Location: Estero, FL
Region: Florida
Posts: 402
Quote:
Originally Posted by Socal Stangman View Post
External blue and reds lights are pretty much illegal in all states.

Yup, that's unfortunate because they do look nice. OP, you should get the ones on AM. Made a nice difference from the factory ones.
Click image for larger version

Name:	ImageUploadedByMustang Evolution1402673738.587357.jpg
Views:	100
Size:	787.3 KB
ID:	159173
rringler is offline   Reply With Quote
Old 06-13-2014, 10:55 AM   #21
Registered Member
Regular
 
WipeYourEyes's Avatar
 
Join Date: May 2014
Location: Painesville, Ohio
Posts: 47
I like those!
WipeYourEyes is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
License plate bulbs Tarheel8613 1996-2004 Mustang GT 7 02-01-2012 07:32 AM
License Plate Bama Matt Mustang Audio & Video 11 04-18-2006 03:40 PM
LMAO!! the best license plate ever Zim The Bar 16 02-20-2004 04:30 PM
license plate ideas?? Falcon The Bar 13 11-09-2003 09:33 PM
License plate Falcon The Bar 3 11-09-2003 12:34 PM

» Like Us On Facebook



05:25 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.