Funky smell coming from vents - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-25-2014, 03:34 PM   #1
Registered Member
Regular
 
StolenSinner09's Avatar
 
Join Date: May 2014
Location: Copperas Cove, TX
Posts: 99
Funky smell coming from vents

So pretty much the point being, I get a weird smell from my vents when I accelerate aggressively, like let's say, speed limit going from 55 to 75...or just flat out WOT. Smells like burnt hair to me.

Any ideas?
StolenSinner09 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-25-2014, 03:59 PM   #2
Registered Member
Regular
 
fknjulian's Avatar
 
Join Date: Mar 2014
Location: McAllen
Region: Texas
Posts: 113
Same happens to me when I step on it on the expressway. It leaves shorty after though. I think it's just the engine burning the fuel and the sudden change in speed and RPMs cause it so get that smell??


Sent from my iPhone using Mustang Evolution
fknjulian is offline   Reply With Quote
Old 07-25-2014, 04:05 PM   #3
Registered Member
Regular
 
Frozen Yettie's Avatar
 
Join Date: Jan 2014
Location: South East
Region: Texas
Posts: 191
What is your mileage?

I only had this problem for the first few months I've owned my stang. Once I put a couple thousand miles on it, it doesn't smell anymore.

All that I smell now is rubber from the tires
__________________
2014 Black Mustang 3.7L V6 Premium | 93Race MPT Tuned | Too many mods to list just check out my garage.
Frozen Yettie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-25-2014, 04:32 PM   #4
Registered Member
Regular
 
StolenSinner09's Avatar
 
Join Date: May 2014
Location: Copperas Cove, TX
Posts: 99
Quote:
Originally Posted by Frozen Yettie View Post
What is your mileage?



I only had this problem for the first few months I've owned my stang. Once I put a couple thousand miles on it, it doesn't smell anymore.



All that I smell now is rubber from the tires

29K

---------- Post added at 09:32 PM ---------- Previous post was at 09:31 PM ----------

Quote:
Originally Posted by Frozen Yettie View Post
All that I smell now is rubber from the tires

+1
StolenSinner09 is offline   Reply With Quote
Old 07-25-2014, 06:58 PM   #5
Registered Member
Regular
 
mikeygaga's Avatar
 
Join Date: Apr 2014
Location: Long Island
Region: New York
Posts: 556
Happens to me too. There was a thread a few months ago on this, it's normal. Something to do with burning off carbon build - up in your cats i think.
__________________
2016 GT- Lund tune, jlt intake, mbrp catback.
2014 3.7 - SOLD
mikeygaga is offline   Reply With Quote
Old 07-25-2014, 08:42 PM   #6
Registered Member
Regular
 
BlackPonyIHave's Avatar
 
Join Date: Oct 2013
Location: Mount Vernon
Region: Ohio
Posts: 125
I think Bigfoot climbed into your engine compartment and died...

4.6, K&N CAI tuned, torque bar, SLP Exhaust
__________________
4.6 engine,Ford Racing torque bar, diablo performance 93 octane tune, cold air intake with a K&N filter, SLP exhaust from axle back, 3.73 ford racing gears
BlackPonyIHave is offline   Reply With Quote
Old 07-25-2014, 09:05 PM   #7
Registered Member
Regular
 
Join Date: Jul 2014
Location: Midland
Region: Texas
Posts: 21
I get this all the time too
cameron43 is offline   Reply With Quote
Old 07-25-2014, 09:45 PM   #8
Registered Member
Regular
 
cmegnin1's Avatar
 
Join Date: May 2013
Location: New Providence
Region: New Jersey
Posts: 151
WTF is wrong with your cars. No smell on WOT. Just pure happiness and the natural testosterone smell. Lol


Sent from my iPad using Mustang Evolution
cmegnin1 is offline   Reply With Quote
Old 07-26-2014, 03:31 PM   #9
Registered Member
Regular
 
Join Date: Feb 2014
Location: 00
Region: Other
Posts: 1,198
Cats are what is smelling bad. I have 12k on mine and is starting not to smell as much


Sent from my iPhone using Mustang Evolution
Bigshow14 is offline   Reply With Quote
Old 07-27-2014, 05:34 PM   #10
Registered Member
Regular
 
StolenSinner09's Avatar
 
Join Date: May 2014
Location: Copperas Cove, TX
Posts: 99
Interesting
StolenSinner09 is offline   Reply With Quote
Old 07-27-2014, 10:33 PM   #11
Registered Member
Regular
 
Sakib's Avatar
 
Join Date: Aug 2013
Location: Bryan
Region: Texas
Posts: 813
This totally happened to me for the first time in owning my car for 3 years, yesterday morning. Car has 33K miles. I went WOT about 3 minutes after starting. Ironically, I went WOT to catch up to a 2015 Mustang GT that passed me as I was turning on to the main road, lol. Anyway, smelled exactly how you described. I tried to replicate it a few minutes later when entering the expressway, but I did not get it that time, and I haven't been able to get it back ever since. So, carbon buildup in the cats burning off is a possible explanation, I think.
Sakib is offline   Reply With Quote
Old 07-28-2014, 01:35 PM   #12
Registered Member
Regular
 
Join Date: Jan 2013
Location: miramar
Region: Florida
Posts: 153
this usually happenes when you buy a new car and you dont let it break in you just start going at it hard from the get go ... get your cats fixed ... by fixed i mean buy a xpipe with a high flow cats and the smell should go away forever !!!
dozer 13 is offline   Reply With Quote
Old 07-31-2014, 06:22 PM   #13
Registered Member
Regular
 
Sakib's Avatar
 
Join Date: Aug 2013
Location: Bryan
Region: Texas
Posts: 813
Quote:
Originally Posted by dozer 13 View Post
this usually happenes when you buy a new car and you dont let it break in you just start going at it hard from the get go ... get your cats fixed ... by fixed i mean buy a xpipe with a high flow cats and the smell should go away forever !!!
I think you're right because I indeed got a little impatient before 1,000 miles and went hard a couple times. I went on a long road trip the day after I bought it through these beautiful scenic drives, totally open roads, and it was just too tempting. Those of you who have also gotten the smell... does this explanation fit for you? And what exactly is the damage to the cats that happened in this case? What other damage might have happened due to going to hard before the break-in?
Sakib is offline   Reply With Quote
Old 09-05-2014, 08:16 PM   #14
Registered Member
Regular
 
powerwhee's Avatar
 
Join Date: Jan 2013
Location: SFV
Region: California
Posts: 350
That's incredibly not true. Just stupid.
powerwhee is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Smoke coming out of ac vents at high rpm Mustangfed 2011-2014 Mustang GT 15 01-06-2014 03:24 PM
To answer those water coming in the vents.. shunc01 Mustang Paint, Appearance & Detailing 1 03-31-2013 06:50 PM
Smoke coming from vents Mlp51284 2011-2014 V6 Mustang 4 05-21-2012 12:47 PM
Funky idle.. Thanks Seafoam? AgentOrange 1996-2004 Mustang GT 9 03-25-2012 06:57 PM
Wanting to change the look of the side vents BlkStang4Me Mustang Audio & Video 9 03-30-2004 11:59 PM

» Like Us On Facebook



03:41 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.