Dealer woes - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-04-2014, 03:06 PM   #1
Registered Member
Regular
 
ponie1992's Avatar
 
Join Date: Jul 2014
Location: Lexington
Region: South Carolina
Posts: 1,052
Dealer woes

Got my radio replaced today finally. Dealer never called when they got it. Took the service guy for a drive so he could hear the front suspension creaking sound and he did. Didn't happen every time and he said they couldn't recreate it in the shop and everything looked fine. They didnt fix it. Great... my warranty is up on the 18th.

Sent from my SCH-I545 using Mustang Evolution mobile app
__________________
Jeremy
2016 Ruby Red PP GT
ponie1992 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-04-2014, 03:42 PM   #2
Registered Member
Regular
 
Sgonza33's Avatar
 
Join Date: Aug 2014
Location: Lodi
Region: California
Posts: 52
I have the same creaking problem too. I've read that it's most likely bad lca bushings. Can you just ask them to replace them or do they have to physically be there when it creaks to fix it?
Sgonza33 is offline   Reply With Quote
Old 11-04-2014, 03:50 PM   #3
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
I've got that creaking/squeaking too, which reminds me I need to call the dealership if they have the LCA replacements already.
I have a 2014 and there's a tsb for the LCA, I don't know what year your stangs are though. You may want to check if there's a tsb on the LCAs if its not a '14.

You need to know the rules, to break the rules
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-04-2014, 03:54 PM   #4
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
Quote:
Originally Posted by Sgonza33 View Post
...Can you just ask them to replace them or do they have to physically be there when it creaks to fix it?
Good question. Not sure exactly but I'm guessing they have to hear the creak. Unless like I mentioned there's a tsb. If there is, print the tsb report so they won't be bsing you.

I found out there was a tsb for my LCAs, printed it out and told the service manager. He didn't have anyone check for the creaking since I had the tsb printed . Of course, he also checked if indeed there was a tsb on the LCAs.

You need to know the rules, to break the rules
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Old 11-04-2014, 04:00 PM   #5
Registered Member
Regular
 
Sgonza33's Avatar
 
Join Date: Aug 2014
Location: Lodi
Region: California
Posts: 52
I searched and found it on Latemodelrestoration website. Would this be sufficient or does it need to be straight from a ford website?
Sgonza33 is offline   Reply With Quote
Old 11-04-2014, 04:04 PM   #6
Registered Member
Regular
 
ponie1992's Avatar
 
Join Date: Jul 2014
Location: Lexington
Region: South Carolina
Posts: 1,052
I had the TSB with me and they still wouldn't replace it without being able to recreate it. I think it's BS and may try another dealer.

Sent from my SCH-I545 using Mustang Evolution mobile app
__________________
Jeremy
2016 Ruby Red PP GT
ponie1992 is offline   Reply With Quote
Old 11-04-2014, 04:15 PM   #7
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
Quote:
Originally Posted by Sgonza33 View Post
I searched and found it on Latemodelrestoration website. Would this be sufficient or does it need to be straight from a ford website?
You should be good




Quote:
Originally Posted by ponie1992 View Post
I had the TSB with me and they still wouldn't replace it without being able to recreate it. I think it's BS and may try another dealer.

Sent from my SCH-I545 using Mustang Evolution mobile app
Head to another dealership, don't deal with their bs. Clearly you provided proof there's a tsb; did they even checked for the tsb? When I took mine in, the service manager checked for the tsb even when I told him about the tsb and handed him the print out. He told me they would get it fixed (without anybody recreating the creaking) but unfortunately they didn't have the replacements. I would have gone straight to another one to check if they had the replacements but its a long drive, so I decided to wait.

You need to know the rules, to break the rules
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Old 11-04-2014, 06:38 PM   #8
Registered Member
Regular
 
white14v6's Avatar
 
Join Date: Jul 2014
Location: Guys
Region: Tennessee
Posts: 163
Can you post the link for the tab?
white14v6 is offline   Reply With Quote
Old 11-04-2014, 07:35 PM   #9
Registered Member
Regular
 
Sgonza33's Avatar
 
Join Date: Aug 2014
Location: Lodi
Region: California
Posts: 52
Quote:
Originally Posted by white14v6 View Post
Can you post the link for the tab?

http://www.latemodelrestoration.com/...ang-TSB-Recall

Is this what you're looking for?
Sgonza33 is offline   Reply With Quote
Old 11-04-2014, 07:46 PM   #10
Registered Member
Regular
 
white14v6's Avatar
 
Join Date: Jul 2014
Location: Guys
Region: Tennessee
Posts: 163
Vic, you have a 2014. There is not a tsb on late model restoration that relates to the creaking sound.
white14v6 is offline   Reply With Quote
Old 11-04-2014, 07:55 PM   #11
Registered Member
Regular
 
JR4288's Avatar
 
Join Date: Sep 2014
Location: San Antonio
Region: Texas
Posts: 220
Well I have a 14 and definitely have a squeaking at low speeds. Does there have to be a TSB for them to do something about it?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
JR4288 is offline   Reply With Quote
Old 11-04-2014, 08:01 PM   #12
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
Quote:
Originally Posted by white14v6 View Post
Vic, you have a 2014. There is not a tsb on late model restoration that relates to the creaking sound.
Yeah, when I was looking around a search took me to late model; but I didn't find the TSB there for our stangs. I can't recall where I found it, though I remember one search brought me here to ME. Bucko has a thread on the TSBs and it mentions the creaking for the '14. Give me a bit and I'll get you the link to that thread.

Edit* this is the link to the thread
New TSB release
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Old 11-04-2014, 08:08 PM   #13
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
Quote:
Originally Posted by JR4288 View Post
Well I have a 14 and definitely have a squeaking at low speeds. Does there have to be a TSB for them to do something about it?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
Nope. Since it's still under warranty the dealership should work on it. When I first had this squeaking/creaking, I took her in and they replaced the LCAs, after a few weeks the squeaking came back. I told them I got the squeaking sound back and they told me it was normal. Then I found out about the TSB. Took her back in, only to find out they didn't have the replacements in stock; I was told they have them in stock now so I'm taking her Friday. The TSB SHOULD resolve the issue, as I understand the LCA replacements come with a heat shield.
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Old 11-04-2014, 09:12 PM   #14
Registered Member
Regular
 
blackstang1's Avatar
 
Join Date: May 2014
Location: Northern Illinois
Region: Illinois
Posts: 229
I actually just ran into this problem. I have had the suspension creak/squeak since the car was brand new. Just took it into the dealer for the oil change and asked them to fix the squeak. Told me they couldn't recreate the noise...told them there is a TSB for it... they said that in order for them to perform the TSB, they must see wear/defaults with the component in question.
__________________
2014 Mustang V6 w/Technology package, 6MT

Mods: Airaid CAI w/ Synthamax filter, 18" black AMR wheels
blackstang1 is offline   Reply With Quote
Old 11-04-2014, 10:11 PM   #15
Registered Member
Regular
 
ponie1992's Avatar
 
Join Date: Jul 2014
Location: Lexington
Region: South Carolina
Posts: 1,052
Quote:
Originally Posted by blackstang1 View Post
I actually just ran into this problem. I have had the suspension creak/squeak since the car was brand new. Just took it into the dealer for the oil change and asked them to fix the squeak. Told me they couldn't recreate the noise...told them there is a TSB for it... they said that in order for them to perform the TSB, they must see wear/defaults with the component in question.
This is exactly what I was told.

Sent from my SCH-I545 using Mustang Evolution mobile app
__________________
Jeremy
2016 Ruby Red PP GT
ponie1992 is offline   Reply With Quote
Old 11-04-2014, 10:22 PM   #16
Registered Member
Regular
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 342
My car has 10k miles and have being doing that since 0 miles. I will ask the dealer to fix it on my next oil change.

Mine is a 2014


Sent from my iPhone using Mustang Evolution
Ranger052 is offline   Reply With Quote
Old 11-05-2014, 06:52 AM   #17
Registered Member
Regular
 
blackstang1's Avatar
 
Join Date: May 2014
Location: Northern Illinois
Region: Illinois
Posts: 229
Quote:
Originally Posted by ponie1992 View Post
This is exactly what I was told.

Sent from my SCH-I545 using Mustang Evolution mobile app

I wonder if Deysha can get involved in this?


Sent from my iPhone using Mustang Evolution

---------- Post added at 06:52 AM ---------- Previous post was at 06:51 AM ----------

Quote:
Originally Posted by Ranger052 View Post
My car has 10k miles and have being doing that since 0 miles. I will ask the dealer to fix it on my next oil change.

Mine is a 2014


Sent from my iPhone using Mustang Evolution

Same boat as you. Same year, same mileage. Hope they fix yours though!


Sent from my iPhone using Mustang Evolution
__________________
2014 Mustang V6 w/Technology package, 6MT

Mods: Airaid CAI w/ Synthamax filter, 18" black AMR wheels
blackstang1 is offline   Reply With Quote
Old 11-05-2014, 06:57 AM   #18
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
Quote:
Originally Posted by blackstang1 View Post
I actually just ran into this problem. I have had the suspension creak/squeak since the car was brand new. Just took it into the dealer for the oil change and asked them to fix the squeak. Told me they couldn't recreate the noise...told them there is a TSB for it... they said that in order for them to perform the TSB, they must see wear/defaults with the component in question.






Quote:
Originally Posted by ponie1992 View Post
This is exactly what I was told.

Sent from my SCH-I545 using Mustang Evolution mobile app

I would go to another dealership




Quote:
Originally Posted by Ranger052 View Post
My car has 10k miles and have being doing that since 0 miles. I will ask the dealer to fix it on my next oil change.

Mine is a 2014


Sent from my iPhone using Mustang Evolution
Make sure to take a print out. I know ponie1992 took it but they still didn't work on his mustang. But having the tsb printed out will be good for you. hope you don't get bs like ponie and blackstang

You need to know the rules, to break the rules

---------- Post added at 06:57 AM ---------- Previous post was at 06:56 AM ----------

Quote:
Originally Posted by blackstang1 View Post
I wonder if Deysha can get involved in this?

Sent from my iPhone using Mustang Evolution
Who's Deysha?

You need to know the rules, to break the rules
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Old 11-05-2014, 01:03 PM   #19
Registered Member
Regular
 
Siber Express's Avatar
 
Join Date: Jan 2013
Location: Clinton
Region: Tennessee
Posts: 1,100
Quote:

Who's Deysha?

You need to know the rules, to break the rules
Fords customer service rep.
Helps a lot of people on many sites.



Sent from my SPH-L720 using Mustang Evolution mobile app
__________________
2013 V6 MCoA, Performance Package, Security Package, Comfort Package and Electronic Package.
Mods OEM Backup Camera, BBK Shorties, FRPP Cut and Clamp X-Pipe, Borla Touring A/B's, Airaid CAI, Axle Xchange 2 piece aluminum Driveshaft, Koni Sport Shocks and Struts, Vogtland V6 Leveling springs, Ford Racing 302s wheels wrapped with Continental 275/40 19's, JBL GTO 8628 6X8 in all 4 corners.
2013 F 150 FX2 With a 6.2 Boss
Siber Express is offline   Reply With Quote
Old 11-05-2014, 05:04 PM   #20
Registered Member
Regular
 
Vic14's Avatar
 
Join Date: Jun 2014
Location: Donna
Region: Texas
Posts: 651
I was seeing my comments and forgot to mention. Have the tech always ride along with you or vice versa (you ride along with the tech) to recreate whatever is wrong. The tech may not know how to exactly recreate whatever is wrong or may just say everything is fine when its not. Play it safe!

Quote:
Originally Posted by Siber Expres View Post
Fords customer service rep.
Helps a lot of people on many sites.



Sent from my SPH-L720 using Mustang Evolution mobile app
Oh, that's good to know. How does one get a hold of her, if needed?
__________________
"I know I was born and I know that I'll die... The in between is mine." -Pearl Jam
Vic14 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspension woes charkelly9 Pre-2005 V6 Mustang 9 07-22-2008 07:56 AM
'07 Pony "earl" woes greaser Pre-2005 V6 Mustang 16 09-24-2006 09:42 PM
charging system woes Thomas91169 Mustang Audio & Video 15 08-12-2006 01:34 AM
college woes jimmy_beaner The Bar 27 10-31-2004 11:55 PM
window woes el cheapo Mustang Audio & Video 13 10-06-2003 12:59 PM

» Like Us On Facebook



07:35 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.