JLT Oil separator issues - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-10-2014, 09:09 PM   #1
Registered Member
Regular
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 342
JLT Oil separator issues

As the title describe, I am having some issues with jlt oil separator.

The issue is that after I installed it i started to hear some ticking noise coming front right behind where the oil separator hose plugs in.

Has anyone noticed that with JLT Oil separators?

Thanks


Sent from my iPhone using Mustang Evolution
Ranger052 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JLT Oil Separator GrabberBlue5.0 2011-2014 Mustang GT 55 12-23-2015 11:35 AM
Jlt vs Moroso oil separator OzzyLiriano 2011-2014 Mustang GT 39 10-29-2013 03:07 PM
JLT Oil Separator for Blown 5.0 poloka 2011-2014 Mustang GT 5 02-15-2013 03:47 PM
JLT Oil Separator 08Mustang 2005-2010 V6 Mustang 16 06-30-2012 08:56 AM
JLT oil separator Mustangpower5.0 2011-2014 Mustang GT 13 05-18-2012 11:32 PM

» Like Us On Facebook



04:24 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.