Halo in instrument cluster - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-28-2015, 12:27 PM   #1
Registered User
Newbie
 
Join Date: Jan 2015
Location: dubai
Region: Other
Posts: 13
Angry Halo in instrument cluster

halo light only light up in the bottom,not a full ring.. any idea what it could be?
slowcheetah is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-28-2015, 02:59 PM   #2
Kevin.Cook
Guest
 
Posts: n/a
LEDs may have went out? If the car is under warranty, take it in for a look over.
  Reply With Quote
Old 01-28-2015, 04:20 PM   #3
Registered Member
Regular
 
iantrusive's Avatar
 
Join Date: Mar 2014
Location: LA
Posts: 195
Picture?


Sent from my Mustang.
iantrusive is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-31-2015, 09:05 AM   #4
Registered User
Newbie
 
Join Date: Jan 2015
Location: dubai
Region: Other
Posts: 13
this is it

Quote:
Originally Posted by iantrusive View Post
Picture?


Sent from my Mustang.
Attached Thumbnails
Click image for larger version

Name:	halo.jpg
Views:	70
Size:	1.10 MB
ID:	174593  
slowcheetah is offline   Reply With Quote
Old 01-31-2015, 02:47 PM   #5
Registered Member
Regular
 
Siber Express's Avatar
 
Join Date: Jan 2013
Location: Clinton
Region: Tennessee
Posts: 1,100
Looks Dimmed, try turning it up and see if they all appear on.
__________________
2013 V6 MCoA, Performance Package, Security Package, Comfort Package and Electronic Package.
Mods OEM Backup Camera, BBK Shorties, FRPP Cut and Clamp X-Pipe, Borla Touring A/B's, Airaid CAI, Axle Xchange 2 piece aluminum Driveshaft, Koni Sport Shocks and Struts, Vogtland V6 Leveling springs, Ford Racing 302s wheels wrapped with Continental 275/40 19's, JBL GTO 8628 6X8 in all 4 corners.
2013 F 150 FX2 With a 6.2 Boss
Siber Express is offline   Reply With Quote
Old 01-31-2015, 02:56 PM   #6
Registered Member
Regular
 
iantrusive's Avatar
 
Join Date: Mar 2014
Location: LA
Posts: 195
Is it affected by the dimmer?


Sent from my Mustang.
iantrusive is offline   Reply With Quote
Old 01-31-2015, 03:03 PM   #7
Registered User
Newbie
 
Join Date: Jan 2015
Location: dubai
Region: Other
Posts: 13
Quote:
Originally Posted by Siber Expres View Post
Looks Dimmed, try turning it up and see if they all appear on.
It's not affected by dimmer. Both clusters, up and down are lighted little.
slowcheetah is offline   Reply With Quote
Old 01-31-2015, 03:07 PM   #8
Registered Member
Regular
 
Siber Express's Avatar
 
Join Date: Jan 2013
Location: Clinton
Region: Tennessee
Posts: 1,100
Quote:
Originally Posted by iantrusive View Post
Is it affected by the dimmer?


Sent from my Mustang.
The Dimmer is in the Set up rotation, you have Bright and Dim, my 2010 looked like it was missing some on the low setting but lit up fine on the Bright setting.
__________________
2013 V6 MCoA, Performance Package, Security Package, Comfort Package and Electronic Package.
Mods OEM Backup Camera, BBK Shorties, FRPP Cut and Clamp X-Pipe, Borla Touring A/B's, Airaid CAI, Axle Xchange 2 piece aluminum Driveshaft, Koni Sport Shocks and Struts, Vogtland V6 Leveling springs, Ford Racing 302s wheels wrapped with Continental 275/40 19's, JBL GTO 8628 6X8 in all 4 corners.
2013 F 150 FX2 With a 6.2 Boss
Siber Express is offline   Reply With Quote
Old 01-31-2015, 07:16 PM   #9
Registered User
Newbie
 
Join Date: Jan 2015
Location: dubai
Region: Other
Posts: 13
[/COLOR]
Quote:
Originally Posted by Siber Expres View Post
The Dimmer is in the Set up rotation, you have Bright and Dim, my 2010 looked like it was missing some on the low setting but lit up fine on the Bright setting.
I tried that. But stil not a full ring.. i think I will just bring out the cluster and check, might be a loose connection..
slowcheetah is offline   Reply With Quote
Old 02-12-2015, 09:20 AM   #10
Registered User
Newbie
 
arctic_zac's Avatar
 
Join Date: Dec 2014
Location: lafayette
Region: Indiana
Posts: 1
get anywhere with it? my halos on my '12 went dim on me a few weeks ago. i'm resurrecting a wrecked one though.
arctic_zac is offline   Reply With Quote
Old 02-12-2015, 09:36 AM   #11
Registered User
Newbie
 
Join Date: Jan 2015
Location: dubai
Region: Other
Posts: 13
Quote:
Originally Posted by arctic_zac View Post
get anywhere with it? my halos on my '12 went dim on me a few weeks ago. i'm resurrecting a wrecked one though.
not yet, i am trying to pull off the instrument cluster and check if its any loose connection. bcoz, i felt like the light is getting brighter when i tried pulled and pushed the cluster.. was in a hurry to look in detail...
slowcheetah is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Roush Mustang Instrument Cluster BetsyBootstrap Pre-2005 V6 Mustang 3 06-30-2010 01:08 PM
Brake, ABS & Instrument Cluster stevinas 2005-2010 Mustang GT 4 07-01-2008 09:53 AM
Need help on Instrument cluster. Batroo 1979-1995 Mustang GT 4 04-23-2008 10:48 PM
instrument cluster swap pipeguy General Mustang Discussion 0 04-11-2008 10:43 AM
94 - 95 GT Instrument Cluster StreetRacer4371 Mustang Parts for Sale and Wanted 5 10-21-2004 09:32 PM

» Like Us On Facebook



12:32 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.