Check engine light flashing - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-26-2016, 12:00 PM   #1
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Check engine light flashing

Hi any ideas on why my check engine light flashes for about 60 seconds when I accelerate hard only sometimes and then goes off and everything is fine again? Dealer can't solve the issue because the light won't stay on and it only does it sometimes. It's a 14 v6 premium with no add ons or modifications to the engine.
Christy jo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2016, 12:15 PM   #2
Registered Member
Regular
 
jayochs's Avatar
 
Join Date: Aug 2014
Location: NJ
Region: New Jersey
Posts: 1,449
are you sure it's the check engine light, and not the traction control light? if you're spinning the tires at all, traction control is gonna kick in and the light will go on and off
__________________
2014 Ford Mustang 3.7 Premium 6-speed:
MPT Performance Tune, AM Laguna Seca Black 19" Rims, Borla Touring Axlebacks, Boss 302 Strut Tower Brace, Airaid Modular Intake Tube, aFe Pro Dry S Air Filter, Mustang GT Grille w/ Foglight Mesh, Taillight Tint, Tinted Door Ventvisors, Diode Dynamics LED's
jayochs is offline   Reply With Quote
Old 03-26-2016, 12:24 PM   #3
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
No it's definitely not that light, it's for sure the check engine light. It's only when I'm on the interstate and go to pass someone and I accelerate hard.

Sent from my HTC6525LVW using Mustang Evolution mobile app
Christy jo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2016, 12:37 PM   #4
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
If you had a tuner, you could datalog it or have someone watching the diagnostic tool and try to catch the code while doing your thing on the interstate.

Other then that, have you tried leaving the battery disconnected for an hour to let everything reset?


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 01:00 PM   #5
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Yeah I have

Sent from my HTC6525LVW using Mustang Evolution mobile app
Christy jo is offline   Reply With Quote
Old 03-26-2016, 01:08 PM   #6
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
Definitely gotta catch the code then. Otherwise, you are spinning your wheels.

You can try checking your maf sensor and stuff. But i believe that kind of stuff throws a wrench light.


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 01:09 PM   #7
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
I would just go through and make sure everything is plugged in and secure. What happens if you park it and rev it really high? Curious if it is speed related or rpm related.


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 01:17 PM   #8
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Hummmm not sure, I'll try it and let you know.
Christy jo is offline   Reply With Quote
Old 03-26-2016, 01:25 PM   #9
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
It is a misfire

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Old 03-26-2016, 01:33 PM   #10
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
If it is a misfire, maybe change the spark plugs and inspect your coils.


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 01:35 PM   #11
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Done that already too and car doesn't run bad at all.
Christy jo is offline   Reply With Quote
Old 03-26-2016, 01:37 PM   #12
Registered Member
Regular
 
SouthernCyclone's Avatar
 
Join Date: Jul 2013
Location: Schnars
Region: Alabama
Posts: 290
Misfire like Nate said. If your lucky and pull the code it will tell you what cylinders the misfire is on. If not you will just get a general misfire code.
SouthernCyclone is offline   Reply With Quote
Old 03-26-2016, 02:02 PM   #13
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
What kind of fuel are you using? Maybe try a fuel system cleaner in case you got ahold of some bad stuff.


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 02:02 PM   #14
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Ok thanks!
Christy jo is offline   Reply With Quote
Old 03-26-2016, 02:15 PM   #15
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
I did that too lol. Dealership said could be bad gas so I put cleaner in it and only use top of line gas now.

---------- Post added at 07:15 PM ---------- Previous post was at 07:14 PM ----------

Someone said something about a possible vacuum leak or breather problem, idk.
Christy jo is offline   Reply With Quote
Old 03-26-2016, 03:03 PM   #16
Registered Member
Regular
 
David Young's Avatar
 
Join Date: Feb 2013
Location: Clinton
Region: Tennessee
Posts: 1,005
Your 'dealer' can hook up something (some kind of box) that will remember the code or codes while you drive. You have a pretty new Mustang, let the dealer worry about it
__________________
Little Red. 2011 V6. Automatic Trans., C&L CAI, JLT Catch Can, BBK Ceramic Coated Long Tube Headers with BBK Catted X Pipe, Axle Exchange (American Muscle) Aluminum DriveShaft, GT 500 Lower Control Arms, Koni (orange) Dampers, Steeda Watts Link, Ford Racing 3.73 Gears, Magnaflow Street Series Axle Backs and a few more mods....Wifes car, 2014 Ford Edge Limited.
David Young is offline   Reply With Quote
Old 03-26-2016, 03:05 PM   #17
Evolution's Finest
Regular
Supporter
 
ZombieSlayer's Avatar
 
Join Date: Feb 2016
Location: 78613
Region: Texas
Posts: 944
What kind of "dealer" are we talkin?


Sent from my iPhone using Mustang Evolution
__________________
2016 Mustang GT: Guard Metallic w/ manual transmission; Performance Pack and Backup Sensors

Follow me on Instagram: https://www.instagram.com/kevin.cook2016/?hl=en
ZombieSlayer is offline   Reply With Quote
Old 03-26-2016, 03:13 PM   #18
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Ford dealership in Louisiana lol and yes at least it's still under warranty
Christy jo is offline   Reply With Quote
Old 03-26-2016, 03:36 PM   #19
Registered Member
Regular
 
David Young's Avatar
 
Join Date: Feb 2013
Location: Clinton
Region: Tennessee
Posts: 1,005
Quote:
Originally Posted by ZombieSlayer View Post
What kind of "dealer" are we talkin?


Sent from my iPhone using Mustang Evolution

Ha ha
__________________
Little Red. 2011 V6. Automatic Trans., C&L CAI, JLT Catch Can, BBK Ceramic Coated Long Tube Headers with BBK Catted X Pipe, Axle Exchange (American Muscle) Aluminum DriveShaft, GT 500 Lower Control Arms, Koni (orange) Dampers, Steeda Watts Link, Ford Racing 3.73 Gears, Magnaflow Street Series Axle Backs and a few more mods....Wifes car, 2014 Ford Edge Limited.
David Young is offline   Reply With Quote
Old 03-26-2016, 03:54 PM   #20
Registered Member
Regular
 
heebe_geebe's Avatar
 
Join Date: Mar 2016
Location: midwest
Region: Missouri
Posts: 114
Quote:
Originally Posted by Christy jo View Post
Ford dealership in Louisiana lol and yes at least it's still under warranty
Wow still under warranty and they're blowing you off. Is it the dealer you got the car from? IMO Regardless I'd be hunting up another dealer...
__________________
2014 MCOA, V6 PREMIUM, PERFORMANCE PACKAGE, COMFORT PACKAGE, SECURITY PACKAGE, DEEP IMPACT BLUE WITH SILVER CUSTOM COBRA STYLE STRIPES, AIRAID TUBE, TINTED 35%, PIONEER 8000 NEX, REAR CAMERA, BORLA TOUR AXLE BACK, K&N FILTER. JLT OIL CATCH CAN, CUSTOM MADE HOOD STRUTS, BBK SHORTY CERAMIC

heebe_geebe is offline   Reply With Quote
Old 03-26-2016, 04:30 PM   #21
Junior Member
 
Join Date: Mar 2016
Location: Joint Base MDL
Region: Arizona
Posts: 6
Isn't this typically a sign of detonation?

Sent from my SM-G900P using Tapatalk
gt_thunder is offline   Reply With Quote
Old 03-26-2016, 07:19 PM   #22
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
Yes it is the dealership I got it from
Christy jo is offline   Reply With Quote
Old 03-26-2016, 10:35 PM   #23
Registered Member
Regular
 
Hawkstang's Avatar
 
Join Date: Jul 2015
Location: Sioux City
Region: Iowa
Posts: 1,273
Quote:
Originally Posted by natestang07 View Post
It is a misfire

Sent from my VS985 4G using Mustang Evolution mobile app
This is correct. I had this happen on my last car (2006 CTS) and it happened more than once, all on hard accelerations.

Turned out I had three coils go bad. When I asked the tech how 3 could go bad all at once, he didn't have an answer, though my amateur guess is one was bad and the other two on that side over compensated?

Bottom line is whenever your engine light flashes it's a misfire. Back off the gas and drive conservative until you get it diagnosed.

Mine was flashing once then stayed on and I could feel a considerable loss in power so I grannied it home and to the shop asap the next day.

Don't take chances with misfires. Good luck and keep us posted.
Hawkstang is offline   Reply With Quote
Old 03-26-2016, 10:39 PM   #24
Registered Member
Regular
 
Hawkstang's Avatar
 
Join Date: Jul 2015
Location: Sioux City
Region: Iowa
Posts: 1,273
Quote:
Originally Posted by Christy jo View Post
I did that too lol. Dealership said could be bad gas so I put cleaner in it and only use top of line gas now.

---------- Post added at 07:15 PM ---------- Previous post was at 07:14 PM ----------

Someone said something about a possible vacuum leak or breather problem, idk.
You don't have a cold air intake do you?
Hawkstang is offline   Reply With Quote
Old 03-28-2016, 06:45 AM   #25
Registered User
Newbie
 
Join Date: Mar 2016
Location: 39466
Region: Mississippi
Posts: 17
No sure don't but the misfire sounds about right because that's exactly how the car is acting and they did change a coil before I bought it and yes if I drive it normal it doesn't do it at all so I'll take your advice and don't accelerate hard if I don't have to until it gets fixed.
Christy jo is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashing Check Engine light, Random Misfire code Crystalwilliams Pre-2005 V6 Mustang 5 10-14-2014 04:38 PM
Flashing check engine light Seanp94 2011-2014 Mustang GT 29 10-12-2014 09:30 PM
Flashing check engine light after hard pull Pancakes 1996-2004 Mustang GT 2 08-28-2014 07:52 PM
2013 V6 Check Engine Light Flashing vcantrell 2011-2014 V6 Mustang 8 06-22-2013 10:43 PM
Check engine light flashing!!! rich671 Pre-2005 V6 Mustang 8 09-14-2012 06:39 PM

» Like Us On Facebook



01:21 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.