Temperature Reading - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-11-2016, 08:38 PM   #1
Registered Member
Regular
 
parkerbickel's Avatar
 
Join Date: Apr 2016
Location: La Junta
Region: Colorado
Posts: 269
Temperature Reading

So yesterday I got my Raxiom non sync navigation unit. I did the install and followed all instructions but my raxiom seems to be showing a temperature of 80 degrees (it's 100+ out) I took it out and realized my OEM display is also showing 80 degrees. What can be causing this? Worked fine until I installed my Raxiom.
__________________
2011 V6 Race Red - Roush Axle Back Exhaust, GT500 Steering Wheel, GROM Audio Bluetooth Module, Raxiom Aero Smoked Tail lights, Raxiom GPS
parkerbickel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-12-2016, 12:41 AM   #2
Registered Member
Regular
 
Chaz12's Avatar
 
Join Date: Oct 2014
Location: Austin
Region: Texas
Posts: 578
It's a Raxiom product, that's the answer lol but honestly that's weird. Mine works fine.


2013 Premium Performance White

Bama 93 Race tune, GT500 blue racing stripes with matching hash marks and side stripe, cold air intake, Flowmaster super 44s with Roush 4" tips, CDC performance grille, side scoops, painted white quarter windows, all lights tinted

Last Mod: Bama 93 Race Tune

IG: chaznungaray
__________________
2013 Premium Performance White

Bama 91 Race tune, GT500 blue racing stripes with matching hash marks and side stripes, cold air intake, Flowmaster super 44s with Roush 4" Tips, CDC performance grille, side scoops, painted quarter windows, all lights tinted
Chaz12 is offline   Reply With Quote
Old 08-12-2016, 07:36 AM   #3
Registered Member
Regular
 
parkerbickel's Avatar
 
Join Date: Apr 2016
Location: La Junta
Region: Colorado
Posts: 269
I wonder if my temperature sensor just failed at the same time as install. As I said when I looked at my OEM screen wrapped in foam it was reading 80 degrees as well.

Sent from my SM-G935V using Mustang Evolution mobile app
__________________
2011 V6 Race Red - Roush Axle Back Exhaust, GT500 Steering Wheel, GROM Audio Bluetooth Module, Raxiom Aero Smoked Tail lights, Raxiom GPS
parkerbickel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-12-2016, 09:20 AM   #4
Registered Member
Regular
 
parkerbickel's Avatar
 
Join Date: Apr 2016
Location: La Junta
Region: Colorado
Posts: 269
Turned the car on this morning and it was reading the correct temp. Very weird. My miles left till empty was acting weird though, which is extra strange considering I never unhooked the battery. After filling it up full it displays 290 till E and when I filled it up this morning was showing 360 till E. Guess I'll let it sit and see if it corrects itself.

Sent from my SM-G935V using Mustang Evolution mobile app
__________________
2011 V6 Race Red - Roush Axle Back Exhaust, GT500 Steering Wheel, GROM Audio Bluetooth Module, Raxiom Aero Smoked Tail lights, Raxiom GPS
parkerbickel is offline   Reply With Quote
Old 08-12-2016, 10:16 AM   #5
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 4,796
check your battery terminals....wild guess
__________________
New England Mustang Cruise July 29th
http://www.mustangevolution.com/forum/f296/t394033/
regional forums or PM Me or Robostang
Strange Mud is online now   Reply With Quote
Old 08-13-2016, 10:24 AM   #6
Registered Member
Regular
 
David Young's Avatar
 
Join Date: Feb 2013
Location: Clinton
Region: Tennessee
Posts: 922
Quote:
Originally Posted by parkerbickel View Post
Turned the car on this morning and it was reading the correct temp. Very weird. My miles left till empty was acting weird though, which is extra strange considering I never unhooked the battery. After filling it up full it displays 290 till E and when I filled it up this morning was showing 360 till E. Guess I'll let it sit and see if it corrects itself.

Sent from my SM-G935V using Mustang Evolution mobile app

Strange things happen to our Mustangs when the battery is getting ready to go bad
__________________
Little Red. 2011 V6. Automatic Trans., C&L CAI, JLT Catch Can, BBK Ceramic Coated Long Tube Headers with BBK Catted X Pipe, Axle Exchange (American Muscle) Aluminum DriveShaft, GT 500 Lower Control Arms, Koni (orange) Dampers, Steeda Watts Link, Ford Racing 3.73 Gears, Magnaflow Street Series Axle Backs and a few more mods....Wifes car, 2014 Ford Edge Limited.
David Young is offline   Reply With Quote
Old 08-13-2016, 06:44 PM   #7
Registered Member
Regular
 
Diehard's Avatar
 
Join Date: Mar 2014
Location: North Reading
Region: Massachusetts
Posts: 2,112
Quote:
Originally Posted by parkerbickel View Post
Turned the car on this morning and it was reading the correct temp. Very weird. My miles left till empty was acting weird though, which is extra strange considering I never unhooked the battery. After filling it up full it displays 290 till E and when I filled it up this morning was showing 360 till E. Guess I'll let it sit and see if it corrects itself.

Sent from my SM-G935V using Mustang Evolution mobile app
Yeah but what were your average MPG at the time of each fill?
__________________
____________________________________________________
14 V6 auto, MCA, PP, BBK Shorties, MMD Hood Struts, Borla Touring A/B's, MAC ProChamber, aFe drop-in Filter
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Lets not forget, an opinion is a judgment, viewpoint, or statement about matters commonly considered to be subjective.
Diehard is offline   Reply With Quote
Old 08-13-2016, 11:26 PM   #8
Registered Member
Regular
 
parkerbickel's Avatar
 
Join Date: Apr 2016
Location: La Junta
Region: Colorado
Posts: 269
Usually 18 MPG. Before I put in the raxiom it was showing 18 on the gauges after it was showing 9. I'm wondering what happened when I put the raxiom in that sent everything out of whack. Everything seems back to "normal" now but I'm watching closely

Sent from my SM-G935V using Mustang Evolution mobile app
__________________
2011 V6 Race Red - Roush Axle Back Exhaust, GT500 Steering Wheel, GROM Audio Bluetooth Module, Raxiom Aero Smoked Tail lights, Raxiom GPS
parkerbickel is offline   Reply With Quote
Old 08-15-2016, 08:40 PM   #9
Registered Member
Regular
 
Join Date: Feb 2015
Location: Cross Plains
Region: Tennessee
Posts: 135
When I installed mine it was weird too, its from disconnecting the battery, after about 350 miles it straightened itself out.
Logan541 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Outside temperature reading. Whitey5.0 2011-2014 Mustang GT 4 07-18-2015 08:48 PM
Is there any way to calibrate the temperature reading? sbbamafan General Mustang Discussion 1 04-06-2014 10:25 AM
Chain E-mail, but this one is worth reading. WhiteStang99 The Bar 5 07-13-2004 12:19 PM
This book im reading.. Zim The Bar 5 07-09-2004 03:45 PM
Lite Reading Ken The Bar 32 05-01-2004 10:26 AM

» Like Us On Facebook



12:34 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.