2012 A/C Air Conditioning not blowing cold - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-05-2017, 07:36 AM   #1
Registered Member
Regular
 
ActorMike's Avatar
 
Join Date: Mar 2017
Location: Knoxville
Region: Tennessee
Posts: 51
2012 A/C Air Conditioning not blowing cold

Air was working fine, then suddenly stopped working the next time I drove the car. It's blowing out about 78 degree air right now with the outdoor temperature at 68 degrees. I never smelled anything funny like an A/C clutch, when I started the car, I did hear a very subtle whining noise. For now I just have the the A/C turned off. Any guesses? Car has 76,000 miles.
ActorMike is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-05-2017, 07:50 AM   #2
Junior Member
 
Join Date: Jul 2017
Posts: 16
Check your refrigerant pressure, make sure your fan is kicking on, or check for leaks. But if it was sudden you might be looking at a fan or compressor
austinh1999 is offline   Reply With Quote
Old 08-05-2017, 05:26 PM   #3
Registered Member
Regular
 
ActorMike's Avatar
 
Join Date: Mar 2017
Location: Knoxville
Region: Tennessee
Posts: 51
Quote:
Originally Posted by austinh1999 View Post
Check your refrigerant pressure, make sure your fan is kicking on, or check for leaks. But if it was sudden you might be looking at a fan or compressor
Pressure on the low side was okay. Compressor is not coming on, it should spin the in middle when it is running, right? Anything else I can check other than the compressor before taking it to the shop? Thanks.
ActorMike is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-06-2017, 01:15 AM   #4
Registered Member
Regular
 
iguanaman3's Avatar
 
Join Date: Jun 2014
Location: Bokeelia
Region: Florida
Posts: 313
Get yourself a UV light and check all the pipes for leaks. My 2012 had a defective high pressure pipe that leaked at a joint near the compressor. Ford puts dye in at the factory so any leaks will show right up under UV.
iguanaman3 is offline   Reply With Quote
Old 08-06-2017, 12:23 PM   #5
Registered User
Newbie
 
Join Date: Jan 2013
Location: Oro Valley, AZ
Region: Arizona
Posts: 15
Sounds like your AC clutch is bad--you said your compressor is not spinning. Not overly expensive to repair.
kipschitz is offline   Reply With Quote
Old 08-13-2017, 09:06 AM   #6
Registered Member
Regular
 
Top Down's Avatar
 
Join Date: Sep 2016
Location: Sheboygan Falls
Region: Wisconsin
Posts: 23
Mine needed a CR3Z 19972 C tube assembly. From what I've read on this forum, it's been a problem. The original has a weak joint.
__________________
2012 Grabber Blue V6 Premium Convertible
202A Pony Package, Comfort Package
Shaker 500 Audio, Sirius
Automatic transmission mod when I can afford it LOL
Top Down is offline   Reply With Quote
Old 08-13-2017, 10:55 AM   #7
Registered Member
Regular
 
ActorMike's Avatar
 
Join Date: Mar 2017
Location: Knoxville
Region: Tennessee
Posts: 51
Quote:
Originally Posted by Top Down View Post
Mine needed a CR3Z 19972 C tube assembly. From what I've read on this forum, it's been a problem. The original has a weak joint.
They tolde the compressor had a leak, I wonder if I just need the tube assembly?
ActorMike is offline   Reply With Quote
Old 08-13-2017, 12:29 PM   #8
Registered Member
Regular
 
iguanaman3's Avatar
 
Join Date: Jun 2014
Location: Bokeelia
Region: Florida
Posts: 313
A UV light will tell the story. Ask them to show you the leak under UV.
iguanaman3 is offline   Reply With Quote
Old 08-19-2017, 05:59 PM   #9
Registered Member
Regular
 
Join Date: Jan 2017
Location: chi t
Region: Ohio
Posts: 81
I have a similar issue. Seems to only happen on hotter days like 80 degrees + and its not every day that its that hot. But the air will blow cold for a few minutes then get warmer for a few seconds, then blow cold then warm intermittently like that. I checked the coolant level and it is not low but added a little anyways, fan is working. Any ideas?
Renownedd is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2011-2014 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C stopped blowing cold air MedicDave 2005-2010 Mustang GT 2 08-30-2015 02:38 PM
mustang v6 2012 air condition after use the hot air do not blow cold air blackout2012 2011-2014 V6 Mustang 5 12-14-2014 07:17 AM
Mustang a/c just quit blowing cold air paulflor98 2011-2014 Mustang GT 30 08-14-2014 04:45 PM
Air conditioning not really cold jomcgui 2011-2014 V6 Mustang 31 06-24-2014 05:22 PM
Right side not blowing cold air Drakma675 2005-2010 V6 Mustang 5 10-14-2013 03:10 AM

» Like Us On Facebook



08:53 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.