2013 rust problem - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-21-2012, 12:25 AM   #1
Registered User
Newbie
 
Kwestmoreland's Avatar
 
Join Date: Aug 2012
Region: Georgia
Posts: 2
2013 rust problem

As anyone experience a rust problem on the new 2013? I had the first service completed and while it was racked the whole bottom was rusted to include exhaust system. This car was purchased in Rome Georgia.
Kwestmoreland is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2012, 12:50 AM   #2
Registered Member
Regular
 
bluemonster13's Avatar
 
Join Date: May 2012
Region: California
Posts: 453
Quote:
Originally Posted by Kwestmoreland
As anyone experience a rust problem on the new 2013? I had the first service completed and while it was racked the whole bottom was rusted to include exhaust system. This car was purchased in Rome Georgia.
I haven't had any issues yet. I've had mine since may.
__________________
2013 Mustang GT Premium
brembo package
heat extractor hood
3.55 Gears
Borla "s" type catback exhaust
20% tint alll around.
bluemonster13 is offline   Reply With Quote
Old 08-21-2012, 01:08 AM   #3
Registered Member
Regular
 
Edens5's Avatar
 
Join Date: Apr 2012
Region: Pennsylvania
Posts: 361
Its not rust its surface oxidation. If u drove it in the rain its gonna happen Nd theres no way to avoid it. U could of only had it 3 days but if u drove it from the dealer in the rain itll have some of that. It comes right off, but its metal, it tends to do that unless u get it treated.
Edens5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2012, 01:41 AM   #4
Registered User
Newbie
 
Kwestmoreland's Avatar
 
Join Date: Aug 2012
Region: Georgia
Posts: 2
Thanks for the information. There is a thickening of the rust, that is what worried me. The exhaust shows whitening as if salt damage, Is this also normal?
Kwestmoreland is offline   Reply With Quote
Old 08-21-2012, 11:27 AM   #5
Registered Member
Regular
 
Edens5's Avatar
 
Join Date: Apr 2012
Region: Pennsylvania
Posts: 361
Quote:
Originally Posted by Kwestmoreland
Thanks for the information. There is a thickening of the rust, that is what worried me. The exhaust shows whitening as if salt damage, Is this also normal?
Not really sure what you mean by that but if u live near the ocean it is a possibility. It would take a little time to occur though
Edens5 is offline   Reply With Quote
Old 08-21-2012, 12:41 PM   #6
Registered Member
Regular
 
Join Date: Dec 2011
Region: Canada
Posts: 2,976
Re: 2013 rust problem

Ok, it's time to relax. The rear axle is unpainted and forms a nice rust seal on the metal over time. Once that happens it will take a century to even get close to rusting through those axle tubes.

As for the exhaust, they rust from the inside out so, a little surface corrosion on the outside isn't doing anything.

You have rust on the panels under the car, that merits concern.
5LHO is offline   Reply With Quote
Old 08-21-2012, 07:50 PM   #7
Registered Member
Regular
 
Tapakegovagnaps's Avatar
 
Join Date: Jul 2012
Region: Virginia
Posts: 59
I had planned on coating my rear axle with something. My '13 track pack rear end came painted to my surprise....
__________________
2013 GB GT MT- Track Pack, Recaros. Whipple 2.3, JLT CAI, VMP 3x Pass HE, 170 TSTAT, Flowmaster Outlaw/RTR AB, Magnaflow Tru X, SCT ITSX, Eibach Pro Street Coilovers, Axle Exchange Alum. D.S.,BMR Loop, SOS Dual W/ Aeroforce Duals, Boss Steering Wheel, Gt500 Shift Boot, Gt500 Spoiler, MMD Louvers and Hood Struts, Fays2, 3DCarbon Rear Diffuser, DBA Rotors, MGW Shifter, Forgestar CF5s
Tapakegovagnaps is offline   Reply With Quote
Old 08-21-2012, 08:23 PM   #8
Registered Member
Regular
 
Ilovemustangs88's Avatar
 
Join Date: Nov 2011
Region: Pennsylvania
Posts: 158
My 2000 mustang has no rust underneath at all. But mine is undercoated. I would undercoat it and you won't have that problem.
Ilovemustangs88 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:25 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.