front end sounds - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-24-2012, 05:58 PM   #1
Registered Member
Regular
 
runthatsleeper's Avatar
 
Join Date: Apr 2012
Location: New York
Region: New York
Posts: 102
front end sounds

hi everyone i need some help. i lower my 2012 gt about 3 weeks ago and now when i turn the wheel either way it sounds like something in the front is cricking and i can feel a little thru the wheel. i was wondering if anyone could know what it could possibly be ? i was think maybe something wasn't greased etc. i also had the lower control arms done on the car like a month ago because of those cricking but its a different type of sound. and also does anyone know if when doing lower control arms if the strut bar has to be taken off? i only ask because i recently look under my hood and noticed that the stock one was missing.
runthatsleeper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2012, 06:26 PM   #2
Registered Member
Regular
 
2013_stang_gt's Avatar
 
Join Date: Jul 2012
Region: Texas
Posts: 350
definately find out whos got your tower brace.
2013_stang_gt is offline   Reply With Quote
Old 10-24-2012, 06:28 PM   #3
Registered Member
Regular
 
runthatsleeper's Avatar
 
Join Date: Apr 2012
Location: New York
Region: New York
Posts: 102
Yea I think think they forgot to put it back one at the dealer ship
runthatsleeper is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2012, 06:44 PM   #4
The Blue Dragon
Regular
Supporter
 
GrabberBlue5.0's Avatar
 
Join Date: Feb 2012
Location: Louisville
Region: Kentucky
Posts: 5,661
Whoa... You better get back that brace... That shouldn't cause creaking though. Any time you change suspension geometry you're likely to get noises
__________________
New quick exhaust video

AUGUST 2012 MOTM!!!!
GrabberBlue5.0 is offline   Reply With Quote
Old 10-24-2012, 06:46 PM   #5
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
I be strak raving mad!

The noise may go away. Mine did. But comes back every so often. :/
primer2tone is offline   Reply With Quote
Old 10-24-2012, 06:48 PM   #6
Registered Member
Regular
 
runthatsleeper's Avatar
 
Join Date: Apr 2012
Location: New York
Region: New York
Posts: 102
It's just weird that is wasn't doing that when they were put in
runthatsleeper is offline   Reply With Quote
Old 10-24-2012, 07:00 PM   #7
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
It'll settle in. If not, take it back but they'll just blame your springs.
primer2tone is offline   Reply With Quote
Old 10-24-2012, 07:19 PM   #8
Registered Member
Regular
 
92mustang2.3's Avatar
 
Join Date: Oct 2011
Location: Waxahachie
Region: Texas
Posts: 96
Did you replace the upper strut mounts when you lowered it cause the factory ones suck ?
92mustang2.3 is offline   Reply With Quote
Old 10-24-2012, 07:35 PM   #9
Registered Member
Regular
 
bradtaylornator's Avatar
 
Join Date: Oct 2012
Region: Oklahoma
Posts: 169
Quote:
Originally Posted by 92mustang2.3
Did you replace the upper strut mounts when you lowered it cause the factory ones suck ?
I had to get the upper struts replaced on mine 1 week after i got my car. They said it wouldn't hurt anything it just sounds like a beat up junker rolling through a parking lot
bradtaylornator is offline   Reply With Quote
Old 10-24-2012, 07:38 PM   #10
Registered Member
Regular
 
poloka's Avatar
 
Join Date: May 2011
Region: Missouri
Posts: 698
Quote:
Originally Posted by 92mustang2.3
Did you replace the upper strut mounts when you lowered it cause the factory ones suck ?
+1. Make sure and have car aligned if you didn't but the stock should last for a bit. I've got 10,000 miles on my stock ones right now and only pop just slightly when backing out of driveway on a cooler day. Other than that they are still good.
__________________
2011 GT 5.0 Supercharged Phase 2 TVS2300
http://www.mustangevolution.com/forum/f376/t290294/
poloka is offline   Reply With Quote
Old 10-27-2012, 01:22 PM   #11
Registered Member
Regular
 
runthatsleeper's Avatar
 
Join Date: Apr 2012
Location: New York
Region: New York
Posts: 102
does anyone have idea what this sound might be because i think its getting worse and it only does it when i turn the wheel ?
runthatsleeper is offline   Reply With Quote
Old 10-27-2012, 01:25 PM   #12
Registered Member
Regular
 
92mustang2.3's Avatar
 
Join Date: Oct 2011
Location: Waxahachie
Region: Texas
Posts: 96
Quote:
Originally Posted by runthatsleeper
does anyone have idea what this sound might be because i think its getting worse and it only does it when i turn the wheel ?
Replace strut mounts
92mustang2.3 is offline   Reply With Quote
Old 10-28-2012, 11:59 AM   #13
Registered Member
Regular
 
bradtaylornator's Avatar
 
Join Date: Oct 2012
Region: Oklahoma
Posts: 169
Quote:
Originally Posted by runthatsleeper
does anyone have idea what this sound might be because i think its getting worse and it only does it when i turn the wheel ?
Yep replace strut mounts mine did the same thing
bradtaylornator is offline   Reply With Quote
Old 11-02-2012, 11:41 PM   #14
Registered Member
Regular
 
runthatsleeper's Avatar
 
Join Date: Apr 2012
Location: New York
Region: New York
Posts: 102
Just in the front ? Or should I do all 4 corners ? How much are they ?
runthatsleeper is offline   Reply With Quote
Old 11-03-2012, 05:06 AM   #15
Registered Member
Regular
 
bradtaylornator's Avatar
 
Join Date: Oct 2012
Region: Oklahoma
Posts: 169
Quote:
Originally Posted by runthatsleeper
Just in the front ? Or should I do all 4 corners ? How much are they ?
Mine was covered by dealer it was the upper struts on front. They would pop and squeak at real low speeds and over bumps. The dealer said that it is a big issue that ford has looked into. I had two drive around for 2 months with the sound cause the parts were on a national backorder

---------- Post added at 05:06 AM ---------- Previous post was at 05:03 AM ----------

Quote:
Originally Posted by bradtaylornator

Mine was covered by dealer it was the upper struts on front. They would pop and squeak at real low speeds and over bumps. The dealer said that it is a big issue that ford has looked into. I had two drive around for 2 months with the sound cause the parts were on a national backorder
Just to clear up, by big issue i mean the dealer said alot of people the have this issue, Not that it could be a catastrophic failure lol, didn't wanna give anyone the wrong idea
bradtaylornator is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:16 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.