mustang 2012 gt hitting rev limiter @ 135 @ the RACE TRACK - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-10-2013, 01:24 PM   #1
Registered User
Newbie
 
darkmatter's Avatar
 
Join Date: Apr 2013
Location: florida
Region: Florida
Posts: 5
mustang 2012 gt hitting rev limiter @ 135 @ the RACE TRACK

Hello All,

first post here!!!

All accounts of below info is @ the race track on closed runway.

Here is my issue i have a 12 gt auto with 3.73gears boss intake C&l Cai and offroad h pipe no cats..and handling mods. Ever since i installed my 3.73 gears i have been hitting rev limiter at 135mph and car will back off. This is not a normal top end speed as far as i know, the other day i was able to get up to 150mph but 90% of the time i can only get to 135 so myself and my tuner are stumped. I have been well passed 160 before the gears change at the runway track. So what could be wrong something maybe in the tune? what speeds do you guys get to with 3.73 or 4.10 gears? i have put a link to my you tube video showing it. thanks everyone

2012 gt mustang rpm cut off - YouTube
darkmatter is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-10-2013, 03:40 PM   #2
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Did your tune change the speedometer output reading? Is the speedometer/tach giving you the true speed? The higher gear ratio you have from stock is making your driveshaft spin faster for a given RPM; this makes the cars computer think it's going faster than it really is. I'm guessing your speed is off around 25 MPH (going from a 2.73 to a 3.73 as an example).
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 04-10-2013, 03:42 PM   #3
Registered User
Newbie
 
darkmatter's Avatar
 
Join Date: Apr 2013
Location: florida
Region: Florida
Posts: 5
Yes speed is correct i gps it with in 1mph i actual had 3.15 stock before the new 3.73. thank you for your reply though
darkmatter is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-10-2013, 03:46 PM   #4
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Back to the tuner then. If you could reach the speeds before, and the tuner changed for the rear gear, and lifted the top speed (yes?), then the tune has to be at fault.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 04-10-2013, 03:47 PM   #5
Registered Member
Regular
 
acornsmoke's Avatar
 
Join Date: Dec 2012
Location: Boca Raton
Region: Florida
Posts: 536
don't know much but that sounds like a tuner problem
acornsmoke is offline   Reply With Quote
Old 04-10-2013, 05:43 PM   #6
Registered Member
Regular
 
nosympathy's Avatar
 
Join Date: Oct 2012
Location: none
Region: Ohio
Posts: 3,551
Quote:
Originally Posted by acornsmoke View Post
don't know much but that sounds like a tuner problem
Yeeeeep. Tuner needs to get it together.
__________________
MustangEvolution ROCKS MY SOCKS!!!
nosympathy is offline   Reply With Quote
Old 04-10-2013, 08:05 PM   #7
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Who's the tune by? Data logging your car and submitting that to your tuner may help correct your issue.
primer2tone is offline   Reply With Quote
Old 04-10-2013, 08:49 PM   #8
Registered Member
Regular
 
Tominkc's Avatar
 
Join Date: Jan 2011
Region: Kansas
Posts: 374
Send a message via Yahoo to Tominkc
I have a 93 race tune on my 2012 GT with 3:73 gears and I've hit 155 mph on a open track and my rev limiter never comes on since the tune, so it has to be the tune not turning off the limiter!!
Tominkc is offline   Reply With Quote
Old 04-11-2013, 10:59 AM   #9
Registered User
Newbie
 
darkmatter's Avatar
 
Join Date: Apr 2013
Location: florida
Region: Florida
Posts: 5
Quote:
Originally Posted by primer2tone View Post
Who's the tune by? Data logging your car and submitting that to your tuner may help correct your issue.
I use steeda Gus, i always get great tunes with no issues from him, but for some reason we are having this issue. He contacted SCT to have a look at it also i hope we get it fixed soon or i will have to drive to steeda to do-it in person. Thank you all for your insight.
darkmatter is offline   Reply With Quote
Old 04-11-2013, 01:16 PM   #10
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Quote:
Originally Posted by darkmatter View Post

I use steeda Gus, i always get great tunes with no issues from him, but for some reason we are having this issue. He contacted SCT to have a look at it also i hope we get it fixed soon or i will have to drive to steeda to do-it in person. Thank you all for your insight.
Have you tried returning it to stock and check your limiter then?
primer2tone is offline   Reply With Quote
Old 04-11-2013, 01:21 PM   #11
Registered User
Newbie
 
darkmatter's Avatar
 
Join Date: Apr 2013
Location: florida
Region: Florida
Posts: 5
Quote:
Originally Posted by primer2tone View Post
Have you tried returning it to stock and check your limiter then?
No i didn't try to return to stock, because i have to many mods and i am afraid it will not run correctly. But i was able 1 time to get to 150 on this tune and setup. Its like it hits redline before it can shift to 6th, i must have been at a lower speed different gear to do that.

I am waiting to see what sct says now
darkmatter is offline   Reply With Quote
Old 04-11-2013, 01:25 PM   #12
It's not me, it's you.
Regular
Supporter
 
primer2tone's Avatar
 
Join Date: Dec 2010
Location: Corpus Christi
Region: Texas
Posts: 6,752
Sixth is more like an overdrive on our cars anyway. Yeah, get SCT to got through it. Best of luck. Let us know what they find.
primer2tone is offline   Reply With Quote
Old 04-12-2013, 09:42 AM   #13
Registered User
Newbie
 
darkmatter's Avatar
 
Join Date: Apr 2013
Location: florida
Region: Florida
Posts: 5
update

Here is an update to issue i will try it tonight when i get to tthe track and let you know if it worked.
Tom, I’ve had some expert minds from SCT and other sources look at the file, none of them are seeing a "smoking gun" in this one. All of the rev limiters appear in order and we are not sure how the shift would be affected, but what we did notice based on the shift schedule is when you punch it at 85MPH, it looks like (if the RPM reference is correct) that it will downshift to 3rd gear. I then have it set up to command the upshift to 4th around 102mph. That might be the coincidence we are looking for. It may be that after the downshift to 3rd, not enough time has elapsed to command the 3-4 shift and the computer can’t react fast enough.

Is that what is happening is that you are downshifting to 3rd at 85mph? If so, the fix may be to change the downshift points so that it will downshift into 4th at 85mph and not 3rd. I have spent the better part of an hour reworking the entire shift strategies, converter lock ups, torque reductions, etc.
I want you to try this file here and see how it behaves. Let me know.
darkmatter is offline   Reply With Quote
Old 09-19-2013, 12:52 PM   #14
Registered Member
Regular
 
Intense.'s Avatar
 
Join Date: Jul 2013
Location: Central
Region: Kentucky
Posts: 72
Quote:
Originally Posted by darkmatter View Post
Here is an update to issue i will try it tonight when i get to tthe track and let you know if it worked.
Tom, I’ve had some expert minds from SCT and other sources look at the file, none of them are seeing a "smoking gun" in this one. All of the rev limiters appear in order and we are not sure how the shift would be affected, but what we did notice based on the shift schedule is when you punch it at 85MPH, it looks like (if the RPM reference is correct) that it will downshift to 3rd gear. I then have it set up to command the upshift to 4th around 102mph. That might be the coincidence we are looking for. It may be that after the downshift to 3rd, not enough time has elapsed to command the 3-4 shift and the computer can’t react fast enough.

Is that what is happening is that you are downshifting to 3rd at 85mph? If so, the fix may be to change the downshift points so that it will downshift into 4th at 85mph and not 3rd. I have spent the better part of an hour reworking the entire shift strategies, converter lock ups, torque reductions, etc.
I want you to try this file here and see how it behaves. Let me know.
Just in case I come across this problem, how did it turn out?
__________________
'14 Race Red GT M6, premium, comfort package, Steeda stb
Intense. is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Tags
2012 gt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



09:06 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.