Car problems - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-16-2013, 06:31 AM   #1
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
Car problems

Hey guys been reading this forum for a while and thought I would make my first thread with some questions.

I have a 2013 5.0 premium that I got last august. So far the car only has 6800km on it and I'm starting to have issues.

The list so far
- ticking from the engine
- noisy trans
- won't always let me go into 4th or 5th (standard)
- my seat heaters still don't work after having them in twice and ford is now telling me it's normal.
- a lot of rattles in the cabin.

So my question is does anyone have any ideas or suggestions, or even some of the same problems?
Nizmo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-16-2013, 06:37 AM   #2
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
Take it to a different dealership, none of your problems are normal. If that doesn't work, call Ford.
tc x 4 is offline   Reply With Quote
Old 05-16-2013, 06:47 AM   #3
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
Yea ford was gonna be my next call. I had called them about the seats not working and they are the ones that said it was normal in the first place
Nizmo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-16-2013, 06:57 AM   #4
Registered Member
Regular
 
tc x 4's Avatar
 
Join Date: Jan 2012
Region: Indiana
Posts: 3,783
I think you have to give them 3 chances to fix it, then file papers for the lemon law. It's ashamed but it does happen and it sounds like you got one.
tc x 4 is offline   Reply With Quote
Old 05-16-2013, 07:01 AM   #5
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
Yea that's what ive been thinking. I live in Ontario and we dont have "lemon law" but other things we can do
Nizmo is offline   Reply With Quote
Old 05-16-2013, 10:02 AM   #6
Registered Member
Regular
 
GE3G's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 721
Where abouts in ontario are you from.... At idle the ticking is normal due to the tivct variable valve timing system... Or is it a tick that happens every 5 seconds? An the trannys on these cars are alittle clunky but usually when they warm up there fine... I would take it to the dealer tho cause u still have warentee
GE3G is offline   Reply With Quote
Old 05-16-2013, 10:13 AM   #7
Registered Member
Regular
 
Gordito's Avatar
 
Join Date: Mar 2013
Location: CG
Region: Arizona
Posts: 374
The only issue I've had is going into 3rd sometimes.. sometimes it's real hard to get it in. But that could just be me not doing something right because its my 1st manual.. but I read about it in other threads so I know what I have to do.. Hope you get a new Mustang or everything fixed soon
Gordito is offline   Reply With Quote
Old 05-16-2013, 10:47 AM   #8
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
It's a different tick than the tivct. Sounds like either a knock or a bad lifter. It has issues going into gear even once it's warm. I'm gonna call them today and get them to check it out.

Thanks a lot guys I'll keep you posted on updates
Nizmo is offline   Reply With Quote
Old 05-16-2013, 10:51 AM   #9
Registered Member
Regular
 
GE3G's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 721
You in ontario canada?
GE3G is offline   Reply With Quote
Old 05-16-2013, 10:52 AM   #10
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
Yea about an hour from Toronto
Nizmo is offline   Reply With Quote
Old 05-16-2013, 10:54 AM   #11
Registered Member
Regular
 
nosympathy's Avatar
 
Join Date: Oct 2012
Location: none
Region: Ohio
Posts: 3,551
Quote:
Originally Posted by Gordito View Post
The only issue I've had is going into 3rd sometimes.. sometimes it's real hard to get it in. But that could just be me not doing something right because its my 1st manual.. but I read about it in other threads so I know what I have to do.. Hope you get a new Mustang or everything fixed soon
you just have to let the centering spring center the shifter and push it forward. I've learned to do this and works fine for me. If I try and push the shifter straight into 3rd I often can't get in it.

I am replacing my shifter with an MGW trying to remedy this.
__________________
MustangEvolution ROCKS MY SOCKS!!!
nosympathy is offline   Reply With Quote
Old 05-16-2013, 11:17 AM   #12
Registered Member
Regular
 
GE3G's Avatar
 
Join Date: Jan 2012
Region: Canada
Posts: 721
Right on dude im in toronto... You should come to ERTEFA tonight.. Hwy7 and weston massive car meet every thursday night 1000 + cars.. I cruise down with abunch of 5.0s
GE3G is offline   Reply With Quote
Old 05-16-2013, 01:50 PM   #13
Registered User
Newbie
 
Join Date: Dec 2012
Location: Guelph
Region: Canada
Posts: 6
Wow will have to check that out some time. If I can find a day I don't work lol
Nizmo is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:02 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.