Front end noise - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-15-2013, 09:18 PM   #1
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Front end noise

I have gt500 mounts, and they squeek like a mother f****** when there is suspension travel at low speeds. When I do CPR on my front end I can hear my passenger side mount squeaking but in the car sometimes it sounds like both sides are squeaking.

Please tell me there is a fix for this because I literally want to punch a hole in my dash whenever I go under 30 miles an hour. What should I trouble shoot? Are these things Greasable? Maybe the spindle nut is loose? Frustrated : (
Mikeyt03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2013, 09:34 PM   #2
Registered User
Newbie
 
BlackFiveOh813's Avatar
 
Join Date: Jul 2013
Location: Jacksonville, FL
Region: Florida
Posts: 4
There is a technical service bulletin out by for for 11-13 Mustangs front lower control arm hydro bushings, that has to deal with suspension noise at low speeds over things like speed bumps and what not, if thats the case Ford should replace them for free
BlackFiveOh813 is offline   Reply With Quote
Old 07-15-2013, 10:20 PM   #3
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Quote:
Originally Posted by BlackFiveOh813 View Post
There is a technical service bulletin out by for for 11-13 Mustangs front lower control arm hydro bushings, that has to deal with suspension noise at low speeds over things like speed bumps and what not, if thats the case Ford should replace them for free
It's not that. I had that issue too, but it's not the same sound. Unless lowering my car made the sound different. They replaced the drivers side lca and not the passenger side. So that's initially what I thought. But it didn't start really until I lowered my car. I'll have ford check it out, but I think it's my mounts.
Mikeyt03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2013, 10:57 PM   #4
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Im sure you did, but did you use the stock lower spring isolators from the stock springs? If not that will definitely cause squeaking.
Other than that, double check the front strut bolts, as well as the sway bar end link bolts. If you reused the original bolts, make sure to put locktite on them, as they can back out. According to Ford they are all one time use bolts. But most of us (myself included) reuse the stockers and just add locktite.
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 07-15-2013, 11:06 PM   #5
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Quote:
Originally Posted by Evil2014GT View Post
Im sure you did, but did you use the stock lower spring isolators from the stock springs? If not that will definitely cause squeaking.
Other than that, double check the front strut bolts, as well as the sway bar end link bolts. If you reused the original bolts, make sure to put locktite on them, as they can back out. According to Ford they are all one time use bolts. But most of us (myself included) reuse the stockers and just add locktite.
Isolaters are on. Locktite in all bolts, but I'm going to have my shop check the torque specs again. It's a very rubbery squeak. Definitely not metal on metal.
Mikeyt03 is offline   Reply With Quote
Old 07-15-2013, 11:11 PM   #6
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Quote:
Originally Posted by Mikeyt03 View Post

Isolaters are on. Locktite in all bolts, but I'm going to have my shop check the torque specs again. It's a very rubbery squeak. Definitely not metal on metal.
Hmm. Did you get new struts as well?
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 07-16-2013, 12:17 AM   #7
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Quote:
Originally Posted by Evil2014GT View Post

Hmm. Did you get new struts as well?
Yup koni strt
Mikeyt03 is offline   Reply With Quote
Old 07-16-2013, 12:29 AM   #8
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Are you sure your not just hearing the sound of the strut compressing? I have thr str.ts as well, and i have definitely noticed they are louder when compressed then the stock struts. It does sound like a rubber rub a bit.
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 07-16-2013, 01:01 AM   #9
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Quote:
Originally Posted by Evil2014GT View Post
Are you sure your not just hearing the sound of the strut compressing? I have thr str.ts as well, and i have definitely noticed they are louder when compressed then the stock struts. It does sound like a rubber rub a bit.
No I'm sure. I hear it over bumps too.
Mikeyt03 is offline   Reply With Quote
Old 07-16-2013, 06:13 AM   #10
Registered User
Newbie
 
Phoenix335's Avatar
 
Join Date: Sep 2012
Region: Washington
Posts: 18
I have this as well, I think it is the sway bar bushings.
Phoenix335 is offline   Reply With Quote
Old 07-16-2013, 07:11 AM   #11
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
Quote:
Originally Posted by Phoenix335 View Post
I have this as well, I think it is the sway bar bushings.
It has to be my strut mount. If it were my sway bar I would heard it before my suspension install.
Mikeyt03 is offline   Reply With Quote
Old 07-16-2013, 09:00 AM   #12
Road Trip!
 
Join Date: Jul 2012
Region: Florida
Posts: 1,684
My dash will have a hole in it by the end of the week if I don't figure this out.. I'm thinking about just dropping it off to steeda and having the put in the HD mounts.
Mikeyt03 is offline   Reply With Quote
Old 07-16-2013, 09:54 AM   #13
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Quote:
Originally Posted by Mikeyt03 View Post
My dash will have a hole in it by the end of the week if I don't figure this out.. I'm thinking about just dropping it off to steeda and having the put in the HD mounts.
Cant go wrong with steeda or maximum motorsport plates. Thats weird the GT500s are making noise so quick though. Maybe you got a bad set.
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



11:49 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.