launch control question - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-26-2013, 08:02 AM   #1
Registered User
Newbie
 
RiceKillerGT's Avatar
 
Join Date: Mar 2013
Location: Philadelphia
Region: Pennsylvania
Posts: 18
Hey guys, taking the 5.0 back to the track tomorrow to see how she does after all the mods. I was wondering on where you guys think I should be launching, I have launch control on the car at 3k RPM. Last time I was at the track (no mods, just a tune) I would hook upon launch but then bog out for a second. 2.2 60 foot but ran out 12.7 @ 114 stock on old slicks that still seem to hook. Now, last time I did forget to hold the T/C button down for 5 seconds I just tapped it. (still did a smoky burnout haha) do you think that could cause my issue? Is 3k good to launch at? Thanks! My car currently has JLT cai, O/R H pipe, axle backs and a tune. 6 speed manual transmission
RiceKillerGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-26-2013, 08:07 AM   #2
Registered Member
Regular
 
thecos54's Avatar
 
Join Date: Sep 2012
Location: Virginia Beach
Region: Virginia
Posts: 163
I am surely not qualified to answer this... Lol just getting into this. Just wanted to see what year car you have and what axle backs you have... Thanks..
thecos54 is offline   Reply With Quote
Old 08-26-2013, 08:09 AM   #3
Registered User
Newbie
 
RiceKillerGT's Avatar
 
Join Date: Mar 2013
Location: Philadelphia
Region: Pennsylvania
Posts: 18
Haha, It's a 2012 5.0 and I currently have roush axle backs. Love the sound but get too raspy at WOT. Gonna be switching them up for outlaws shortly
RiceKillerGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-26-2013, 08:19 AM   #4
Registered Member
Regular
 
thecos54's Avatar
 
Join Date: Sep 2012
Location: Virginia Beach
Region: Virginia
Posts: 163
Lol, alright. That's what I have also... I have a Boss IM also, just haven't taken it to the track... Thinking about a SC in the next few months, but alot of cash there. I have a 2011. I like my Roush AB... But if I redo the headers some day.. I'll probably go with Borla's...
thecos54 is offline   Reply With Quote
Old 08-26-2013, 08:44 AM   #5
Registered User
Newbie
 
RiceKillerGT's Avatar
 
Join Date: Mar 2013
Location: Philadelphia
Region: Pennsylvania
Posts: 18
Nice, boss manifold is going on soon but not until I get gears and headers. Don't wanna lose too much power down low
RiceKillerGT is offline   Reply With Quote
Old 08-26-2013, 09:17 AM   #6
Registered Member
Regular
 
Join Date: Dec 2011
Region: Canada
Posts: 2,974
With the MT, just keep raising your launch rpm until you blow the tires off. No one can answer you with more than that. I launch at ~5000, depending on what the track'll hold that day.

What launch control do you have...? It sounds from your description you mean the factory traction/stability control and that needs to be ALL off. I put switch in line with the check circuit in the footwell fuse panel so I can turn every nanny off completely with one action.
__________________
2014 Premium GT, SGM, Brembo, Auto, Tech, Comfort, etc. GT500s, Steeda UCA, VMP auto N/A tune. 100 shot nitrous on BBR tune. Best e/t 11.42 at 120.64

2012 Premium GT, Candy Red, Brembo package, 3.73, MT82, Comfort, Tech, et al. Procal tune, Roush UCA, UMI poly LCA, GT500s, Steeda red bracket, Hoosier 28x10x16 bias drags. Best e/t 11.91 at 115.23 RIP
5LHO is offline   Reply With Quote
Old 08-26-2013, 09:19 AM   #7
Registered User
Newbie
 
RiceKillerGT's Avatar
 
Join Date: Mar 2013
Location: Philadelphia
Region: Pennsylvania
Posts: 18
No, I have launch control custom tuned in

---------- Post added at 08:19 AM ---------- Previous post was at 08:19 AM ----------

Hold the clutch, slam the gas it holds at 3k
RiceKillerGT is offline   Reply With Quote
Old 08-26-2013, 09:23 AM   #8
Registered Member
Regular
 
Join Date: Dec 2011
Region: Canada
Posts: 2,974
Ok, cool. Jack it up to where I'm at and see what that does for you. I can almost pull a tire from there, on the BBP suspension. Still doesn't 60 super strong but, it ain't no drag car, just a street car with slicks.
__________________
2014 Premium GT, SGM, Brembo, Auto, Tech, Comfort, etc. GT500s, Steeda UCA, VMP auto N/A tune. 100 shot nitrous on BBR tune. Best e/t 11.42 at 120.64

2012 Premium GT, Candy Red, Brembo package, 3.73, MT82, Comfort, Tech, et al. Procal tune, Roush UCA, UMI poly LCA, GT500s, Steeda red bracket, Hoosier 28x10x16 bias drags. Best e/t 11.91 at 115.23 RIP
5LHO is offline   Reply With Quote
Old 08-26-2013, 09:34 AM   #9
Registered User
Newbie
 
RiceKillerGT's Avatar
 
Join Date: Mar 2013
Location: Philadelphia
Region: Pennsylvania
Posts: 18
Yup, only negative is that I can't remotely change it, so if I jack it up and it fails, I'll have to run on my performance tune at the track to turn launch control off lol
RiceKillerGT is offline   Reply With Quote
Old 08-26-2013, 10:06 AM   #10
Registered Member
Regular
 
Join Date: Dec 2011
Region: Canada
Posts: 2,974
Well, that's bloody useless....
__________________
2014 Premium GT, SGM, Brembo, Auto, Tech, Comfort, etc. GT500s, Steeda UCA, VMP auto N/A tune. 100 shot nitrous on BBR tune. Best e/t 11.42 at 120.64

2012 Premium GT, Candy Red, Brembo package, 3.73, MT82, Comfort, Tech, et al. Procal tune, Roush UCA, UMI poly LCA, GT500s, Steeda red bracket, Hoosier 28x10x16 bias drags. Best e/t 11.91 at 115.23 RIP
5LHO is offline   Reply With Quote
Old 08-26-2013, 10:07 AM   #11
Registered Member
Regular
 
Napoleon85's Avatar
 
Join Date: Aug 2011
Region: Ohio
Posts: 3,045
Quote:
Originally Posted by RiceKillerGT View Post
Hey guys, taking the 5.0 back to the track tomorrow to see how she does after all the mods. I was wondering on where you guys think I should be launching, I have launch control on the car at 3k RPM. Last time I was at the track (no mods, just a tune) I would hook upon launch but then bog out for a second. 2.2 60 foot but ran out 12.7 @ 114 stock on old slicks that still seem to hook. Now, last time I did forget to hold the T/C button down for 5 seconds I just tapped it. (still did a smoky burnout haha) do you think that could cause my issue? Is 3k good to launch at? Thanks! My car currently has JLT cai, O/R H pipe, axle backs and a tune. 6 speed manual transmission
Not fully disabling advancetrac will absolutely cause bog and all sorts of other performance issues.

Quote:
Originally Posted by RiceKillerGT View Post
Nice, boss manifold is going on soon but not until I get gears and headers. Don't wanna lose too much power down low
Good call.

Quote:
Originally Posted by RiceKillerGT View Post
No, I have launch control custom tuned in

---------- Post added at 08:19 AM ---------- Previous post was at 08:19 AM ----------

Hold the clutch, slam the gas it holds at 3k
Quote:
Originally Posted by RiceKillerGT View Post
Yup, only negative is that I can't remotely change it, so if I jack it up and it fails, I'll have to run on my performance tune at the track to turn launch control off lol
Is this being done with the SCT options? You can't adjust it when loading the tune from the handheld? Who tuned this in for you?
__________________
Official Exhaust Thread Troller
Napoleon85 is offline   Reply With Quote
Old 08-26-2013, 05:29 PM   #12
Registered Member
Regular
 
Mr. Anderson's Avatar
 
Join Date: Aug 2013
Location: Moore
Region: Oklahoma
Posts: 44
+1, who is tuning in your launch control, I wasn't aware that they could do this, if so can you change the RPM at the track?
as to answer for your question. unfortunately that's gonna depend on how well your tracks prepped. and that just means playing with air pressure in your slicks and rpms at launch. If your running slicks I would start at 16psi and RPM's around 5k and go from there.
Mr. Anderson is offline   Reply With Quote
Old 08-26-2013, 06:53 PM   #13
Registered Member
Regular
 
Join Date: Aug 2013
Location: Bristol
Region: Connecticut
Posts: 22
Quote:
Originally Posted by RiceKillerGT View Post
Haha, It's a 2012 5.0 and I currently have roush axle backs. Love the sound but get too raspy at WOT. Gonna be switching them up for outlaws shortly
Do you by any chance have a vid of how yours sounds? I have Roush AB and i want an o/r h pipe myself.
RyanB is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:11 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.