SCT tuner issue - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-09-2013, 04:24 PM   #1
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
SCT tuner issue

So I just received my SCT tuner (model 3000) loaded with 93 tune from Steeda. I went to install the tune, download went all the way to 100%, my guages moved and got lights on the dash. The tuner then said download failed. Return to stock. I was able to return the vehicle back to stock and all work as advertised. About an hour later, I tried it again. Same exact thing happened except this time as soon as I tried to "return to stock" it immediately said "download failed". Longer story short, I finally was able to get it back to stock tune and car runs normal (presumably). Pretty pissed off. I talked to Steeda and they were of zero help. I was told call SCT and that's all he offered. Been on hold with SCT for 52 mins now. Any suggestions? Note: I had everything turned off, I.e. Radio, lights, doors shut, all air off.
Crewchief15 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-09-2013, 04:26 PM   #2
Registered Member
Regular
 
jayman33's Avatar
 
Join Date: Nov 2012
Region: North Carolina
Posts: 515
Did you have the tuner updated?
__________________
A boss.....
jayman33 is offline   Reply With Quote
Old 12-09-2013, 04:28 PM   #3
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
Quote:
Originally Posted by jayman33 View Post
Did you have the tuner updated?
Well I was told to only update the tuner prior to uploading new tunes. I was told by a friend who uses the same tuner and is experienced. So no I didn't. He could have given me bad info but I've never used one so I'm clueless essentially. I tried to follow the directions exactly. I doesn't state to update the device or anything like that.
Crewchief15 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-09-2013, 04:41 PM   #4
Registered Member
Regular
 
jayman33's Avatar
 
Join Date: Nov 2012
Region: North Carolina
Posts: 515
I would update the device, then reload the tune.
__________________
A boss.....
jayman33 is offline   Reply With Quote
Old 12-09-2013, 05:01 PM   #5
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
Quote:
Originally Posted by jayman33 View Post
I would update the device, then reload the tune.
Checked. "Device is up to date". There was no update needed apparently.
Crewchief15 is offline   Reply With Quote
Old 12-09-2013, 07:26 PM   #6
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Thats weird. I had no problems with mine. Definitely sounds like an issue with the sct, and not the tune though. Keep us posted on what sct says.

Ive heard from several people that sct has some of the worst customer service out there, so good luck man.
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 12-09-2013, 07:29 PM   #7
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
Quote:
Originally Posted by Evil2014GT View Post
Thats weird. I had no problems with mine. Definitely sounds like an issue with the sct, and not the tune though. Keep us posted on what sct says. Ive heard from several people that sct has some of the worst customer service out there, so good luck man.
Oh, not a good experience so far with SCT. Hour and change on hold so I said f it. I guess I'll send Steeda my vehicle strategy to be sure that Ford didn't flash me and not put a new sticker on resulting in me giving them the wrong code. As of right now, I have a $300 code reader.
Crewchief15 is offline   Reply With Quote
Old 12-09-2013, 07:39 PM   #8
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Quote:
Originally Posted by Crewchief15 View Post

Oh, not a good experience so far with SCT. Hour and change on hold so I said f it. I guess I'll send Steeda my vehicle strategy to be sure that Ford didn't flash me and not put a new sticker on resulting in me giving them the wrong code. As of right now, I have a $300 code reader.
Just curious did you buy the car new or used?
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 12-09-2013, 07:40 PM   #9
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
Quote:
Originally Posted by Evil2014GT View Post
Just curious did you buy the car new or used?
Bought it brand new. It's a 14. Couldn't have been a previous performance tune installed
Crewchief15 is offline   Reply With Quote
Old 12-09-2013, 07:48 PM   #10
Registered Member
Regular
 
Evil2014GT's Avatar
 
Join Date: Mar 2013
Location: Northern VA
Region: Alabama
Posts: 1,579
Quote:
Originally Posted by Crewchief15 View Post

Bought it brand new. It's a 14. Couldn't have been a previous performance tune installed
Gotcha. Yeah that was what i was thinking if it was used.
__________________
2014 Mustang GT Base MT82 -Stock 3.73s, Roush axleback, Steeda 93R tune, Steeda Hi-flow X-pipe, 19" Charcoal AMR's, smoked front and rear side markers, 20% tint, quarter window louvers, Steeda Ultralite springs, Koni Str.t shocks/struts, MM camber plates, J&M adjustable panhard bar, BMR LCAs and relo brackets, Barton shifter and 2-post bracket, Black Modern Billet Grilles
Evil2014GT is offline   Reply With Quote
Old 12-09-2013, 09:29 PM   #11
Registered Member
Regular
 
jayman33's Avatar
 
Join Date: Nov 2012
Region: North Carolina
Posts: 515
Even if your PCM was wrong your tune would still load onto the car. This could be a number of things... starting with a hardware problem.
__________________
A boss.....
jayman33 is offline   Reply With Quote
Old 12-09-2013, 09:33 PM   #12
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
Quote:
Originally Posted by jayman33 View Post
Even if your PCM was wrong your tune would still load onto the car. This could be a number of things... starting with a hardware problem.
Yeah, I'm going to try and see if SCT will give me another stock tune to load to make sure it's not the tune. I don't know man, this modding thing may not be for me lol. I have bad luck
Crewchief15 is offline   Reply With Quote
Old 12-24-2013, 03:42 AM   #13
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
UPDATE:

So, after troubleshooting to no end with SCT, I had Steeda send me a revised tune as a last ditch attempt. I finally found time to upload the new tune sent from Gus at Steeda to my device. (Was no fault of Steeda or Gus. The tune was sent promptly. I just needed to find time to mess with it) I loaded the new/revised tune to my vehicle without issue. The vehicle started perfectly. Unfortunately it's pouring rain out so I couldn't notice much difference in performance for obvious reasons. I don't know for sure what the problem was before but clearly it wasn't hardware related. Either way, happy this isn't lingering in the back of my mind every day anymore!
Crewchief15 is offline   Reply With Quote
Old 12-24-2013, 05:33 AM   #14
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
So, no fault of the SCT device or SCT. In this case, it was a bad tune file. Correct?
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 12-24-2013, 05:35 AM   #15
Registered Member
Regular
 
Crewchief15's Avatar
 
Join Date: Aug 2013
Location: Charleston
Region: South Carolina
Posts: 177
I would guess so, yes. The only variable that changed was the tune. It was just weird that the previous (failed) tune went all the way to 100% and then failed numerous times.
Crewchief15 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



05:46 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.