Help with popping noise - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 01-20-2014, 11:44 PM   #1
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Help with popping noise

2011 5.0 with k-springs.. When I back up and have the wheel turned (not while I'm turning) I get a pretty hard loud popping sound coming from the front end. The wheel has to be turned at least half way from what it seems. Doesn't do it every time but does it pretty often. Seems worse if I'm on an incline.. Any ideas?
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-21-2014, 01:46 PM   #2
Registered Member
Regular
 
bellski's Avatar
 
Join Date: Apr 2012
Region: Wisconsin
Posts: 283
sounds like your strut mounts are shot.
__________________
2011 GT M6 Premium- Mechanical upgrades include: Boss 302 Intake, JLT CAI, JPC LT Headers, Off Road X Pipe, and mufflers, 410 Gears, Granatelli Hot Street Coil Packs, 93 Octane Ghost Cam Tune by Jon Lund,Eibach ProKit Springs,shocks, struts and sway bars, BMR LCA's, Strut Tower Brace, and adjustable Panhard Bar, Maximum Motorsports Camber/Caster Plates, Barton Shortshifter and bracket, Wilwood Superlight Brakes w/6 and 4 piston calipers, Steeda Spyders- 9-1/2X20 with 275/35 and 11X20 with 315/35 Nitto Invos.
bellski is offline   Reply With Quote
Old 01-21-2014, 01:48 PM   #3
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Like I said not WHILE turning.. Already replaced the mounts. This is way louder and harder
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-22-2014, 10:11 AM   #4
Registered Member
Regular
 
Join Date: Sep 2013
Location: WPB
Region: Florida
Posts: 31
Maybe something isn't tightened properly. Could be a possibility that when you turn the strut is moving in and out of the bottom knuckle.
1ststang is offline   Reply With Quote
Old 01-26-2014, 06:12 PM   #5
Registered Member
Regular
 
scott_0's Avatar
 
Join Date: Jan 2014
Posts: 774
a lot of the time, this noise is the sway bar end links, they aren't tight enough most likely

Sent from S4 using tapatalk
__________________
2016 DIB GT Premium A6, Borla S-type axle backs, Rovos Pretoria wheels 20x8.5/20x10, Nitto N555G2 tires 255/35/20 and 275/35/20, Koni yellows, BMR springs
scott_0 is offline   Reply With Quote
Old 01-27-2014, 12:51 AM   #6
Registered Member
Regular
 
ksnapp's Avatar
 
Join Date: Nov 2013
Location: Oregon
Region: Oregon
Posts: 72
^ What they said, I would just re check everything =)

Kyle
ksnapp is offline   Reply With Quote
Old 01-28-2014, 01:55 PM   #7
Registered Member
Regular
 
Droidman86's Avatar
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 50
I'm having this same issue, already ordered I'm just waiting for it to arrive and see if that gets rid of the popping noise.
Droidman86 is offline   Reply With Quote
Old 01-28-2014, 03:31 PM   #8
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Quote:
Originally Posted by Droidman86 View Post
I'm having this same issue, already ordered I'm just waiting for it to arrive and see if that gets rid of the popping noise.

Does yours do it while turning the wheel?
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Old 01-28-2014, 03:34 PM   #9
Registered Member
Regular
 
Droidman86's Avatar
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 50
Quote:
Originally Posted by 11stangGT View Post
Does yours do it while turning the wheel?
Yes, only does it while turning the wheel at very low speeds.
__________________
2012 Mustang 5.0
Steeda CAI, Boss Manifold, 3.73 Gears, E85, NX Wet 150 Shot, AED Tuned, LT Headers, Aluminum Driveshaft, Mcleod Twin Disc Clutch, KB Bap, N2MB wot box w/ window switch.
Droidman86 is offline   Reply With Quote
Old 01-28-2014, 03:45 PM   #10
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Not what mine does.. Like I said in the opening post NOT WHILE turning but with the wheel turned. Ur issue is definitely strut mounts though.
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Old 01-29-2014, 02:44 AM   #11
Registered Member
Regular
 
Red Stallion 11's Avatar
 
Join Date: Oct 2011
Region: Florida
Posts: 478
I had a similar problem in my old 11 3.7. I ended up being the power steering rack. Ford replaced it under the warranty. There are issues with the electronic racks.

Before you go to that extreme I would get underneath and start smacking things around with a rubber mallot, see if there is anything else going wrong under there.
Red Stallion 11 is offline   Reply With Quote
Old 01-29-2014, 11:55 PM   #12
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Quote:
Originally Posted by Red Stallion 11 View Post
I had a similar problem in my old 11 3.7. I ended up being the power steering rack. Ford replaced it under the warranty. There are issues with the electronic racks.

Before you go to that extreme I would get underneath and start smacking things around with a rubber mallot, see if there is anything else going wrong under there.

When did yours do it exactly? Mine does it with the wheel turned about 3/4 and then start to back up, with the wheel stationary. It sounds like I have a 4wd and my cv axles are getting in a bind.
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Old 01-30-2014, 12:31 AM   #13
Registered Member
Regular
 
mark_ash0426's Avatar
 
Join Date: Sep 2013
Location: California
Region: California
Posts: 443
Quote:
Originally Posted by 11stangGT View Post
When did yours do it exactly? Mine does it with the wheel turned about 3/4 and then start to back up, with the wheel stationary. It sounds like I have a 4wd and my cv axles are getting in a bind.

I started a thread about a somewhat similar problem but nobody was able to help me
My problem is that every time im driving and i go through like little road bumps my rear squeaks
My thoughts is it would be the panhard bar ?
Any thoughts guys ?
mark_ash0426 is offline   Reply With Quote
Old 02-06-2014, 08:11 AM   #14
Registered User
Newbie
 
42NATO's Avatar
 
Join Date: Apr 2013
Location: Long Island
Region: New York
Posts: 9
I think it's your sway bar end links. I'm lowered with k springs as well and get an occasional loud pop when turning. I bought new end links off of AM just haven't put them on yet. They say on there that it's normal problem when lowering your car.
42NATO is offline   Reply With Quote
Old 03-23-2014, 01:43 PM   #15
Registered User
Newbie
 
Join Date: Mar 2014
Posts: 1
I have a 96 cobra and am having a popping sound coming front the left rear end. Can feel it with your feet if sitting behind the driver. It seems to be worst when I am in first or second and am getting into it getting on the highway. Any ideas of what can be causing it?
missouri96cobra is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hissing Noise JetLife 01GT 1996-2004 Mustang GT 14 12-03-2013 01:03 PM
Car still makes loud noise when going over bumps Coltonhess 1996-2004 Mustang GT 8 07-23-2013 10:35 PM
High pitched engine noise whine cjd_1986 2005-2010 V6 Mustang 4 01-16-2012 12:34 PM
Clutch noise 02 mustang gt mkw037 1996-2004 Mustang GT 5 09-05-2011 09:14 AM

» Like Us On Facebook



05:42 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.