Hitting the limiter when pumping Fuel - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-25-2014, 12:53 PM   #1
Registered Member
Regular
 
Join Date: Aug 2013
Location: Dallas TX
Region: Texas
Posts: 63
Hitting the limiter when pumping Fuel

Just recently, when clearly I have no gas in the car, the pump begins to hit the limiter when putting in fuel. Very odd. The odometer says "Empty" but it keeps clicking after just a few seconds of pumping gas. I would have to refuel almost everyday because I can't put enough gas in without it clicking constantly.

What is going on here? Has anyone had problems with this?

Someone said my fuel line sensor could be burnt/melted from my exhaust.

P.S. - I own a 2014 GT if that helps.
seville is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-25-2014, 12:57 PM   #2
Registered Member
Regular
 
olds442111's Avatar
 
Join Date: Feb 2014
Location: Hammond
Region: Louisiana
Posts: 303
Send a message via AIM to olds442111
Have you tried pulling the nozzle out just a bit? Mine will do this at some stations, and I pull the nozzle out a bit and it fills as normal.
__________________
White 2014 GT coupe / Auto Trans / Louisiana
olds442111 is offline   Reply With Quote
Old 02-25-2014, 01:05 PM   #3
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
Quote:
Originally Posted by olds442111 View Post
Have you tried pulling the nozzle out just a bit? Mine will do this at some stations, and I pull the nozzle out a bit and it fills as normal.

+1
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-25-2014, 01:07 PM   #4
Registered Member
Regular
 
LuisBlackGT's Avatar
 
Join Date: Feb 2014
Location: West Palm Beach
Region: Florida
Posts: 334
Try pulling the nozzle out because the way the gas might be coming it it could touch the outside of the nozzle which would make it click

---------- Post added at 02:07 PM ---------- Previous post was at 02:06 PM ----------

Also try pumping on a slower mode
__________________
2014 Black Mustang GT. 20" Amr wheels, Sr Performance lowering springs 1.5", stillen front chin, mmd window louvers, roush AB exhaust. FOLLOW ME ON INSTAGRAM: @barrios_Luis
LuisBlackGT is offline   Reply With Quote
Old 02-25-2014, 05:48 PM   #5
Registered Member
Regular
 
Join Date: Aug 2013
Location: Dallas TX
Region: Texas
Posts: 63
Yes I have tried all different kinds of gas stations and still no good. Also tried pulling it out slightly about an inch and still no good. Will need to bring it to dealership. So unfortunate.
seville is offline   Reply With Quote
Old 02-26-2014, 11:14 AM   #6
Registered Member
Regular
 
Stangholio's Avatar
 
Join Date: Jun 2013
Location: San antonio
Region: Texas
Posts: 222
When I read the title I thought rev limiter while pumping fuel. Wow glad that wasn't it.
__________________
GHIGitty
Stangholio is offline   Reply With Quote
Old 02-26-2014, 11:17 AM   #7
Registered Member
Regular
 
11stangGT's Avatar
 
Join Date: Apr 2011
Region: Arkansas
Posts: 1,541
That's what drew me in as well lol
__________________
2011 5.0
Bama 93 race tune, bbk o/r xpipe, gt500 axle backs, frpp k-springs, steeda rear lca's, 3d carbon 3d500 wing, boss/cs front fascia w boss brake cooling kit, plenty more...
11stangGT is offline   Reply With Quote
Old 02-26-2014, 11:33 AM   #8
Registered Member
Regular
 
LuisBlackGT's Avatar
 
Join Date: Feb 2014
Location: West Palm Beach
Region: Florida
Posts: 334
I thought the same thing, I was like doesn't that car have to be on lol?
__________________
2014 Black Mustang GT. 20" Amr wheels, Sr Performance lowering springs 1.5", stillen front chin, mmd window louvers, roush AB exhaust. FOLLOW ME ON INSTAGRAM: @barrios_Luis
LuisBlackGT is offline   Reply With Quote
Old 02-26-2014, 12:42 PM   #9
Registered Member
Regular
 
KSconvert's Avatar
 
Join Date: Dec 2013
Location: Wichita
Region: Kansas
Posts: 424
I work at a gas station and get questions like this all the time. You'd be surprised how many people get mad and/or blame us for their tanks only taking 1-2 gallons when they're on empty. It could be several things. There could be too much pressure, filling too fast, gas splashing inside the car's hose, the angle of the nozzle, etc. I haven't had this issue with this car, but have had cars in the past that did this regularly.

I would suggest either taking it slower and seeing how that works, move the nozzle around, just experiment really. If it's getting to be that big of an issue, try taking it back to the dealer and have them look at it.
__________________
2014 GT MT aka: Ruffian-
3.73 gears, Roush AB, BBR O/R x-pipe, JLT intake, BMR panhard bar, BMR lowers and brackets, FRPP 47# injectors, Lund E85 tune, SR springs, MGW shifter, 416rwhp/393rwtq
KSconvert is offline   Reply With Quote
Old 02-27-2014, 01:06 PM   #10
Registered Member
Regular
 
A1ex's Avatar
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 110
happens in my jeep at times, ive been told it can be air that gets in. like others said, try moving the nozzle around a bit or pulling out a bit, pulling out is always a good thing hehehe
__________________
2014 GT Premium and Brembo Package in Black
Flowmaster American Thunder Axle back, Barton Short Shifter and Brackets, Eibach Sportlines, BMR adj pan hard, SCT Tuner, Stainless Powers Longtube Headers and Offroad X-Pipe
A1ex is offline   Reply With Quote
Old 02-28-2014, 02:36 AM   #11
Registered Member
Regular
 
willb2305's Avatar
 
Join Date: Feb 2013
Location: LA county
Region: California
Posts: 149
^^ correction pulling out at the right time is a good thing
__________________
2012 V6
AirRaid CAI, BBK Ceramic LT Headers, BBK Catted X Pipe, Borla ATAK, MPT 93/97 Tune, Steeda LCA's and UCA, Steeda Relocation Brackets, 373 gears, WaveTrac LSD, Dynotech Driveshaft. Prothane Motor Mounts, Whiteline adjustable panhard bar & brace.Ground Control Coilovers with Koni's custom valved. Coming soon Circle D 3800 Stall and Lone Wolf Intake Manifold.
willb2305 is offline   Reply With Quote
Old 02-28-2014, 12:11 PM   #12
Registered Member
Regular
 
A1ex's Avatar
 
Join Date: Jan 2014
Location: Miami
Region: Florida
Posts: 110
^^^ i stand corrected
__________________
2014 GT Premium and Brembo Package in Black
Flowmaster American Thunder Axle back, Barton Short Shifter and Brackets, Eibach Sportlines, BMR adj pan hard, SCT Tuner, Stainless Powers Longtube Headers and Offroad X-Pipe
A1ex is offline   Reply With Quote
Old 02-28-2014, 12:47 PM   #13
Registered Member
Regular
 
Join Date: Aug 2013
Location: Dallas TX
Region: Texas
Posts: 63
Just got it fixed by Ford. My vent hose was burnt/melted from the close proximity of my aftermarket exhaust. All is good now.
seville is offline   Reply With Quote
Old 02-28-2014, 01:25 PM   #14
Registered Member
Regular
 
olds442111's Avatar
 
Join Date: Feb 2014
Location: Hammond
Region: Louisiana
Posts: 303
Send a message via AIM to olds442111
Quote:
Originally Posted by seville View Post
Just got it fixed by Ford. My vent hose was burnt/melted from the close proximity of my aftermarket exhaust. All is good now.
Awesome, and the hose is now safe from future damage / meltdowns?
__________________
White 2014 GT coupe / Auto Trans / Louisiana
olds442111 is offline   Reply With Quote
Old 02-28-2014, 02:18 PM   #15
Registered Member
Regular
 
Stangholio's Avatar
 
Join Date: Jun 2013
Location: San antonio
Region: Texas
Posts: 222
Wow that's crazy. Glad it was fixed though
__________________
GHIGitty
Stangholio is offline   Reply With Quote
Old 03-01-2014, 09:28 AM   #16
Registered Member
Regular
 
dudley279's Avatar
 
Join Date: Feb 2014
Location: Dallas
Region: Texas
Posts: 74
Glad to hear you got it fixed! I had a similar issue back with my 05 3V, would pump for a few seconds regardless of speed and just kick off. Like it was getting bottle-necked in the inlet tube. Found out if I just turn the nozzle upside down and pump it worked like a champ. No clue why but it did lol. Haven't had this issue on my '13 thankfully.
dudley279 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car wont turn... Adamp1 2011-2014 V6 Mustang 11 10-11-2013 11:07 AM
Check engine soon light came on? KamzGT Pre-2005 V6 Mustang 27 09-14-2013 05:33 PM
For Sale: Custom GT500 Dual Fuel Pump Stang23 Mustang Parts for Sale and Wanted 0 08-05-2013 08:56 PM
03 fuel rail Xaperez100 1996-2004 Mustang GT 3 04-12-2013 03:52 PM
Fun Ford Weekend and Super Chevy Shows Welcome Aeromotive Fuel Systems as Series Spo FunFordWeekend At the Track 7 02-09-2012 08:02 PM

» Like Us On Facebook



11:35 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.