CHECK ENGINE LIGHT wtf - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-07-2014, 06:36 PM   #1
Registered Member
Regular
 
GT5h0e's Avatar
 
Join Date: Jun 2014
Location: carlsbad
Region: California
Posts: 22
CHECK ENGINE LIGHT wtf

hey guys, wanted to see if anyone of you have been through anything similar to this.
i had purchased a 2011 GT 5.0 a week ago.

when i got it, it was about a quart low on oil, filled that up. filled the windshield washer fluid to the top, & topped off the radiator fluid.

ANYWAYS, when i really get on it and start rowing through the gears a check engine light would pop up and flash for about 15-20 seconds. it happened TWO times to me today. Then today i ran a 135i bmw with a jb4 tuner with a cat back exhaust. we went from a roll 50-130 and i had hime by a car and a half, those things are quick everything was fine until we went from a dig. Launched in first, spun a little through second, chirped 3rd and when i looked down the CEL was there lit up and now it wont go away

anyone have any tips?
GT5h0e is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-07-2014, 06:55 PM   #2
Registered Member
Regular
 
M_Andrews's Avatar
 
Join Date: Jan 2014
Posts: 21
Go to Auto Zone and have them check the code with an OBDI scanner. Once or if you do decide to get a hand held tuner for your car you will be able to check the codes yourself. Can't really say what the problem might be from the description but I wouldn't be to worried about it, these cars are pretty fickle and will throw a code if something vary minor is going on. Anyways go get it checked at your parts place and go from there!
M_Andrews is offline   Reply With Quote
Old 06-07-2014, 07:01 PM   #3
Registered Member
Regular
 
irishfan's Avatar
 
Join Date: Mar 2014
Location: jefferson city
Region: Missouri
Posts: 43
Did the car go into limp mode ?

Sent from my SPH-L900 using Mustang Evolution mobile app
irishfan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-08-2014, 01:52 AM   #4
Registered Member
Regular
 
GT5h0e's Avatar
 
Join Date: Jun 2014
Location: carlsbad
Region: California
Posts: 22
car went into LIMP mode. getting it scanned tomorrow.
GT5h0e is offline   Reply With Quote
Old 06-08-2014, 03:01 AM   #5
Registered Member
Regular
 
irishfan's Avatar
 
Join Date: Mar 2014
Location: jefferson city
Region: Missouri
Posts: 43
It's the crankshaft position o-ring. All the dealers got a bulletin on it

Sent from my SPH-L900 using Mustang Evolution mobile app
irishfan is offline   Reply With Quote
Old 06-08-2014, 01:52 PM   #6
Registered Member
Regular
 
Join Date: Jun 2014
Location: Texas
Region: Texas
Posts: 182
My 2012 had the same issue. I bought the car with 3500 miles on it and it certain situations the check engine light would flash. Mine did it at part throttle situations, such as lifting my foot after accelerating hard. The car was misfiring and sometimes it was bad enough I could feel the car pulse and shake.

Codes I got were misfire codes, p0300, p0302, and p0304. Dealer performed the crank position sensor TSB and so far so good.
BadCon is offline   Reply With Quote
Old 06-09-2014, 12:40 AM   #7
Registered Member
Regular
 
GT5h0e's Avatar
 
Join Date: Jun 2014
Location: carlsbad
Region: California
Posts: 22
hey guys, thankfully it wasnt the crank shaft sensor. i sprayed off my motor the other day and there was some water near cylinder's 2 & 4. cleared the code and everything is A-OK!
these things are pretty fickle, anything can make it throw a CEL ive read.
GT5h0e is offline   Reply With Quote
Old 06-09-2014, 02:08 AM   #8
Registered Member
Regular
 
Join Date: Dec 2013
Location: oak hill
Region: West Virgina
Posts: 253
So, what are you saying? The water made it go into limp mode? I doubt that is what it was, it will probably happen again. I would take it in and see if the TSB has been taken care of for the crankshaft position o ring.
__________________
2013 Gotta Have It Green Gt, stock with American thunder axle backs, 6-speed
Green5.0 is offline   Reply With Quote
Old 06-09-2014, 05:14 AM   #9
Registered Member
Regular
 
irishfan's Avatar
 
Join Date: Mar 2014
Location: jefferson city
Region: Missouri
Posts: 43
Yea, likely wasn't water. Good luck tho, hope it's fixed.

Sent from my SPH-L900 using Mustang Evolution mobile app
irishfan is offline   Reply With Quote
Old 06-09-2014, 06:47 AM   #10
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Spraying down the engine with water to clean it is not a great idea (as you have found out). The sensors and connections under the engine compartment are very sensitive, and water getting into one can create all kinds of triggered trouble codes.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 06-09-2014, 09:09 AM   #11
Registered Member
Regular
 
KARgt13's Avatar
 
Join Date: Nov 2012
Region: Pennsylvania
Posts: 720
It could be misfiring cylinders. Used to happen to me a lot. They have a TSB to fix it.
KARgt13 is offline   Reply With Quote
Old 06-09-2014, 08:06 PM   #12
Registered Member
Regular
 
GT5h0e's Avatar
 
Join Date: Jun 2014
Location: carlsbad
Region: California
Posts: 22
Had it serviced and nothing was wrong with it. Definitely was the water.
GT5h0e is offline   Reply With Quote
Old 06-09-2014, 08:21 PM   #13
Registered Member
Regular
 
GT5h0e's Avatar
 
Join Date: Jun 2014
Location: carlsbad
Region: California
Posts: 22
have already put 100+ miles on the car, driven it hard as hell & no check engine signs at all.
GT5h0e is offline   Reply With Quote
Old 06-11-2014, 01:54 PM   #14
Registered Member
Regular
 
Compstall's Avatar
 
Join Date: Jun 2012
Location: Tacoma, WA
Region: Washington
Posts: 1,162
I use a pressure washer on all my vehicles' engines, I just make sure to use the static pressure only around electrical connections.

Sent from my SGH-M919 using Mustang Evolution mobile app
__________________
- Brent
'11 GT Kona Blue Brembo
"Measure with micrometers, mark with a scribe, chop with an axe"
"I'm not new to driving. I've been doing it for a couple of years now." - Aphex
Compstall is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Fuel Cap & Service Engine Soon Light??????? mattstang Pre-2005 V6 Mustang 8 12-25-2006 02:33 PM
check engine soon light finally off stangracer Pre-2005 V6 Mustang 4 02-04-2004 11:41 AM
Check Engine Light MUSTANGJUNKY420 Pre-2005 V6 Mustang 11 08-09-2003 01:29 AM
Check engine light, codes inside, cause? MUSTANGJUNKY420 Pre-2005 V6 Mustang 1 08-03-2003 09:24 AM
Check engine light, codes inside, cause? MUSTANGJUNKY420 Pre-2005 V6 Mustang 2 07-30-2003 01:22 AM

» Like Us On Facebook



05:34 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.