will switching from 520 to 530 - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-09-2015, 01:12 PM   #1
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
will switching from 520 to 530

Make my engine tick....just switched to royal purple 5w30 no it got a random tick here and there didn't have it before
Jstorm is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2015, 01:24 PM   #2
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Feel a power loss to...does it have to be re tuned with the oil weight switched
Jstorm is offline   Reply With Quote
Old 03-09-2015, 01:47 PM   #3
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Nope
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-09-2015, 01:49 PM   #4
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Well I didn't do until the oil was changed. No its got a bottom end tick not constant. Ticks here and there
Jstorm is offline   Reply With Quote
Old 03-09-2015, 01:55 PM   #5
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Did you prefill the filter?

It has nothing to do with the weight. Track pack cars call for 5W-50 and they have the same motor. I run 10W-30 with no problems.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 03-09-2015, 01:59 PM   #6
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
No on the prefill ...put 8 quarts in
Jstorm is offline   Reply With Quote
Old 03-09-2015, 02:22 PM   #7
Registered Member
Regular
 
utm18's Avatar
 
Join Date: May 2014
Location: trenton
Region: Ohio
Posts: 267
I just switched from 5w20 Mobil 1 to 5w30 amsoil.
utm18 is offline   Reply With Quote
Old 03-09-2015, 02:26 PM   #8
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
You're supposed to fill the oil filter before installing it. This will prevent any dry startup problems and could be the source of your problem.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 03-09-2015, 02:57 PM   #9
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
So. Should I. Take the filter off and fill it? Or add lucas or something. ...
Jstorm is offline   Reply With Quote
Old 03-09-2015, 03:25 PM   #10
Registered Member
Regular
 
Terminator's Avatar
 
Join Date: Nov 2011
Region: California
Posts: 983
I would think you would have oil in the filter by now if you have been running the car
Terminator is offline   Reply With Quote
Old 03-09-2015, 03:27 PM   #11
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Yea....I have no clue why this thing is ticking at 20000....going nuts here
Jstorm is offline   Reply With Quote
Old 03-09-2015, 03:47 PM   #12
Registered Member
Regular
 
utm18's Avatar
 
Join Date: May 2014
Location: trenton
Region: Ohio
Posts: 267
Where is the sound coming from
utm18 is offline   Reply With Quote
Old 03-09-2015, 04:29 PM   #13
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Bottom......anyone think it my be because of a low Octane ...I got a 93 tune and I think the guy put 87 in it the other day .....could that be it....I didn't notice a ping till after the oIL change tho
Jstorm is offline   Reply With Quote
Old 03-09-2015, 04:31 PM   #14
Registered Member
Regular
 
utm18's Avatar
 
Join Date: May 2014
Location: trenton
Region: Ohio
Posts: 267
Holy ****, 93 Tune with 87.
utm18 is offline   Reply With Quote
Old 03-09-2015, 04:34 PM   #15
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
I think they did ...it seemed funny after I filled up Saturday. .plus jersey u can't pump ur own gas...so u never know
Jstorm is offline   Reply With Quote
Old 03-09-2015, 04:35 PM   #16
Registered Member
Regular
 
utm18's Avatar
 
Join Date: May 2014
Location: trenton
Region: Ohio
Posts: 267
You need to fix that immediately. Go back to stock tune asap.

---------- Post added at 05:35 PM ---------- Previous post was at 05:34 PM ----------

is it a tick or a knock?
utm18 is offline   Reply With Quote
Old 03-09-2015, 04:37 PM   #17
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Well my car empty so I'm filling it today with 93

---------- Post added at 05:37 PM ---------- Previous post was at 05:36 PM ----------

It's in between a tick and knock...and it's not constant. .it's in spurts
Jstorm is offline   Reply With Quote
Old 03-09-2015, 04:38 PM   #18
Registered Member
Regular
 
utm18's Avatar
 
Join Date: May 2014
Location: trenton
Region: Ohio
Posts: 267
Have you checked your oil level?
utm18 is offline   Reply With Quote
Old 03-09-2015, 04:43 PM   #19
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Clean full no signs of metal shavings ..put exactly 8 quarts of 5w30 royal purple in and a Motorcraft filter 500s I believe was the part number....I was use r9 putting the bigger filter on my 99 gt suprised it called for the smaller one
Jstorm is offline   Reply With Quote
Old 03-09-2015, 05:55 PM   #20
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
It's only doing it when it's warmed up tho
Jstorm is offline   Reply With Quote
Old 03-09-2015, 08:55 PM   #21
Road Trip!
 
Join Date: Dec 2014
Posts: 105
You don't have to prefill the oil filter
NcmustangboyIw is offline   Reply With Quote
Old 03-09-2015, 08:57 PM   #22
Registered Member
Regular
 
Join Date: Jan 2015
Location: New Jersey
Region: New Jersey
Posts: 133
Well Big update...it WAS the 5w30 Royal purple that mad the car starting ticking/knocking. Just switched it out for 5w20 Mobil 1, As of right now there is no more noise , no ticking no knocking, gonna do some more driving tomorrow
Jstorm is offline   Reply With Quote
Old 03-09-2015, 08:58 PM   #23
Road Trip!
 
Join Date: Dec 2014
Posts: 105
That's weird
NcmustangboyIw is offline   Reply With Quote
Old 03-09-2015, 09:31 PM   #24
Registered Member
Regular
 
Psmith129's Avatar
 
Join Date: Jun 2014
Location: Riverside
Region: California
Posts: 190
Tick is normal , mine comes and goes but nothing to be worried about


Sent from my iPhone using Mustang Evolution
Psmith129 is offline   Reply With Quote
Old 03-09-2015, 11:57 PM   #25
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Quote:
Originally Posted by NcmustangboyIw View Post
You don't have to prefill the oil filter
No but it certainly doesn't hurt and does prevent dry startups.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 03-09-2015, 11:58 PM   #26
ME Bloodhound
Staff
 
Soccerluvr4's Avatar
 
Join Date: Feb 2012
Location: Sacramento/Bay Area
Region: California
Posts: 14,672
Quote:
Originally Posted by Grabber Blue5.0 View Post
No but it certainly doesn't hurt and does prevent dry startups.

If the car has been driven wouldn't there now be oil in there anyway?


Bullitts are better than Bullets
__________________

Bullitt build paused pending graduation

HID end all thread
Soccerluvr4 is offline   Reply With Quote
Old 03-10-2015, 12:04 AM   #27
Registered Member

Regular
 
oxford5pointoh's Avatar
 
Join Date: Jan 2015
Location: Murica
Region: Other
Posts: 4,069
Quote:
Originally Posted by Soccerluvr4 View Post
If the car has been driven wouldn't there now be oil in there anyway?


Bullitts are better than Bullets

Yeah but grabber is saying moving forward he should pre fill the filter. I changed my oil for the first time a few months back (amsoil) and I prefilled the filter because it sits at a great angle to do so and as stated prevents dry start ups. Think about those few seconds where oil is supposed to be coming back out of that filter and lubricating SOMETHING but it has to fill up first before it can do so... I'd rather be safe than sorry. It takes Damn near a half quart folks!
oxford5pointoh is offline   Reply With Quote
Old 03-10-2015, 12:06 AM   #28
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Quote:
Originally Posted by Soccerluvr4 View Post
If the car has been driven wouldn't there now be oil in there anyway?


Bullitts are better than Bullets
Yes but I'm referring to the initial startup after changing oil. It's best to prefill the filter before starting the car.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 2011+ Mustang FS: Pypes off-road Xpipe and Speedmaster Long Tube Headers $530 + shipp HPFury Mustang Parts for Sale and Wanted 8 11-20-2014 01:31 AM
Anybody in northern kali wants to join 530 Fourloko530 Pre-2005 V6 Mustang 0 06-18-2012 11:31 PM
switching to 5 speed stovalini69 1996-2004 Mustang GT 7 11-30-2006 01:19 AM
GeigerCars - Mustang GT 520 JROC General Mustang Discussion 10 09-27-2006 09:34 PM
Switching to 4.10.....questions Ghostbuster Pre-2005 V6 Mustang 6 08-19-2004 02:00 AM

» Like Us On Facebook



08:56 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.