2012 GT died during idle after refuel - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 04-02-2015, 11:01 PM   #1
Registered Member
Regular
 
Mustang Coyote's Avatar
 
Join Date: Jul 2014
Location: Austin
Region: Texas
Posts: 126
2012 GT died during idle after refuel

Well for the first time in the 22K miles Ive had this car, it died after refueling with 93 octane. Same Bucees station I've used for the year. Car has 63K miles on it. I turned it on, idled rough - the normal rough idle - then it bogged down but to the point of dying. A/C was off. What should I be looking to clean/replace?? I have a stock powertrain, drivetrain, and tune. Thanks for the input!
Mustang Coyote is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-02-2015, 11:11 PM   #2
Registered Member

Regular
 
Famine's Avatar
 
Join Date: Jun 2013
Location: Rapid City
Region: South Dakota
Posts: 684
No cel's?
Famine is offline   Reply With Quote
Old 04-02-2015, 11:21 PM   #3
Registered Member
Regular
 
Mustang Coyote's Avatar
 
Join Date: Jul 2014
Location: Austin
Region: Texas
Posts: 126
No none at all. It's always bogged a bit after refueling and at lights with the A/C on...
Mustang Coyote is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-02-2015, 11:22 PM   #4
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Bad gas maybe?

Sent from the Death Star.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 04-02-2015, 11:23 PM   #5
Registered Member

Regular
 
natestang07's Avatar
 
Join Date: Jun 2014
Location: Soap Lake
Region: Washington
Posts: 5,321
Quote:
Originally Posted by Mustang Coyote View Post
No none at all. It's always bogged a bit after refueling and at lights with the A/C on...
Maybe try a new station

Sent from my VS985 4G using Mustang Evolution mobile app
natestang07 is offline   Reply With Quote
Old 04-02-2015, 11:50 PM   #6
Registered Member
Regular
 
Redonblackpony's Avatar
 
Join Date: Dec 2013
Location: Moorpark
Region: California
Posts: 206
Possibly a vacuum leak


Sent from my iPhone using Mustang Evolution
Redonblackpony is offline   Reply With Quote
Old 04-03-2015, 11:40 AM   #7
Registered Member
Regular
 
Jbone007's Avatar
 
Join Date: Mar 2015
Location: Oceanside
Region: California
Posts: 435
Fuel filter maybe! I had some issues with the Wife's Volvo doing the same thing, had a fuel system flushed and cleaned the Throttle body, problem resolved.
Jbone007 is offline   Reply With Quote
Old 04-03-2015, 03:21 PM   #8
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
The fuel filter is non serviceable in these cars.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 04-03-2015, 03:36 PM   #9
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Quote:
Originally Posted by Grabber Blue5.0 View Post
The fuel filter is non serviceable in these cars.
Yep. Built into the fuel pump, correct?
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 04-03-2015, 04:12 PM   #10
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Quote:
Originally Posted by WhoDat View Post
Yep. Built into the fuel pump, correct?
Correct.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 04-03-2015, 04:43 PM   #11
Evolution's Finest
Supporter
 
ronnie948's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach
Region: Florida
Posts: 3,960
This will do it.

Go to Walmart or an auto parts store and buy a couple bottles of "TECHRON" This stuff works great to clean up the fuel pump, hoses and best of all THE INJECTORS.
The "TECHRON" is the best but if you can't find it in your area get the STP total Fuel System Cleaner.
It is worth trying this before paying a whole bunch of $$$$$ to a trial & error mechanic.
Ronnie
__________________
2012-candy red- V-6 MCA, Automatic Trans. CFM Valve cover breather. MMD blackTail light trim.Magnaflow axle back street mufflers, JLT oil catch can.MMD hood struts.
Airaid Cold Air intake. red caliper covers, 3.7L performance engine cover, Flat black hood spears.Boss 302 strut brace, CDC rear panel, Trunk Cargo net,--Dash carpet cover,
Viser stickers to cover ugly yellow warning crap,Aluminum driveshafft and Swarr Bar.
ronnie948 is offline   Reply With Quote
Old 04-03-2015, 05:07 PM   #12
Registered Member
Regular
 
yellowconve's Avatar
 
Join Date: Jan 2014
Location: laredo
Region: Texas
Posts: 615
try to clean the maf sensor dk hope it gets resolved and like ronnie said try some things b4 paying big buck to have the mechanic put that same TECHRON solution he mentioned in and fixes it for u.
__________________
0-100 REAL QUICK!!!
yellowconve is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Tags
2012 gt

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesistation/knocking during hard acceleration; failure to maintain 4000 RPM at idle DmitriK Pre-2005 V6 Mustang 5 01-13-2015 02:13 PM
Help: Rough Idle and feels like its sputtering during acceleration. brooksyx Pre-2005 V6 Mustang 9 05-13-2013 03:25 PM
humming noise during idle robertoortiz85 1996-2004 Mustang GT 6 10-23-2011 03:12 AM
After 39,000 trouble free miles It died Herbstang Pre-2005 V6 Mustang 12 08-06-2010 02:01 PM
Some chick nearly died after eating nothing but CRISPS for three years. Seph The Bar 12 07-08-2005 10:12 AM

» Like Us On Facebook



02:11 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.