10mpg after cat delete tune - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-06-2015, 08:55 PM   #1
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
10mpg after cat delete tune

I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
Fax22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-06-2015, 08:59 PM   #2
Sad Panda
Staff
 
silverskoundrel's Avatar
 
Join Date: Aug 2012
Location: TX
Region: Texas
Posts: 5,633
10mpg after cat delete tune

If I were you I'd drive it till its empty, fill it up then check the actual mpg


Sent from my iPad using Mustang Evolution
__________________
@silverskoundrel
05 TL Mustang Base (the silverskoundrel) - sold
05 TL Mustang GT - sold
98 UA Mustang GT - sold
10 CI Mustang GT - slow
silverskoundrel is offline   Reply With Quote
Old 08-07-2015, 03:33 AM   #3
Registered Member
Regular
 
Join Date: Sep 2013
Location: hiram
Region: Georgia
Posts: 76
definitely check with bama, its something with the tune probably
rwheels is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-07-2015, 04:38 AM   #4
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Sounds like COT is still on. It needs to be turned off in the tune.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 08-07-2015, 07:25 AM   #5
Registered Member
Regular
 
Join Date: Apr 2014
Location: St-Hubert
Region: Canada
Posts: 74
Quote:
Originally Posted by Fax22 View Post
I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
Try setting your cluster to metric, then back to imperial. 10.1 litres per 100 km, is what I'm used to seeing.
NoTop5.0 is offline   Reply With Quote
Old 08-07-2015, 01:33 PM   #6
Registered Member
Regular
 
c_rizzle's Avatar
 
Join Date: Sep 2014
Location: New Orleans
Region: Louisiana
Posts: 1,008
Try not stomping the gas pedal at every red light?

If I hit reset and drive it like I stole it.... "testing out" my new performance mods.... I get about <10 mpg too. Then again... my best city mpg is only about 14.x mpg.

I rarely do highway miles, so don't really get much of the high mpg's averaged in there.
c_rizzle is offline   Reply With Quote
Old 08-07-2015, 02:39 PM   #7
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
Well i have been trying to keep it easy just to test it. My instant mpg goes down to 10 when i lightly touch the gas. Only ever goes up to 15 or 16 when im barely touching it. Its pretty 0 if i ha e ti accelerate at all.

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
Fax22 is offline   Reply With Quote
Old 08-07-2015, 05:14 PM   #8
Site Sponsor
Sponsor
 
AMWill's Avatar
 
Join Date: Apr 2012
Location: Malvern
Region: Pennsylvania
Posts: 2,171
Quote:
Originally Posted by Fax22 View Post
I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
Hey fax,

Keep an eye on it! When you freshly tune the car and reset the MPG it's going to take a while for it to learn the driving habits all over again and average out. Especially after changing all the parameters that the tune does.

I would recommend giving it some time and seeing what happens, if the MPG stays down, should the Bama team a call and I guarantee that they can adjust that for you.

Hope this helps!

-Will
__________________
Will Levantovsky | AmericanMuscle.com
Toll Free: 866.727.1266
Bama Hotline: 888.226.9764 | M-F 9AM-5:30PM EST
WIN A $1500 MMD STYLING PACKAGE
Free Same-Day Shipping!
AMWill is offline   Reply With Quote
Old 08-07-2015, 05:18 PM   #9
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
Thats what i think im going to do. It just psyvhs me out seeing it that low haha. Ill let you guys know what happens in the next few days. Im driving up to the lake tomorrow and then back. Mostly highway. Ill see if it improves after that

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
Fax22 is offline   Reply With Quote
Old 08-08-2015, 03:50 PM   #10
Registered Member
Regular
 
2 Stangz's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Region: Nevada
Posts: 2,093
Every time I have to re-flash my PCM due to tune revision or whatever, I always put at least 50~ grandma miles on it before getting on it or even going WOT (since I have an auto, shift points take a while to smooth out). The PCM also has to relearn idle and all of the rest of the parameters.

If you're unsure, you can always use your tuner to erase the on-board memory and "start over." Just crank it, let it get to operating temp, put A/C on for few mins, then put a few easy miles on it to ensure everything is running right.
__________________
2010 GT Premium - Automatic - Torch Red
2 Stangz is offline   Reply With Quote
Old 08-09-2015, 11:46 AM   #11
Registered Member
Regular
 
Join Date: Jul 2015
Location: Williamsport
Region: Pennsylvania
Posts: 35
agree...give it at least 50-100 miles and im sure itll improve
14GRAYGTCS is offline   Reply With Quote
Old 08-09-2015, 09:00 PM   #12
Registered Member
Regular
 
Diehard's Avatar
 
Join Date: Mar 2014
Location: North Reading
Region: Massachusetts
Posts: 2,112
Did you happen to follow up on Grabber Blue5.0's comment above regarding the COT setting in the tune?
COT(Cat Over Temperature) It is a system in the car that dumps raw fuel in the exhaust to cool down the cats.
Apparently when the cats have been removed the COT should be disabled.

Or did you check it out with Bama?
__________________
____________________________________________________
14 V6 auto, MCA, PP, BBK Shorties, MMD Hood Struts, Borla Touring A/B's, MAC ProChamber, aFe drop-in Filter
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Lets not forget, an opinion is a judgment, viewpoint, or statement about matters commonly considered to be subjective.
Diehard is offline   Reply With Quote
Old 08-09-2015, 09:15 PM   #13
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
No i havent checked that out yet. I assume bama would know to take care of that, but is there a way to turn it off from the tuner

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
Fax22 is offline   Reply With Quote
Old 08-10-2015, 02:36 AM   #14
Registered Member
Regular
 
2 Stangz's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Region: Nevada
Posts: 2,093
Quote:
Originally Posted by Fax22 View Post
No i havent checked that out yet. I assume bama would know to take care of that, but is there a way to turn it off from the tuner

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
I'd highly recommend that you let Bama attempt to address your issue first. There may be more than one parameter that needs to be addressed and if you mess with only one, it could snowball into other parameters and become a disaster.

Just my $0.02.
__________________
2010 GT Premium - Automatic - Torch Red
2 Stangz is offline   Reply With Quote
Old 08-10-2015, 05:23 AM   #15
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
Did you change your rear gearing? If so, your tune may not have the correct gear ratio set.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 08-10-2015, 06:00 AM   #16
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Even at 10.1, you are 2.1 better than me lololol.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 08-10-2015, 09:35 AM   #17
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
I have driven it on the highway some now and its up to 14, so maybe it is just taking some time. Ill let you guys know after a few more days if i can get it back up to 16 lol.

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
Fax22 is offline   Reply With Quote
Old 08-13-2015, 08:32 PM   #18
Registered Member
Regular
 
Fax22's Avatar
 
Join Date: Jan 2013
Location: Johns Creek
Region: Georgia
Posts: 202
Just got it running back where it should be. Still some low spots, but i was getting close to 40mpg over 5 minute intervals at 60mph. Thats unheard of. I guess i was being a bit paranoid lol

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
Attached Thumbnails
Click image for larger version

Name:	1439516045716.jpg
Views:	67
Size:	44.0 KB
ID:	189314  
Fax22 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cat delete. Tune? Do I need one and how howellrobby Pre-2005 V6 Mustang 5 12-18-2014 04:10 PM
Header to cat/cat delete pipe gasket. nosympathy 2011-2014 Mustang GT 9 12-14-2012 10:36 PM
I got my ghost cam tune from bama and bbk cat delete Mustang_5.0 2011-2014 Mustang GT 19 08-29-2012 01:39 PM
cat delete Supertzi 2011-2014 Mustang GT 18 02-03-2012 02:51 PM
cat or no cat 96mustangv8 1996-2004 Mustang GT 15 05-12-2011 03:00 PM

» Like Us On Facebook



09:29 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.