Another BMR UCA & LCA clunk/knock thread - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 10-03-2015, 08:43 AM   #1
Registered Member
Regular
 
Join Date: May 2015
Location: findf
Region: Other
Posts: 91
Another BMR UCA & LCA clunk/knock thread

Hey guys!
I know its been asked many times but i couldn't find the correct answer for my issue.


I recently installed along with my VMP TVS kit the BMR LCA and adjustable UCA with BMR Mount.
I am not sure what angle the guy who installed it for me set it to,
but since then, i have an annoying clunk (i think from the UCA) whenever i am the gear shifts in in the lower gears (1,2 & 3).
My car has an auto transmission and if it matters i installed back then Eibach PRO-KIT

I made sure everything is tighten as expected and put grease in all the bolts.
How can I solve this this? is it possible that the angle is incorrect?

Please assist
Thanks!
demas is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2015, 02:14 PM   #2
Registered Member
Regular
 
Ammermeow's Avatar
 
Join Date: Aug 2014
Location: Riverside, CA
Region: California
Posts: 110
Probably just drive train clunk. This gets really loud when you replace the stock pieces with their soft rubber bushings. When does it make the noise? When you let off and on the gas or over bumps?

Sent from my SM-N910V using Mustang Evolution mobile app
__________________
2012 GT Brembo M6, BBK CAI, Dynomax axleback, Bama tuned, UPR UCA & mount, Hotchkis LCA/panhard bar/adjustable swaybars, Whiteline relocation brackets, Barton shifter & bracket, Eibach ProKit Springs.
Ammermeow is offline   Reply With Quote
Old 10-05-2015, 05:20 PM   #3
Registered Member
Regular
 
RJTheIV's Avatar
 
Join Date: Mar 2014
Location: Kansas City
Posts: 185
That's odd. I have the exact same suspension setup and all I get are light squeaks over bumps(barely audible)
RJTheIV is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-05-2015, 09:20 PM   #4
Registered Member
Regular
 
TCopp's Avatar
 
Join Date: Mar 2013
Location: KCMO
Region: Missouri
Posts: 1,260
Pinion angle may have been set wrong.


Sent from my iPhone using Mustang Evolution
__________________

2013 GT/CS
TCopp is offline   Reply With Quote
Old 10-05-2015, 11:15 PM   #5
Registered User
Newbie
 
Join Date: Aug 2015
Location: Warrenton
Region: Virginia
Posts: 8
Just heard mine today. Is yours at parking lot speed while turning? That's when I hear mine the most.


Sent from my iPhone using Mustang Evolution
blackbella5.oh is offline   Reply With Quote
Old 10-06-2015, 04:32 PM   #6
Registered Member

Regular
 
Famine's Avatar
 
Join Date: Jun 2013
Location: Rapid City
Region: South Dakota
Posts: 684
It could just be the drivetrain. You should check the uca. Make sure you have the correct pinion angle and ensure that you have it loctited. If you don't, it may have come lose and that will give you the clunk.
Famine is offline   Reply With Quote
Old 10-08-2015, 10:28 AM   #7
Registered Member
Regular
 
Join Date: May 2015
Location: findf
Region: Other
Posts: 91
I hear it mostly when the gear (Auto) is shifting to a lower or to an upper one.
I tried to set the pinion angle and have 1,2 negative angle but so far it only got worse... :S
demas is offline   Reply With Quote
Old 10-08-2015, 09:48 PM   #8
Registered Member
Regular
 
thelastsumurai's Avatar
 
Join Date: Oct 2011
Region: Florida
Posts: 371
Do you have a drive shaft loop installed.
__________________
'16 Eco-Boost Premium, White, Performance Pkg, 6R80 (again), Pwr Ebony Lthr with Nether Region Cooling, Adaptive Cruise Control, Enhanced Security Pkg., Reverse Park Assist., Big Worm OTT Graphix.

2014 GT Premium 200A, Black on black , leather , 6R80, Nav, Security. Pro Cal, HT catback exhaust 12.54@112
thelastsumurai is offline   Reply With Quote
Old 10-09-2015, 09:41 AM   #9
Registered Member
Regular
 
Join Date: May 2015
Location: findf
Region: Other
Posts: 91
Quote:
Originally Posted by thelastsumurai View Post
Do you have a drive shaft loop installed.

Nope, suspension wise i only replaced:
UCA w/ mount
LCA
Springs
demas is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sad Sad Sad Day for me and my family M3to5.0 The Bar 27 03-07-2016 08:49 PM
BMR LCA/UCA - poly or spherical/rod end hispeedlodrag 2011-2014 Mustang GT 3 02-27-2015 01:57 PM
Installed BMR adjustable UCA, LCA, loud noise/clunk on sharp turns Riko 2011-2014 Mustang GT 24 12-14-2014 03:46 PM
Lca & uca & relocation bracket Laquisha 2011-2014 Mustang GT 43 11-15-2014 01:02 AM
Sad Sad SAD day Seph The Bar 9 04-06-2004 11:24 AM

» Like Us On Facebook



05:22 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.