o2 sensors and AFR readings - Mustang Evolution

Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-21-2016, 08:28 AM   #1
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
o2 sensors and AFR readings

So yesterday I got a little excited and put in my drag tune fro AED for a couple of runs. After 4 runs the AFR gauge was stuck at 20 and not moving at all. Check engine light came on and both front o2 sensors are not reading anything. (So I'm guessing they are fried)

Now my question might be stupid: the AFR reading is stuck at 20, but that doesn't mean that the car is running lean? Right? Safe to drive the car until I get new o2 sensors?

If it matters, main mods are boss302 manifold and bbk ceramic 1 and 3/4 long tube headers with off road x pipe





Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2016, 08:33 AM   #2
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Which longtube headers?
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 02-21-2016, 08:35 AM   #3
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
Quote:
Originally Posted by Grabber Blue5.0 View Post
Which longtube headers?

BBK ceramic, 1 and ¾


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2016, 08:50 AM   #4
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
I wouldn't drive the car until you either replace those sensors or find out what's giving the false readings.

Also expect this to happen again due to the placement of the o2's.

If you're running the extensions that is also a problem and you need to get those off ASAP.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 02-21-2016, 09:57 AM   #5
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
Click image for larger version

Name:	ImageUploadedByMustang Evolution1456070226.362499.jpg
Views:	94
Size:	94.6 KB
ID:	197320 this is the passenger side o2 sensor. The driver side is not as bad


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Old 02-21-2016, 06:08 PM   #6
Registered Member
Regular
 
Koryak's Avatar
 
Join Date: Jan 2015
Location: Boulder
Region: Colorado
Posts: 79
The pic looks like oil or something got on the sensor. These things should look light tan or whitish in street driving. Something happened in the full throttle runs like oil or carbon burning. I'm betting you're running in limp-home mode with 20:1 A/F signal as that's way too lean for combustion!
Koryak is offline   Reply With Quote
Old 02-21-2016, 06:25 PM   #7
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
The driver side sensor was fine. Just the passenger one was like this( above pics) and it's not reading. I did a datalog and the AFR it's still good, but because one sensors is not reading it, there is a lot of change between bank 1 and 2. I'll get a new sensor to replace it.

The real question is why would the sensor go bad. Car has only 16k miles and only 2k miles with tune and mods


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Old 02-21-2016, 06:53 PM   #8
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Quote:
Originally Posted by ILLY View Post
The real question is why would the sensor go bad. Car has only 16k miles and only 2k miles with tune and mods
Quote:
Originally Posted by Grabber Blue5.0 View Post

Also expect this to happen again due to the placement of the o2's.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 02-22-2016, 07:51 AM   #9
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
Got it! 😬


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Old 02-22-2016, 07:53 AM   #10
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
A friend is giving me a sensor that he bought for his 2013 Shelby. Will the sensor for the Shelby fit the 2014 GT? I don't see why they would be different but doesn't hurt to ask.


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Old 02-22-2016, 08:00 AM   #11
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,576
Don't think you understand that you need to take the car to a shop and have them move the O2 bungs...


If you were going to go cheap on headers you should have at least gone with JBA.


BBK strikes again...
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Old 02-22-2016, 08:06 AM   #12
Registered Member
Regular
 
ILLY's Avatar
 
Join Date: Mar 2014
Posts: 100
Quote:
Originally Posted by scottydsntknow View Post
Don't think you understand that you need to take the car to a shop and have them move the O2 bungs...

No worries I understand, and I can do the relocation myself at my shop.


Sent from my iPhone using Mustang Evolution
ILLY is offline   Reply With Quote
Old 02-22-2016, 08:21 AM   #13
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Move them up if possible to the 10:00 and 2:00 location. Also for anyone else going through this for future reference E85 will make this problem significantly worst.
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 04-30-2016, 05:23 AM   #14
Registered User
Newbie
 
Join Date: Apr 2016
Location: Yale, Ia. 50277
Region: Iowa
Posts: 6
E85... in a sports car? Whoa...WTH. Why the race equipment if your not burning Premium?
06GTragtop is offline   Reply With Quote
Old 04-30-2016, 06:18 AM   #15
Registered Member
Regular
 
Rapinator126's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 9,245
Quote:
Originally Posted by 06GTragtop View Post
E85... in a sports car? Whoa...WTH. Why the race equipment if your not burning Premium?

Well we know you are as new as it gets


LSX 408 FTW
Dragging your a$$
Rapinator126 is offline   Reply With Quote
Old 04-30-2016, 07:11 AM   #16
Registered Member
Regular
 
Joaquin_ii's Avatar
 
Join Date: May 2014
Location: San Antonio
Region: Texas
Posts: 547
^^^ lmao
Joaquin_ii is offline   Reply With Quote
Old 04-30-2016, 07:39 AM   #17
Registered Member
Regular
 
Grabber Blue5.0's Avatar
 
Join Date: Nov 2012
Location: East Haven
Region: Connecticut
Posts: 3,510
Quote:
Originally Posted by 06GTragtop View Post
E85... in a sports car? Whoa...WTH. Why the race equipment if your not burning Premium?
Is this a serious question?
__________________
2017 Dodge Challenger T/A Redline Tri-Coat
2015 Dodge Challenger Scat Pack Jazz Blue Pearl Sold
2015 GT Premium 401A Ingot Silver Sold
2011 GT Premium 401A Grabber Blue Sold
Grabber Blue5.0 is offline   Reply With Quote
Old 04-30-2016, 12:55 PM   #18
Staff
Regular
Staff
 
scottydsntknow's Avatar
 
Join Date: Apr 2013
Location: JB MDL
Region: New Jersey
Posts: 16,576
I'm confused as to whether he thinks e85 is 85 octane or what...

Sent from my LG-D801 using Mustang Evolution mobile app
__________________
2000 Mustang GT Steeda #0048

Just because I give you advice, doesn't mean I know more than you. Its just means I've done more stupid ****.
scottydsntknow is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 1979-2015 Mustang GT || Tech and Talk > 2011-2014 Mustang GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is your best accelerometer readings!? cwyates4 2011-2014 Mustang GT 3 02-12-2015 09:48 PM
PLX gauge obd2 read AFR and if so how... Leo513 2011-2014 Mustang GT 0 01-20-2015 08:29 AM
Need help with the dual fuel pump readings Milton 2011-2014 Mustang GT 0 04-26-2014 02:21 AM
Gimme some insight on Trick Flow TW and AFR 351stroker 1979-1995 Mustang GT 11 09-15-2013 10:13 AM

» Like Us On Facebook



08:41 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.