Mustang SVO, engine problem? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2.3 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-30-2010, 07:30 PM   #1
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 27
Mustang SVO, engine problem?

I have asked this before but i just wanted to ask it again to get more answers, i only got 2 last time and they werent really helpfull.

I have a 1985 Mustang SVO (2.3L turbocharged)
Manual transmission.

An i ran it at the 1/4 mile 2 days ago, After i finished my run i heard REALLY loud clicking, sorta like engine knock but alot louder, i could even hear it over my exhaust. When i rev it the clicking get louder and faster, its not the fan blades hitting anything or anything like that. Its comming from the block. What do you think it is? Its still making good boost and drives fine but i havent been driving it lately because i dont want to cause more damage.

It has 98K org. miles, mostly stock except for the exhaust, wheels and tires and some gauges.

Also, i run 93oct. daily, i have never once put 87 in this car.
kippar is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-30-2010, 07:49 PM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 46
Mustang SVO, engine problem?

Ask the experts...

wwww.turboford.org

Cool guys and lots of free info.
artzai is offline   Reply With Quote
Old 03-30-2010, 08:03 PM   #3
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 35
Mustang SVO, engine problem?

Check your oil level & pressure. Clicking noises that vary with engine speed are generally valve train related (i.e. loose rockers or too much lash between valve stem & rocker). Knocking noises that vary with engine speed are generally rod or main bearing related.
codi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-30-2010, 08:13 PM   #4
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 42
Mustang SVO, engine problem?

a ligght clicking noise in the upper part of the engine would probably be somewhere in the valve train... lifter, pushrod, valve spring...
A heavier noise farther down in the block is usually a rod bearing...
finley is offline   Reply With Quote
Old 03-30-2010, 08:16 PM   #5
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 42
Mustang SVO, engine problem?

Do you have plenty of oil in it, and how is your oil pressure?
hobbard is offline   Reply With Quote
Old 03-30-2010, 09:15 PM   #6
Registered Member
Regular
 
Join Date: Mar 2010
Posts: 37
Mustang SVO, engine problem?

i have no clue... i'll ask my dad
JosT is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2.3 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



01:55 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.