Radiator fan not working, 84 mustang svo turbo? - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2.3 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-22-2011, 09:00 PM   #1
Registered Member
Regular
 
Join Date: Mar 2010
Posts: 34
Radiator fan not working, 84 mustang svo turbo?

I JUST PURCHASED A 1984 MUSTANG SVO TURBO HATCHBACK, BECAUSE IT LOOKS SO FAST AND COOL, THE RADIATOR FAN WONT COME ON. THE CAR TAKES AWHILE TO HEAT UP. THE FAN WILL NOT TURN ON WHEN IT GETS HOT. HELP
Arleigh is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-22-2011, 09:48 PM   #2
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 31
Radiator fan not working, 84 mustang svo turbo?

I had the same problem with mine when I got it, try turning on the AC or defroster, this should force it on.. if that doesn't work, Your AC system may be low on fluid and it is interconnected to the fan and can prevent it from working..

this is what I did....I put a bypass clip in the AC low pressure switch and then upplugged the compressor so it would not come on and be ruined..

Or you can just put a manual switch on the fan..

You can still drive it, just try to keep it over 25 mph, No idling around or long stops with the engine running.. and keep a eye on the temp gauge..
nels91 is offline   Reply With Quote
Old 12-22-2011, 10:34 PM   #3
Registered User
Newbie
 
Join Date: Jul 2011
Posts: 6
Radiator fan not working, 84 mustang svo turbo?

there are 2 sensors and a relay that control the fan (crappy design IMO)
one sensor is in the cooling system and activates the fan relay when the engine gets hot,
the other sensor is attached to the A/C clutch circuit and activates the fan relay whenever the A/C is turned on.
if the fan doesn't come on at all it could be a bad relay or a bad fan motor or the less likely possibility that both sensors are bad.
EDIT
i am mistaken the A/C circuit is directly "tied" to the fan relay , the 2nd sensor i was thinking about goes to the temp gauge in the dash and has nothing to do with the fan coming on.
Rayman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-22-2011, 11:18 PM   #4
Registered Member
Regular
 
Join Date: Aug 2009
Posts: 36
Radiator fan not working, 84 mustang svo turbo?

easiest thing is to run a switch to the cab. you just have to run the wires to the switch with a power on one and the wire going to the fan on the other which will complete the circuit. should cost 5 buck for switch and wiring
glendyn52 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > 2.3 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



03:30 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.