13 Shelby gt500 problem , HELP!!! - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > Shelby Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 02-25-2014, 02:19 PM   #1
Registered User
Newbie
 
Join Date: Feb 2014
Posts: 2
13 Shelby gt500 problem , HELP!!!

I have a 2013 gt500, i love the car and runs perfectly until the oil light suddenly came up on the dash, so I took it to the dealership to see what is wrong, they found out that the oil pump is broken and they fixed it.

After few weeks the car has lost it's power at all, I noticed that air/fuel ratio drops below 10.00 and boost doesn't not go above 5psi with WOT. I took the car to the dealership and they said that the catalytic converter is blocked, so they replaced it with a new one. However the problem is still there but they are saying that the reading is fine and nothing wrong with my car, but AGAIN it has the same issue. Same air/fuel ratio same boost problem. I could not find out what is the issue.

Suggestions please.
Many thanks.
13gt500 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-25-2014, 05:24 PM   #2
Registered Member
Regular
 
EastTNMustang's Avatar
 
Join Date: Nov 2013
Location: Knoxville
Region: Tennessee
Posts: 428
How long/how far did you drive the car after the oil light came on?
EastTNMustang is offline   Reply With Quote
Old 02-26-2014, 07:49 AM   #3
Registered User
Newbie
 
Join Date: Feb 2014
Posts: 2
I stopped immediately, tow it to the workshop
13gt500 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2014, 09:45 AM   #4
Registered Member
Regular
 
EastTNMustang's Avatar
 
Join Date: Nov 2013
Location: Knoxville
Region: Tennessee
Posts: 428
Take it to another dealer
EastTNMustang is offline   Reply With Quote
Old 02-26-2014, 09:12 PM   #5
Registered Member
Regular
 
Chip's Avatar
 
Join Date: Jun 2012
Region: California
Posts: 43
Ditto - take it to a different dealer.
Chip is offline   Reply With Quote
Old 02-27-2014, 05:03 PM   #6
Registered Member
Regular
 
Notorious_rob's Avatar
 
Join Date: Jan 2012
Region: Virginia
Posts: 352
I wouldnt trust em. New dealership!
Notorious_rob is offline   Reply With Quote
Old 03-01-2014, 12:18 AM   #7
Registered Member
Regular
 
godsdisciple85's Avatar
 
Join Date: Jan 2011
Region: Texas
Posts: 594
Sounds like the computer is still seeing the airfuel going to dangerous levels and protecting itself by not allowing you go full wot....have you had it tuned??? It could be that the cat was bad but the computer may need to be reflashed or could be that your airfuel is out of wack...? I would certainly take it to a more "performance" minded dealership that have the expertise to look beyond the surface of problem...
godsdisciple85 is offline   Reply With Quote
Old 03-01-2014, 12:19 AM   #8
Registered Member
Regular
 
godsdisciple85's Avatar
 
Join Date: Jan 2011
Region: Texas
Posts: 594
Like bad wideband sensor...
godsdisciple85 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > Shelby Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



06:01 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.