Check engine light - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > Shelby Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-20-2014, 09:30 PM   #1
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Check engine light

Did a few mods on 2014gt500. Sct chip
Exhaust , super charger pully and bigger intake. Now have engine light on and the wrench symbol in the middle lcd screen. Power is reduced. Any ideas??
robn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2014, 04:52 AM   #2
Registered Member
Regular
 
Notorious_rob's Avatar
 
Join Date: Jan 2012
Region: Virginia
Posts: 352
Tune u have is bad. Ur car may be in limp mode...basically reduces power so u dont completely destroy the engine...
Notorious_rob is offline   Reply With Quote
Old 03-21-2014, 08:28 AM   #3
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Yes its in limp mode. We ordered the tune with vin number.
robn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2014, 09:26 AM   #4
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
Dyno tune
08Mustang is offline   Reply With Quote
Old 03-21-2014, 10:12 AM   #5
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Sct tuner
robn is offline   Reply With Quote
Old 03-21-2014, 10:15 AM   #6
Admin

Supporter
Admin
 
bucko's Avatar
 
Join Date: Nov 2012
Location: Lake Mary
Region: Florida
Posts: 5,822
I'll assume you can set the tune back to stock and clear the problem while it's in "Limp" mode? Time to call the company that provided the tune and get some help.
__________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt.
bucko is offline   Reply With Quote
Old 03-21-2014, 11:46 AM   #7
Registered Member
Regular
 
08Mustang's Avatar
 
Join Date: Feb 2012
Region: Georgia
Posts: 2,401
No I'm saying get a dyno tune lol
08Mustang is offline   Reply With Quote
Old 03-21-2014, 12:01 PM   #8
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Would the dyno tune show the problem?
robn is offline   Reply With Quote
Old 03-21-2014, 12:05 PM   #9
Registered Member
Regular
 
audioAl's Avatar
 
Join Date: Jun 2012
Region: Texas
Posts: 604
Return that pony to stock. Then call SCT.
__________________
2014 DIB 3.7 "Blue Cyclone" on 275/40/18 RE 760 Sports/Sold
2016 ruby red GT 300 A with 3.55:1 gear/SVE resonator delete X-pipe/ UPR catch can/Airaid/AEM/J&M Bushings/ BMR cradle lockout/BMR CB006 brace/BMR cc bolts/S-04 pole position'
audioAl is offline   Reply With Quote
Old 03-21-2014, 01:06 PM   #10
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Ok thx
robn is offline   Reply With Quote
Old 03-21-2014, 09:00 PM   #11
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
Check engine light

I would call Call VMP Tuning...after ensuring the new intake was properly seated.
Depwraith is offline   Reply With Quote
Old 03-21-2014, 09:20 PM   #12
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Would that cause both engine lights to come on?
robn is offline   Reply With Quote
Old 03-22-2014, 07:14 AM   #13
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
I would imagine a leaking intake would cause a lot of things.
Depwraith is offline   Reply With Quote
Old 03-22-2014, 08:36 AM   #14
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Im pretty sure the guys looked at it when i brought it back to then
robn is offline   Reply With Quote
Old 03-22-2014, 08:42 AM   #15
Registered Member
Regular
 
blackhawk 1's Avatar
 
Join Date: Aug 2011
Region: California
Posts: 472
I would freak out if that happened to me
blackhawk 1 is offline   Reply With Quote
Old 03-22-2014, 09:24 AM   #16
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
I agree. Problem is the lights didnt come on right away. Only after i picked it up from the dealership to take it home. The car only has 500k on it. And there shop was like 2k from the dealership. So when they were done it was fine. And now they cant figure out what it could be. Thats why im asking on this forum
robn is offline   Reply With Quote
Old 03-22-2014, 09:33 AM   #17
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
And there shop is over 50k away from my house. So trying to minimize the tines going there and putting extra k's on my car. My 2010 only has 9000k on it. 5600 miles. Im in canada
robn is offline   Reply With Quote
Old 03-22-2014, 01:08 PM   #18
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
What codes is it throwing?
Depwraith is offline   Reply With Quote
Old 03-22-2014, 01:18 PM   #19
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Not sure. Just the 2 engine lights are on. Can i find the codes?
robn is offline   Reply With Quote
Old 03-22-2014, 04:04 PM   #20
Registered Member
Regular
 
KATO's Avatar
 
Join Date: Jul 2011
Location: Cutler Bay
Region: Florida
Posts: 1,593
Send a message via Yahoo to KATO
Your Tuner, should be able to tell you which Codes and what they mean.
__________________
07 GT. SCT: CUSTOM TUNE by "MUSTANG SPECIALTIES". LMR: GEN2 2010 STYLE HEADLIGHTS, RAXIOM: 2010 SMOKED COYOTE TAIL LIGHTS, WHEELS: STAGGERED WHL 22X8.5F-22X10R.
KATO is offline   Reply With Quote
Old 03-22-2014, 10:21 PM   #21
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Click image for larger version

Name:	ImageUploadedByMustang Evolution1395544862.603191.jpg
Views:	172
Size:	559.8 KB
ID:	151558
robn is offline   Reply With Quote
Old 03-23-2014, 07:46 PM   #22
Registered Member
Regular
 
KATO's Avatar
 
Join Date: Jul 2011
Location: Cutler Bay
Region: Florida
Posts: 1,593
Send a message via Yahoo to KATO
Call your Shop and ask them about Code: P061B. Ask them what to do.
__________________
07 GT. SCT: CUSTOM TUNE by "MUSTANG SPECIALTIES". LMR: GEN2 2010 STYLE HEADLIGHTS, RAXIOM: 2010 SMOKED COYOTE TAIL LIGHTS, WHEELS: STAGGERED WHL 22X8.5F-22X10R.
KATO is offline   Reply With Quote
Old 03-23-2014, 08:09 PM   #23
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
I'm telling you, double check the intake. That code usually indicates unmetered air is getting in.
Depwraith is offline   Reply With Quote
Old 03-23-2014, 08:49 PM   #24
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Im sorry. But im not sure what to look for beside it being tight. Everything appears tight. And i really appreciate everyones help here.
robn is offline   Reply With Quote
Old 03-24-2014, 08:35 PM   #25
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
Quote:
Originally Posted by robn View Post
Im sorry. But im not sure what to look for beside it being tight. Everything appears tight. And i really appreciate everyones help here.

Make sure everything is seated properly and tightened, even underneath where you can't see. Also double check filter installation and that there aren't any harnesses that got left unconnected or aren't fully seated.
Depwraith is offline   Reply With Quote
Old 03-28-2014, 03:10 PM   #26
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
I think wraith is speaking of the clamps where the intake is mounted to the throttle body or where the intake parts connect together. Mine was a booger to get tight enough. I ended up having my cold air pop off and having to put a ratchet on it and man tighten it. No hand screw driver would do the trick.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 03-28-2014, 03:49 PM   #27
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
And were you getting the same problem?
robn is offline   Reply With Quote
Old 03-29-2014, 01:41 PM   #28
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Yes. I'm not sure what the code was. I cleared it with my tuner. Check the MAF and all. My tuner also told me of course that I was lean in bank one and two.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 03-29-2014, 01:55 PM   #29
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Of course, I didn't drive it until I fixed it.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 03-29-2014, 08:36 PM   #30
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
So checked the connections of the intake all around and tightened them. The wrench came on first then the engine light. Only got 600k on this car.
robn is offline   Reply With Quote
Old 03-31-2014, 05:36 AM   #31
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
Quote:
Originally Posted by robn View Post
So checked the connections of the intake all around and tightened them. The wrench came on first then the engine light. Only got 600k on this car.

If everything is installed properly I would guess it must be your tune then.
Depwraith is offline   Reply With Quote
Old 04-05-2014, 08:19 PM   #32
Registered Member
Regular
 
Depwraith's Avatar
 
Join Date: May 2012
Region: Florida
Posts: 129
Figure things out? Inquiring minds want to know, lol.
Depwraith is offline   Reply With Quote
Old 04-05-2014, 09:39 PM   #33
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
I was wondering too lol
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Old 04-05-2014, 09:45 PM   #34
Registered Member
Regular
 
robn's Avatar
 
Join Date: Jan 2014
Location: Calgary
Region: Canada
Posts: 31
Nothing yet. Roads were not good enough to take it back to the shop. I will be dropping off next week while im out of town and they better fix it.
robn is offline   Reply With Quote
Old 04-05-2014, 09:47 PM   #35
Registered Member

Regular
 
Ubnbit's Avatar
 
Join Date: Jan 2013
Location: Tazewell
Region: Tennessee
Posts: 3,532
Yes sir. I agree 100%. So worrisome having somebodies hands on my car and then it to have a problem. That sick in the pit of the stomach feeling.
__________________
Tint, louvers, Shelby brake light cover, sequentials, brake vent ring delete, Shorty antenna, JLT cold air intake, BAMA tune, VMP 2.5 S/C pulley, Ford racing shifter, MRT OR-H, SLP loudmouths, BMR adj PHB, BMR LCA, Eibach Pro-Kit, cobra jet big oval TB.
Ubnbit is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > Shelby Mustang

Tags
check engine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with check engine light ey090605 2005-2010 Mustang GT 4 03-13-2014 07:52 PM
O2 sensor throwing the check engine light. frank07stanggt 2005-2010 Mustang GT 4 10-14-2011 11:02 AM
Check engine light? galindojr24 2005-2010 Mustang GT 42 08-30-2011 08:34 PM
'88 GT Check engine light? robert81717 ME Site Help & Announcements 1 07-19-2011 12:28 AM
'88 GT check engine light? robert81717 1979-1995 Mustang GT 7 07-13-2011 12:56 AM

» Like Us On Facebook



05:50 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.