just installed new clutch ram hdx drove about 5 miles and clutch got really hard? - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-14-2012, 09:14 PM   #1
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
just installed new clutch ram hdx drove about 5 miles and clutch got really hard?

Bought a ram hdx clutch from american muscle and firewall adjuster and steel clutch quadrant for my 97 cobra after driving about five miles clutch pedal got really hard and couldn't go down was shifting fine until I got to a stop sign and couldn't shift anymore cuz of the clutch pedal getting so stiff? What went wrong ? I know its a mechanical clutch not hydraulic clutch ..
Cobra209 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2012, 09:32 PM   #2
Registered Member
Regular
 
MiGT01's Avatar
 
Join Date: Jan 2012
Region: Michigan
Posts: 406
Re: just installed new clutch ram hdx drove about 5 miles and clutch got really hard?

Old clutch kindve did the same thing. Stiff pedal and squeaked like crazy. Installed same clutch last month with new fork too and havent had a problem. Could it lie in the quadrant or adjuster?
__________________
01 Black Beauty GT
Eibach pro kit,Tokico shocks/struts,BBK CAI,75mm TB/ Plenum,4.10 FRPP gears,BBK o/r X pipe,Magnaflow Catback,SCT Tuner running 91 Tune,Bama Tunes for Life Member,RAM HD Clutch,BM shifter with MGW "GT" knob,AM smoked Headlights/Sylvania zXe bulbs,VHT smoked tails/3rd brake,Redtop Optima,Mach 1 grille delete,Mach 1 chin spoiler,BULLITT Pedals,20% tint all round,4.6 High Performance Badges
MiGT01 is offline   Reply With Quote
Old 03-14-2012, 09:40 PM   #3
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
I had installed the ram hdx clutch first and had that problem I thought it would be the stock plastic quadrant so I bought that and yh

---------- Post added at 06:40 PM ---------- Previous post was at 06:38 PM ----------

Motorsports quadrant and firewall adjuster and still the same thing i been reading a lot of threads most saying about the fork
Cobra209 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2012, 08:27 PM   #4
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
After letting it sit over night the clutch went back to normal push all the way down and came up normal I have a feeling its goin to do that again where it gets hard ? What is the problem anyone ?
Cobra209 is offline   Reply With Quote
Old 03-15-2012, 09:14 PM   #5
Registered Member
Regular
 
MiGT01's Avatar
 
Join Date: Jan 2012
Region: Michigan
Posts: 406
Re: just installed new clutch ram hdx drove about 5 miles and clutch got really hard?

Quote:
Originally Posted by Cobra209 View Post
After letting it sit over night the clutch went back to normal push all the way down and came up normal I have a feeling its goin to do that again where it gets hard ? What is the problem anyone ?
My guess would be, aside from everything being new and installed.correctly, either the clutch fork or the clutch pivot bolt...like i said b4 i just had the same clutch installed and before that my pedal was stiff and squeaked..they showed me the old fork wore down and pivot bolt was in rough shape...both together was like 80$ from Ford
__________________
01 Black Beauty GT
Eibach pro kit,Tokico shocks/struts,BBK CAI,75mm TB/ Plenum,4.10 FRPP gears,BBK o/r X pipe,Magnaflow Catback,SCT Tuner running 91 Tune,Bama Tunes for Life Member,RAM HD Clutch,BM shifter with MGW "GT" knob,AM smoked Headlights/Sylvania zXe bulbs,VHT smoked tails/3rd brake,Redtop Optima,Mach 1 grille delete,Mach 1 chin spoiler,BULLITT Pedals,20% tint all round,4.6 High Performance Badges
MiGT01 is offline   Reply With Quote
Old 03-15-2012, 09:19 PM   #6
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
My mechanic is goin to be dropping the tranny tomorrow and going to check it out
Cobra209 is offline   Reply With Quote
Old 04-01-2012, 11:07 AM   #7
Registered User
Newbie
 
Join Date: Mar 2012
Region: Florida
Posts: 2
Where you able to fix the problem? I just installed a ram hdx yesterday along with a new fork, new cable and quadrant, and aluminum flywheel. I had the same problem after the first initial drive, tough to get into gear, and also my pedal doesn't go down far enough to press the switch so I can start the car. I'm thinking it's the pivot ball cause it was a little warn. I checked all over the place for one, local ford dealer said he doesn't show the part which is why I didn't replace it.
Guh_guh_goofin is offline   Reply With Quote
Old 04-01-2012, 01:19 PM   #8
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
Yes it was the fork the ended up getting out of place we put it back into its place and its been driving fine after that
Cobra209 is offline   Reply With Quote
Old 04-01-2012, 01:51 PM   #9
Registered Member
Regular
 
MiGT01's Avatar
 
Join Date: Jan 2012
Region: Michigan
Posts: 406
Re: just installed new clutch ram hdx drove about 5 miles and clutch got really hard?

Quote:
Originally Posted by Cobra209 View Post
Yes it was the fork the ended up getting out of place we put it back into its place and its been driving fine after that
Haha 1 point for me being right...woot! good stuff its fixed now
__________________
01 Black Beauty GT
Eibach pro kit,Tokico shocks/struts,BBK CAI,75mm TB/ Plenum,4.10 FRPP gears,BBK o/r X pipe,Magnaflow Catback,SCT Tuner running 91 Tune,Bama Tunes for Life Member,RAM HD Clutch,BM shifter with MGW "GT" knob,AM smoked Headlights/Sylvania zXe bulbs,VHT smoked tails/3rd brake,Redtop Optima,Mach 1 grille delete,Mach 1 chin spoiler,BULLITT Pedals,20% tint all round,4.6 High Performance Badges
MiGT01 is offline   Reply With Quote
Old 04-01-2012, 01:53 PM   #10
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
I know thanks migt01 I haven't had a chance to come and reply
Cobra209 is offline   Reply With Quote
Old 04-01-2012, 03:24 PM   #11
Registered User
Newbie
 
Join Date: Mar 2012
Region: Florida
Posts: 2
Huh, I'll have to check and see if mine may have slipped off the ball or something. Thanks tho and glad to hear its fixed.
Guh_guh_goofin is offline   Reply With Quote
Old 04-01-2012, 05:44 PM   #12
Registered Member
Regular
 
Cobra209's Avatar
 
Join Date: Jan 2012
Region: California
Posts: 49
Yea just double check everything from the adjuster to the quadrant ,fork, your cable
Cobra209 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wheels/Tires Possibly for sale and GT OEM Strut Tower avengnd Mustang Parts for Sale and Wanted 7 03-28-2012 09:07 AM
New AM Wheels and tires ... stampde 2005-2010 V6 Mustang 29 03-19-2012 05:44 AM
My car got hit Bighebs10 2011-2014 V6 Mustang 15 03-17-2012 01:59 AM
Really confused...exhaust linked to signal lights??? tdurham19 2005-2010 V6 Mustang 4 03-14-2012 10:00 PM
Wheels/Tires Possibly for sale and GT OEM Strut Tower avengnd 2011-2014 Mustang GT 4 03-14-2012 07:11 PM

» Like Us On Facebook



06:34 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.