Battery ran low now all of a sudden rough idle and no AC. Help! - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-06-2012, 07:14 PM   #1
Registered Member
Regular
 
Spiney's Avatar
 
Join Date: Jul 2011
Region: Pennsylvania
Posts: 320
Battery ran low now all of a sudden rough idle and no AC. Help!

I Was detailing my car and listening to the radio. The battery was already low from not driving it in a few weeks. The car only has 42K miles and was a garage queen. The battery went low enough car would not start. Before this car ran great and AC blew very cold. I jump started it. Then put in garage and put on a battery tender. Tonight we tried to go for a ride and rough idle and no AC. It appears the compressor isn't even kicking in. Any ideas? How long does it take to reset the ECU. It's going to be 102 tomorrow I really need AC. Thanks, Spiney-Dave

---------- Post added at 08:14 PM ---------- Previous post was at 08:11 PM ----------

Forgot to add its a 96 SVT Cobra. It's a garage queen with only 42K miles. It has ran great for the last year up until today.
Spiney is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2012, 05:42 PM   #2
Registered Member
Regular
 
Spiney's Avatar
 
Join Date: Jul 2011
Region: Pennsylvania
Posts: 320
Where is the constant control relay module. I looked at it closer today. Ac clutch not kicking in. Checked wiring, and fuses. Fuses are fine. Cleaned wiring contacts best I could no improvement. Would low freon keep clutch from kicking in? Should there be 12v at wires going into clutch when ac is on? What determines if clutch should be engaged? Thanks, Dave
Spiney is offline   Reply With Quote
Old 07-07-2012, 08:06 PM   #3
Registered Member
Regular
 
lBRAlD's Avatar
 
Join Date: Jan 2012
Region: Alabama
Posts: 280
Low freon shouldn't keep clutch from kicking in.
lBRAlD is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2012, 09:12 PM   #4
Registered Member
Regular
 
Spiney's Avatar
 
Join Date: Jul 2011
Region: Pennsylvania
Posts: 320
What does the CCRM look like and where do I find it? I read there may be an issue with a connector on there. Also where do I find the low pressure sensor. I want to jumper it to see if I can get the clutch to kick in. Thanks, Dave.

I will exhaust all options before I take it to the garage!
Spiney is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



10:26 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.