Running lean HELP! - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-06-2013, 01:57 PM   #1
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Whats up guys, im having trouble getting my 97 cobra to pass smog and it's all because of 2 trouble codes. One says sensor indicates lean then a screen telling me my fuel system is faulty and the second code says as im running lean as well, it also says LACK OF H02S21 SWITCHES. Also the AIR and CAT's bubble is flashing on my obd2. i think my airbag is unplugged but i have no clue what to do on my cat's. here hare the pictures, thanks for the help.




Click image for larger version

Name:	image-3095636160.jpg
Views:	791
Size:	431.1 KB
ID:	112441



Click image for larger version

Name:	image-2014559745.jpg
Views:	223
Size:	421.4 KB
ID:	112442



Click image for larger version

Name:	image-990339355.jpg
Views:	664
Size:	408.8 KB
ID:	112443
94 GT 5.0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-07-2013, 08:52 AM   #2
Registered Member
Regular
 
Black99Snake's Avatar
 
Join Date: Jun 2011
Region: Colorado
Posts: 433
Possibly one of your upstream o2 sensors may be out. Those tell your computer to lean it or richen it up. Google the dtc and see what it says. Or an injector or injectors.

---------- Post added at 01:52 PM ---------- Previous post was at 01:52 PM ----------

The 1151 is an o2 sensor
__________________
1999 Cobra black with medium parchment interiorJLT CAI, RWR motorsports tune, Pacesetter Longtubes, o/r xpipe w/cutouts, Flowmaster Super 44s, built t56, Kevlar clutch, Nitto NT05R, Ford Racing 4.10 gears, MMR 900 rotating assembly, vortech v3 si, twin aeromotive 340s, aeroquip lines, 80lbs injectors
Black99Snake is offline   Reply With Quote
Old 06-08-2013, 02:47 PM   #3
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
That's what im thinking, but if the o2 sensors were out wouldnt the CEL turn on?
94 GT 5.0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-08-2013, 03:15 PM   #4
Registered Member
Regular
 
Black99Snake's Avatar
 
Join Date: Jun 2011
Region: Colorado
Posts: 433
The cel is check engine light. You should have a light on if you pulled the p1151 code.
__________________
1999 Cobra black with medium parchment interiorJLT CAI, RWR motorsports tune, Pacesetter Longtubes, o/r xpipe w/cutouts, Flowmaster Super 44s, built t56, Kevlar clutch, Nitto NT05R, Ford Racing 4.10 gears, MMR 900 rotating assembly, vortech v3 si, twin aeromotive 340s, aeroquip lines, 80lbs injectors
Black99Snake is offline   Reply With Quote
Old 06-09-2013, 02:46 PM   #5
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Quote:
Originally Posted by Black99Snake View Post
The cel is check engine light. You should have a light on if you pulled the p1151 code.
Yea that's why im saying shouldn't it be on? Because it doesn't turn on, but the light does work. It turns on when i turn the key to on position. Thanks for the help by the way.
94 GT 5.0 is offline   Reply With Quote
Old 06-12-2013, 07:39 AM   #6
Registered Member
Regular
 
Black99Snake's Avatar
 
Join Date: Jun 2011
Region: Colorado
Posts: 433
Gottcha. Thats a strange one
__________________
1999 Cobra black with medium parchment interiorJLT CAI, RWR motorsports tune, Pacesetter Longtubes, o/r xpipe w/cutouts, Flowmaster Super 44s, built t56, Kevlar clutch, Nitto NT05R, Ford Racing 4.10 gears, MMR 900 rotating assembly, vortech v3 si, twin aeromotive 340s, aeroquip lines, 80lbs injectors
Black99Snake is offline   Reply With Quote
Old 06-15-2013, 08:03 PM   #7
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Quote:
Originally Posted by Black99Snake View Post
Gottcha. Thats a strange one
Yea man, it's pissing me off. I need to get it smogged so i can finally get it under my name!. If you think of anything let me know.
94 GT 5.0 is offline   Reply With Quote
Old 06-22-2013, 03:27 PM   #8
Registered Member
Regular
 
540i6e39's Avatar
 
Join Date: Jun 2013
Location: Sacramento
Region: California
Posts: 155
Most likely its the rear O2. Also car wont pass smog with the airbag light or cel on. It could be running lean from a cracked injector. I cracked a injector once changing my upper intake manifold on my 95 mustang years ago. Also check for vacuum leaks.
540i6e39 is offline   Reply With Quote
Old 06-24-2013, 04:25 PM   #9
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Quote:
Originally Posted by 540i6e39 View Post
Most likely its the rear O2. Also car wont pass smog with the airbag light or cel on. It could be running lean from a cracked injector. I cracked a injector once changing my upper intake manifold on my 95 mustang years ago. Also check for vacuum leaks.
+5 that's the answer i was looking for! Thank you!
94 GT 5.0 is offline   Reply With Quote
Old 06-24-2013, 05:22 PM   #10
Registered Member
Regular
 
540i6e39's Avatar
 
Join Date: Jun 2013
Location: Sacramento
Region: California
Posts: 155
Quote:
Originally Posted by 94 GT 5.0 View Post

+5 that's the answer i was looking for! Thank you!
Hope I helped
540i6e39 is offline   Reply With Quote
Old 06-25-2013, 03:11 AM   #11
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Quote:
Originally Posted by 540i6e39 View Post

Hope I helped
Sure did man thanks. I think you pretty much answered all the questions i put up on here, i appreciate it man. +100
94 GT 5.0 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:51 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.