What happened Cobra keeps dying? - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-21-2013, 10:54 AM   #1
Registered User
Newbie
 
ericnikc's Avatar
 
Join Date: Jul 2013
Location: Fairfield
Region: California
Posts: 2
What happened Cobra keeps dying?

I was recently swapping out a battery, I went full ****** and accidentally connected the wrong terminals, some smoke came out on a wire (i think the positive) and now the battery wont charge when it runs, and the speedometer also wont work any idea what it might be or what might've fried?
'96 Cobra Mystic
ericnikc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2013, 11:01 AM   #2
Registered User
Newbie
 
ericnikc's Avatar
 
Join Date: Jul 2013
Location: Fairfield
Region: California
Posts: 2
BTW I swapped out the wire, I dont know if it might be the alternator
ericnikc is offline   Reply With Quote
Old 07-21-2013, 11:15 AM   #3
Registered Member
Regular
 
Doe_Rae_mi's Avatar
 
Join Date: Nov 2011
Region: South Carolina
Posts: 2,587
Quote:
Originally Posted by ericnikc View Post
BTW I swapped out the wire, I dont know if it might be the alternator
coulda been a Fuse, also if it's running but the battery wont charge it's your alternator
Doe_Rae_mi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2013, 09:36 PM   #4
Registered Member
Regular
 
94 GT 5.0's Avatar
 
Join Date: Mar 2013
Location: SF
Region: California
Posts: 221
Uh oh, most likely you burned out a fuse. Take it to your local autozone or parts store and ask if they can check the voltage on your alternator, battery etc.., it's usually free at autozone. Good luck
94 GT 5.0 is offline   Reply With Quote
Old 07-22-2013, 05:29 AM   #5
Registered Member
Regular
 
Black99Snake's Avatar
 
Join Date: Jun 2011
Region: Colorado
Posts: 433
Check all your fuses inside the cabin and the engine bay. I accidentally did that on my bike few months back. Blew a fuse
__________________
1999 Cobra black with medium parchment interiorJLT CAI, RWR motorsports tune, Pacesetter Longtubes, o/r xpipe w/cutouts, Flowmaster Super 44s, built t56, Kevlar clutch, Nitto NT05R, Ford Racing 4.10 gears, MMR 900 rotating assembly, vortech v3 si, twin aeromotive 340s, aeroquip lines, 80lbs injectors
Black99Snake is offline   Reply With Quote
Old 07-22-2013, 07:19 PM   #6
Registered Member
Regular
 
Mystic96's Avatar
 
Join Date: Oct 2012
Location: KC
Region: Missouri
Posts: 161
Check this out brother might help ya out there might be a fusable link instead of a fuse problem. I have a '96 Mystic too but the batts been re-located to the trunk hope the link helps. Hey by ur name on here looks like ur in KC I'm 30 minutes outside Lee Summit.
http://troubleshootmyvehicle.com/for...e-alternator-2
Mystic96 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



07:14 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.