Interesting thing in the Cobra tonight - Mustang Evolution

Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 12-12-2014, 05:26 AM   #1
Moderator Emeritus
Regular
 
MC770's Avatar
 
Join Date: Oct 2010
Location: Charlotte
Region: North Carolina
Posts: 1,761
Interesting thing in the Cobra tonight

Well I was on my way home from work at about 330am this morning when I was getting off the off ramp of the highway the cars battery light popped on and the car died, I was going about 65-70mph and had the heat on the lowest fan speed and the radio above an average volume due to the exhaust lol. I restarted the car and it was fine for about five to ten seconds when the exact same thing happened again. This time I cut off the fan and the radio thinking this could be something either battery or alternator related. After the second time it did not happen again for the rest of the ride home, my question for you guys is does that seem about right or is there other things you may know of as to why this happened?
__________________
~2003 Zinc Yellow Terminator Cobra~
~482 RWHP / 487 LBS Torque~
MC770 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-12-2014, 06:01 AM   #2
Registered Member
Regular
 
Rapinator126's Avatar
 
Join Date: Dec 2011
Region: Texas
Posts: 9,245
Alternator. The 03/04 cobras are prone to the factory alternator failing. Swap it out.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
Rapinator126 is offline   Reply With Quote
Old 12-12-2014, 06:04 AM   #3
Moderator Emeritus
Regular
 
MC770's Avatar
 
Join Date: Oct 2010
Location: Charlotte
Region: North Carolina
Posts: 1,761
Exactly what I had thought and was hoping I hate electrical gremlins, thanks man I'll deff be checking up on that alt
__________________
~2003 Zinc Yellow Terminator Cobra~
~482 RWHP / 487 LBS Torque~
MC770 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-13-2014, 11:51 PM   #4
Registered Member
Regular
 
XSlashDashX's Avatar
 
Join Date: Nov 2011
Location: Silsbee
Region: Texas
Posts: 1,224
Yeah, definitely alt problem.

Sent from my LGLS990 using Mustang Evolution mobile app
XSlashDashX is offline   Reply With Quote
Old 12-14-2014, 12:24 AM   #5
Moderator Emeritus
Regular
 
MC770's Avatar
 
Join Date: Oct 2010
Location: Charlotte
Region: North Carolina
Posts: 1,761
Interesting thing in the Cobra tonight

Well I think it may be related to my idle surge, when stopped the idle drops from 1k down to like 6-700 rpms and then bounce back and forth between them, I think it may have just been dropping too low and stalling?
__________________
~2003 Zinc Yellow Terminator Cobra~
~482 RWHP / 487 LBS Torque~
MC770 is offline   Reply With Quote
Old 12-15-2014, 05:26 PM   #6
Moderator Emeritus
Regular
 
MC770's Avatar
 
Join Date: Oct 2010
Location: Charlotte
Region: North Carolina
Posts: 1,761
Okay so the problem still persisit, when sitting still in neutral the idle will drop from 1k to about 500rpm and then go back and forth. However if I'm coming to a stop from about 50mph and just put it in neutral and brake to a stop the car will drop rpms all the way down to 100-stalling the car. I've pulled the IAC off and looked and cleaned it a little and the problem is still there, any insight would be awesome! thanks

This video is me coming to a stop from 50mph in netural
__________________
~2003 Zinc Yellow Terminator Cobra~
~482 RWHP / 487 LBS Torque~
MC770 is offline   Reply With Quote
Old 02-23-2015, 01:44 PM   #7
Junior Member
 
Join Date: Feb 2015
Posts: 1
My guess would be the to check the IAC valve then clean/replace as needed.

Sent from my SM-G730V using Tapatalk
psyviperx is offline   Reply With Quote
Old 03-12-2015, 09:50 PM   #8
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
No matter what, I use a Dremel tool the clean up every single connector from both sides of battery, Alternator line side (feeder wire) wire to alternator from battery area all cleaned up.
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Old 03-15-2015, 10:57 AM   #9
Registered Member
Regular
 
robb15033's Avatar
 
Join Date: Oct 2010
Location: Northern Virginia
Region: Virginia
Posts: 2,109
Also, my car never ran perfect until i ran a small gauge ground wire from battery to alternator body. I used a 4 0r 6 gauge monster wire positive and negative side fused on positive side.
__________________
'97 3.8L V6
Pacific Green
1996 SVT Cobra White
robb15033 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Shelby | ROUSH | Boss | Saleen | SVT || Tech and Talk > SVT Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Going to the dag strip tonight. Looking for launch RPM tips 96 Cobra Spiney SVT Mustang 3 06-22-2013 03:09 PM
Is there such thing as a 1965 Mustang Cobra? hastiin General Mustang Discussion 11 08-22-2009 02:31 AM
Interesting project for a 96 cobra SpectorV The Bar 14 06-11-2005 11:33 PM
Some sort of import thing in huntsville tonight? SpectorV Regional Mustang Discussion 2 05-07-2005 11:21 PM
Interesting, very interesting.....hmmm Rick0636 The Bar 6 05-04-2004 12:06 PM

» Like Us On Facebook



01:47 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.