HID problem! - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang DIY and Technical



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-27-2014, 05:50 PM   #1
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
HID problem!

I had an hid bulb go out so i ordered new ones, put them in and they started flickering consistently. So i ordered a relay harness, and they're STILL flickering. Ballasts are connected through capacitors as well. Grounds are good, now i am stumped. Any suggestions would be greatly appreciated.

Sent from my LG-LS970 using Mustang Evolution mobile app
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-27-2014, 05:51 PM   #2
ME Bloodhound
Staff
 
Soccerluvr4's Avatar
 
Join Date: Feb 2012
Location: Sacramento/Bay Area
Region: California
Posts: 14,672
Put in normal headlight bulbs... Everyone wins.
__________________

Bullitt build paused pending graduation

HID end all thread
Soccerluvr4 is offline   Reply With Quote
Old 06-27-2014, 05:54 PM   #3
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
My headlights have projectors, i never get flashed unless my fog lights are on, and the fogs have regular bulbs

Sent from my LG-LS970 using Mustang Evolution mobile app
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-27-2014, 06:14 PM   #4
Road Trip!
Regular
 
Join Date: May 2013
Location: Phoenix, Az
Region: Arizona
Posts: 1,037
That was happening to a friend of mine and it turned out to be a bad bulb
Joser714 is offline   Reply With Quote
Old 06-27-2014, 06:20 PM   #5
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
First they sent me two different colored bulbs, (they flickered as well) so i called them and they sent me a new pair and they still flicker. I've had no problems with just the capacitors installed until 1 bulb blew up and went out. Bad capacitors maybe?

Sent from my LG-LS970 using Mustang Evolution mobile app
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Old 06-27-2014, 09:35 PM   #6
Road Trip!
Regular
 
Join Date: May 2013
Location: Phoenix, Az
Region: Arizona
Posts: 1,037
Honestly idk what a cap for an hid kit is. Maybe take them out and just use the ballast
Joser714 is offline   Reply With Quote
Old 06-27-2014, 09:45 PM   #7
Registered Member
Regular
 
Joe_Roma5's Avatar
 
Join Date: Jul 2012
Location: Saint Paul
Region: Minnesota
Posts: 137
Quote:
Originally Posted by Joser714 View Post
Honestly idk what a cap for an hid kit is. Maybe take them out and just use the ballast
Capacitor will allow a continuous amount of electricity to flow to the ballast. They're required for vehicles that have a low voltage sensor for the headlights because they use less energy than standard halogen bulbs

Sent from my LG-LS970 using Mustang Evolution mobile app
__________________
'06 4.0 V6 custom x pipes, cai, screamin demon coil pack, 10mm live wires spark plug wires, NGK iridium plugs, 93 octane bama tune
Joe_Roma5 is offline   Reply With Quote
Old 06-27-2014, 11:49 PM   #8
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
It's possible it could a bad capacitor. I'd start with the one that supplied power to the bulb that blew.

Sent from your mom's house.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is online now   Reply With Quote
Old 06-27-2014, 11:58 PM   #9
Registered Member
Regular
 
2 Stangz's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Region: Nevada
Posts: 2,093
Either bad connection from the start or bad Chinese kit. Morimoto is the only way to go.
__________________
2010 GT Premium - Automatic - Torch Red
2 Stangz is offline   Reply With Quote
Old 06-28-2014, 01:45 AM   #10
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Quote:
Originally Posted by 2 Stangz View Post
Morimoto is the only way to go.
Yep. That's what I'm running in the retrofit I'm working on. Plugged them in to test them and not only do they warm up in seconds, it's a bright, steady light.

Sent from your mom's house.
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is online now   Reply With Quote
Old 06-29-2014, 01:01 PM   #11
Registered Member
Regular
 
2 Stangz's Avatar
 
Join Date: Sep 2013
Location: Las Vegas
Region: Nevada
Posts: 2,093
Quote:
Originally Posted by WhoDat View Post
Yep. That's what I'm running in the retrofit I'm working on. Plugged them in to test them and not only do they warm up in seconds, it's a bright, steady light.

Sent from your mom's house.
Bright, steady light, that will last for years WITH a 2yr/5yr warranty and never waste time "figuring out" dumb flickering.
__________________
2010 GT Premium - Automatic - Torch Red
2 Stangz is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang DIY and Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HID problem Horseplay Mustang Paint, Appearance & Detailing 4 01-07-2013 06:41 PM
HID Foglight Problem EthanGT03 General Mustang Discussion 9 11-27-2012 11:07 PM
HID problem GoldenPonyBoy 2005-2010 V6 Mustang 8 08-21-2012 10:43 PM
Does anyone have problem after replace the head to HID? jmpark527 2005-2010 Mustang GT 2 12-27-2011 02:06 PM
HID problem ProjectPunisher 1979-1995 Mustang GT 0 06-28-2008 11:33 AM

» Like Us On Facebook



07:05 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.