Electrical Problems? - Mustang Evolution

Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang DIY and Technical



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 11-23-2015, 08:59 AM   #1
Registered User
Newbie
 
Join Date: Jun 2013
Location: Chattanooga TN
Region: Tennessee
Posts: 5
Question Electrical Problems?

Hi all,

I have a 2013 V6 that I've been happy with (aside from the misfiring in sport mode due to the intake I installed, but I've come to live with that).

Recently, about a month and a half ago, I had my battery die (that happens every few months due to my radar detector being always on, if I leave it for more than a couple days it dies). This time, when I jumped it, it had some weird electrical issues that have come up.

When I first jumped it, it seemed to have a lot of electrical abnormalities. The first one I noticed was that my driver window didn't work. That started working again after I turned the car off and back on, though. Another thing was that it wouldn't release my key when turning the car off, it did that for a day or two then that seemed to fix itself. However, some other things have continued to not work since then.

A few things that I've noticed aren't working right since then:
1. The steering lock just doesn't work when in park, the steering wheel can be turned freely.
2. My front left foglight stopped working. Could be that the HID bulb died... but it's unlikely that it happened at the exact same time as everything else, yes?
3. I've just now noticed that I can't get any heat when the car is not under power. The car heats up to normal temperature at a normal speed (at least according to the temperature gauge), but I can't get any heat to come out of the system unless I'm running really high RPMs. If I put the car in 2nd, heat will come out as I'm running high RPMs, but anything short of a good amount of power results in cold air for the first 15-20 minutes that I'm in the car. Unless I'm on the interstate of course, then it is under load and gives normal heat.

The last one is the one that finally prompted me to inquire about this, because where I am, it is now in the 20s every day and the heat thing is becoming more of an issue.

I have checked all of the fuses in the cabin, especially the ones relating to any of the issues I've described, and they're all fine. It's like these are all tied together, but randomly, and are related to something I'm missing.

Has anyone seen anything like this before, or have any ideas of things I might try? Beyond fuses, I'm really pretty lost to what it could be..
vcantrell is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-23-2015, 10:50 AM   #2
Registered Member
Regular
 
Join Date: Jun 2015
Location: HARTWELL LAKE AREA
Region: South Carolina
Posts: 435
On the heat problem, does the fan not blow at all or does the fan blow and only blows cold air?

All this could be a blown bcm from improper jump start procedures

if the later check coolent level
ALLYDRIVER1 is offline   Reply With Quote
Old 11-25-2015, 05:44 PM   #3
Registered Member
Regular
 
Join Date: Oct 2015
Location: Foxboro
Region: Massachusetts
Posts: 49
Quote:
Originally Posted by vcantrell View Post
Hi all,

I have a 2013 V6 that I've been happy with (aside from the misfiring in sport mode due to the intake I installed, but I've come to live with that).

Recently, about a month and a half ago, I had my battery die (that happens every few months due to my radar detector being always on, if I leave it for more than a couple days it dies). This time, when I jumped it, it had some weird electrical issues that have come up.

When I first jumped it, it seemed to have a lot of electrical abnormalities. The first one I noticed was that my driver window didn't work. That started working again after I turned the car off and back on, though. Another thing was that it wouldn't release my key when turning the car off, it did that for a day or two then that seemed to fix itself. However, some other things have continued to not work since then.

A few things that I've noticed aren't working right since then:
1. The steering lock just doesn't work when in park, the steering wheel can be turned freely.
2. My front left foglight stopped working. Could be that the HID bulb died... but it's unlikely that it happened at the exact same time as everything else, yes?
3. I've just now noticed that I can't get any heat when the car is not under power. The car heats up to normal temperature at a normal speed (at least according to the temperature gauge), but I can't get any heat to come out of the system unless I'm running really high RPMs. If I put the car in 2nd, heat will come out as I'm running high RPMs, but anything short of a good amount of power results in cold air for the first 15-20 minutes that I'm in the car. Unless I'm on the interstate of course, then it is under load and gives normal heat.

The last one is the one that finally prompted me to inquire about this, because where I am, it is now in the 20s every day and the heat thing is becoming more of an issue.

I have checked all of the fuses in the cabin, especially the ones relating to any of the issues I've described, and they're all fine. It's like these are all tied together, but randomly, and are related to something I'm missing.

Has anyone seen anything like this before, or have any ideas of things I might try? Beyond fuses, I'm really pretty lost to what it could be..
Heat issue- it sounds like you have air in the system, bleed the air out of the coolant system.
fishman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-2015, 09:20 AM   #4
Registered Member
Regular
 
Diehard's Avatar
 
Join Date: Mar 2014
Location: North Reading
Region: Massachusetts
Posts: 2,112
Put that, "radar detector being always on" problem, at the top of your list of things to be fixed.
__________________
____________________________________________________
14 V6 auto, MCA, PP, BBK Shorties, MMD Hood Struts, Borla Touring A/B's, MAC ProChamber, aFe drop-in Filter
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Lets not forget, an opinion is a judgment, viewpoint, or statement about matters commonly considered to be subjective.
Diehard is offline   Reply With Quote
Old 11-28-2015, 02:48 PM   #5
Registered Member

Regular
 
tym_v6's Avatar
 
Join Date: Feb 2015
Location: Suck it, Goodell
Region: Massachusetts
Posts: 1,340
Quote:
Originally Posted by Diehard View Post
Put that, "radar detector being always on" problem, at the top of your list of things to be fixed.
+1.

If you power it off the mirror, it'll be on the accessory delay circuit, coming on with the ignition and shutting off when you open the door to exit the car--automatically.
tym_v6 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Ford Mustang | Wrenching, Care and General Topics > Mustang DIY and Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bugging out dashboard/battery light help! electrical problems ponyobsessed Pre-2005 V6 Mustang 0 01-20-2012 01:09 AM
New member with electrical & idle problems Kevin8677 New Member Introductions & Greetings 1 01-17-2012 08:53 PM
wierd electrical problems pleeaase help! mhobbs 1996-2004 Mustang GT 3 03-09-2011 06:21 PM
Fixing minor electrical problems 1983 Mustangman General Mustang Discussion 0 06-25-2010 11:50 PM
Major Electrical Problems wkndpaintballer 2005-2010 Mustang GT 9 11-05-2009 06:14 PM

» Like Us On Facebook



10:38 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.