Experiencing Low RPM - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-16-2015, 03:41 PM   #1
Registered Member
Regular
 
Join Date: May 2015
Location: findf
Region: Other
Posts: 91
Unhappy Experiencing Low RPM

Hi,
I have a 14 Mustang GT AUTOMATIC and I am running a custom tune w/ 93 Octane by Lund and Bama as well
Recently, I am experiencing a weird behaviour in my car.
I can barley reach 3500 plus RPM and it feels like my car resists to me when ever i touch the acceleration pedal. The car accelerates but on a really low RPM.
When i release the pedal, the RPM are getting really low and my car is slowing dramatically (not as normal).

I tried to re flash both Bama and Lund but it doesn't seem to be related.
Do you have any idea what am I experiencing?
Thanks!
demas is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-16-2015, 05:53 PM   #2
Registered Member
Regular
 
Join Date: Feb 2014
Location: salem
Region: Wisconsin
Posts: 384
Call BAMA.
bodon is offline   Reply With Quote
Old 07-17-2015, 12:23 AM   #3
Registered Member
Regular
 
Join Date: May 2015
Location: findf
Region: Other
Posts: 91
Actually I sent idle and neutral data logs to Lund and they say it looks ok so. I have this issue with both tunes so my guess is that it doesn't related to it.
demas is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft Sync issue...anyone experiencing this problem? HPFury 2011-2014 Mustang GT 3 01-01-2014 02:04 AM
anyone experiencing this? schmitty426 The Bar 4 01-20-2013 03:06 PM
'13 Automatic guys... low rpm question for ya alludc 2011-2014 V6 Mustang 10 12-31-2012 05:03 PM
shaking at low rpm mustangg2000 Pre-2005 V6 Mustang 25 01-30-2012 08:28 PM
May cause slight chatter at low RPM engagement SuperItalian Pre-2005 V6 Mustang 0 06-12-2007 02:43 PM

» Like Us On Facebook



12:57 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.