need help brake lights dont work - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 09-03-2015, 09:45 AM   #1
Registered Member
Regular
 
Join Date: Feb 2013
Location: San Antonio
Region: Texas
Posts: 25
need help brake lights dont work

change the brake light switch and checked all fuzes
richardlab is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-10-2015, 01:51 AM   #2
Registered Member
Regular
 
Mean14's Avatar
 
Join Date: May 2015
Location: Chicago
Region: Illinois
Posts: 594
Happened to me one time in my new edge. Came to realize, when putting one of the taillights back in, I pinched a wire causing it to short out and the brake lights didn't work at all. Got pulled over for it lol. Cop let me go. But maybe you're having the same issue?
__________________

Procharged D1 on 12Lbs, MPT 93 Tune, 73mm BBK TB, Ported Upper/Lower Intakes, BBK Shorty Headers, FRPP Cut n Clamp Xpipe, Borla S-Types, Barton Short Shifter/Blowfish Bracket, SS Clutch Line, Whiteline Trans Bushing, One Piece Driveshaft, Front and Rear Tower Brace, Whiteline Front and Rear Sway Bars, Whiteline Adj LCAs/Adj UCA, BMR Relocation Brackets, BMR adj Panhard Bar, Eibach Sportlines, FRPP Dampers, 20" AMRs, 3.55 gears, Brembos
Mean14 is offline   Reply With Quote
Old 09-10-2015, 06:02 AM   #3
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
you are going to have to start checking for voltage.

1st on both sides of brake switch then check it at lights. Have you done anything else that you didn't mention (new lights/stereo/etc?)
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-10-2015, 06:14 AM   #4
Registered Member
Regular
 
Join Date: Feb 2013
Location: San Antonio
Region: Texas
Posts: 25
No nothing new went and had it look at a shop they said it was a fuse

Sent from my SAMSUNG-SM-G920A using Tapatalk
richardlab is offline   Reply With Quote
Old 09-10-2015, 06:19 AM   #5
Registered Member
Regular
 
Join Date: Feb 2013
Location: San Antonio
Region: Texas
Posts: 25
It's funny checked each fuse pulled it out and put it right back they said I had a 5 amp it needed a 25amp it cost me 20 worth the money now have brakes

Sent from my SAMSUNG-SM-G920A using Tapatalk
richardlab is offline   Reply With Quote
Old 09-10-2015, 06:59 AM   #6
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 5,022
cool and if they made the right call $20 was a fair price.
__________________
2012 V6 with suspension, shifting, stopping and sound mods.
Strange Mud is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail lights dont work Fiveohfox 1979-1995 Mustang GT 2 10-24-2012 10:17 PM
Dont you hate when things dont go as planed 1995boss General Mustang Discussion 7 03-29-2012 02:34 PM
Fog lights dont work BeasGT 1996-2004 Mustang GT 4 02-16-2012 06:06 AM
the #1 you DONT want to get off of work early...... fast64 The Bar 27 10-29-2004 07:42 AM
Dont Work To Hard KrazyPony The Bar 8 08-02-2004 05:58 PM

» Like Us On Facebook



09:12 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.