Please help - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 03-04-2016, 03:43 PM   #1
Registered User
Newbie
 
Join Date: Mar 2016
Location: San antonio
Region: Texas
Posts: 4
Please help

Hey guys i have a 2010 mustang gt and i recently took my car to a shop to get cut cats and they welded straight pipe on and not to long ago i heard ticking/knocking underhood and my car/ motor started shaking and i have a rough idle an my car like missfire it sounds like i have cams in my car please help no one can tell me whats wrong with it
Fasil1234 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-05-2016, 07:47 PM   #2
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
Did you tune it for the cat delete?

Sent from my HTC Desire 610 using Mustang Evolution mobile app
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Old 03-06-2016, 06:51 PM   #3
Registered User
Newbie
 
Join Date: Mar 2016
Location: San antonio
Region: Texas
Posts: 4
No i havent i didnt think it needed it because i people were saying how you didnt need a tune and my car was running fine until its started being like that
Fasil1234 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2016, 06:53 PM   #4
Registered User
Newbie
 
Join Date: Mar 2016
Location: San antonio
Region: Texas
Posts: 4
Will my car go back to normal if i just put the cats back on?
Fasil1234 is offline   Reply With Quote
Old 03-06-2016, 09:57 PM   #5
Abominable Mustang

Regular
Staff
 
WhoDat's Avatar
 
Join Date: Aug 2012
Location: Anchorage
Region: Alaska
Posts: 1,925
I know the newer motors (2011+) can run a catless midpipe without any major issues, usually just running rich and/or throwing a code. I'm not sure about the older ones though. I'd either reinstall the cats, or get it tuned since that sounds like the only thing done near the time you started having issues.

Sent from my HTC Desire 610 using Mustang Evolution mobile app
__________________
2012 Kona Blue 3.7L V6:
Borla LT headers, O/R h-pipe, Borla S-types, 3.73 gears,
Steeda adjustable UCA w/ mount, BMR LCAs, Airaid CAI,
LCA Relocation brackets, AE driveshaft, GT 80mm TB,
Black 18x9/10 2010 GT500 Wheels w/ Nitto NT555s,
Eibach Sportline Springs/shocks & Koni STR.T Struts
WhoDat is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 92 mustang died please help please wont start HybridTruth93 1979-1995 Mustang GT 2 05-04-2014 04:07 PM
Please help me! Please!! 98StangKid SVT Mustang 0 05-17-2013 10:40 PM
PLEASE, PLEASE HELP!!! Zoe 2005-2010 V6 Mustang 6 03-11-2012 02:19 PM
MT82 Transmission Issue...Please Read and Please HELP DannyDoright 2011-2014 V6 Mustang 5 03-02-2012 09:46 AM
Sold a Car Please, please help!!? booth General Mustang Discussion 9 03-20-2010 10:29 AM

» Like Us On Facebook



10:45 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.