2003 V6 Lag in acceleration? - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Join Mustang Evolution Today


Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-09-2016, 03:16 PM   #1
Registered User
Newbie
 
Join Date: Jul 2016
Location: Bel air
Region: Maryland
Posts: 3
2003 V6 Lag in acceleration?

Hello, I'm new to this site and could use some help spinning off some ideas. I try to all the work I can my self unless it's a big problem. I work at an AutoPlus, parts are not a problem. My v6 has just hit 190,000 miles I bought it at about 148,000 miles. This started about a week Just recently in the past few days or so and it's gotten worse I feel like I'm receiving lag when accelerating from stop or just slowly accelerating while I'm cruising around 1000 rpms to 2000 rpms if I floor the gas no lag at all... I've had the torque converter, rear main seal replaced in the trans around 150,000 miles. The trans fluid replaced around that time as well. I bought a cold air intake from bbk and put it on around 155,000 miles went to work today and got k&n recharge kit followed the instructions even got some gum cutter cleaned the cai itself. Put it all back together going to work an hour later same problem. I never did a chip or anything but I've had this set up for over 30,000 miles no issues? Any idea what it could be I've read anything from an o2 sensor, to chip it, to replace throttle body, to fuel filter?


Please help also another issue no idea if it's related when I'm going from stop to accelerate its automatic so I can't tell what gear but around 35 miles per hour it will get stuck and not want to go down In rpms unless I punch the gas or let off for a little.. This issue started about 4 months ago


When I say lag I mean actual lag like you experience in a video game kind of feeling. Slowly push on gas pedal car feels like it's moving backwards and forwards while accelerating slowly if I floor it can't feel anything wrong

Also I filled the tank and added Lucas fuel injector cleaner in it

Plugs and wires replaced at 150,000 miles due to misfire.
Jessej1194 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-10-2016, 11:29 PM   #2
Registered User
Newbie
 
Join Date: Jul 2016
Location: Bel air
Region: Maryland
Posts: 3
It's now starting to make like a popping noise here and there getting more frequent someone please help
Jessej1194 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2016, 09:47 AM   #3
Registered Member
Regular
 
David Young's Avatar
 
Join Date: Feb 2013
Location: Clinton
Region: Tennessee
Posts: 777
Not for the same motor but the same procedure https://youtu.be/JPNnHU6PYbo
__________________
Little Red. 2011 V6. Automatic Trans., C&L CAI, JLT Catch Can, BBK Ceramic Coated Long Tube Headers with BBK Catted X Pipe, Axle Exchange (American Muscle) Aluminum DriveShaft, GT 500 Lower Control Arms, Koni (orange) Dampers, Steeda Watts Link, Ford Racing 3.73 Gears, Magnaflow Street Series Axle Backs and a few more mods....Wifes car, 2014 Ford Edge Limited.
David Young is offline   Reply With Quote
Old 07-12-2016, 09:49 AM   #4
Registered Member
Regular
 
David Young's Avatar
 
Join Date: Feb 2013
Location: Clinton
Region: Tennessee
Posts: 777
The popping sound could be the front strut mounts but could be a lot of other things too
__________________
Little Red. 2011 V6. Automatic Trans., C&L CAI, JLT Catch Can, BBK Ceramic Coated Long Tube Headers with BBK Catted X Pipe, Axle Exchange (American Muscle) Aluminum DriveShaft, GT 500 Lower Control Arms, Koni (orange) Dampers, Steeda Watts Link, Ford Racing 3.73 Gears, Magnaflow Street Series Axle Backs and a few more mods....Wifes car, 2014 Ford Edge Limited.
David Young is offline   Reply With Quote
Old 07-17-2016, 08:07 PM   #5
Registered Member
Regular
 
Mile high JDF's Avatar
 
Join Date: Jun 2011
Location: Thronton
Region: Colorado
Posts: 5,844
Have you done a fuel filter on it at all? Lack of fuel can cause bucking and surging at low throttle.
__________________
Sold - Black 2000 Mustang GT, gone but definitely not forgotten
- Silver 2007 Corvette
Current - DHG 2001 Bullitt
Mile high JDF is offline   Reply With Quote
Old 07-17-2016, 09:23 PM   #6
Registered User
Newbie
 
Join Date: Jul 2016
Location: Bel air
Region: Maryland
Posts: 3
Well, I changed all of my spark plugs, cleaned the throttle body, changed the wires and it has almost all but gone away the last thing I will do is the fuel filter
Jessej1194 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lag in Acceleration/Throttle Response extreme963 2005-2010 Mustang GT 50 10-17-2016 04:18 PM
small popping noise from exhaust And lag under hard acceleration mattyp511 Pre-2005 V6 Mustang 11 12-06-2014 08:55 PM
Acceleration lag.. sixpac 1979-1995 Mustang GT 22 06-26-2012 08:27 AM
shift lag! NotoriousSPG Pre-2005 V6 Mustang 3 05-25-2007 08:01 AM

» Like Us On Facebook



09:19 AM


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.