2015 Mustang GT - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Join Mustang Evolution Today


Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 08-25-2016, 08:05 AM   #1
Registered User
Newbie
 
Join Date: Jul 2016
Location: Warner Robins
Region: Georgia
Posts: 10
2015 Mustang GT

I purchased a X4 SCT tuner and a JLT CAI from Lightening Force Performance with a preload tune, installed both , car would crank , start and then stop running within a few seconds. Talked for 4 days off and on with the SCT TECH support. I was told that it was a mechanical issue to the JLT that I bought was not built for my 2015.
Has anyone ever experienced this?
Mark Marley is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2016, 08:47 AM   #2
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 472
Take the CAI off and see if that actually is the problem.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2016, 10:57 AM   #3
Registered User
Newbie
 
Join Date: Jul 2016
Location: Warner Robins
Region: Georgia
Posts: 10
It was not recommended to run the car with the tune installed, without the CAI ,and I know it won't run with the CAI installed and no tune. That is what SSCT tech reps said, so I did not try it with that setup. Do you think it will mess the car up if I trouble shoot it with tune installed and no CAI?
Mark Marley is offline   Reply With Quote
Old 08-25-2016, 11:09 AM   #4
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: Winston Salem
Region: North Carolina
Posts: 472
I think as a test, starting it up with the factory intake and tune installed for the few seconds it will take to determine if it still shuts off or not would do no harm.
__________________
03 GT Convertible, 5-speed
07 V6 Coupe
jkeaton is offline   Reply With Quote
Old 08-25-2016, 11:26 AM   #5
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 4,271
w/o insulting did you install the air flow sensor correctly and is the plug fully seated. Did it get damaged they are fragile. After checking that I would start again at stock...mayhap corrupted tune?
__________________
"every one of you was going 50"
Strange Mud is offline   Reply With Quote
Old 08-27-2016, 12:49 PM   #6
Registered User
Newbie
 
Join Date: Jul 2016
Location: Warner Robins
Region: Georgia
Posts: 10
You were right, in the JLT CAI you can install the MAF in either direction, reinstalled the correct way and car works AWSOME !!!
Mark Marley is offline   Reply With Quote
Old 08-27-2016, 12:53 PM   #7
Registered User
Newbie
 
Join Date: Jul 2016
Location: Warner Robins
Region: Georgia
Posts: 10
Another question, in the SCT tuner you can change the settings for the transmission, I have an 6 speed Automatic, what do the negative percentages mean and do, and at what percent, positive or negative gives the car the best performace on the street as far as shifting? I really want the car to bark gears when putting my foot down. Thanks for the info
Mark Marley is offline   Reply With Quote
Old 08-29-2016, 06:20 AM   #8
Staff

Regular
Staff
 
Strange Mud's Avatar
 
Join Date: Aug 2013
Location: Small Town
Region: Connecticut
Posts: 4,271
I don't know about the tuner settings..are they LFP tunes or are they SCT? If so see how they are with customer questions.
__________________
"every one of you was going 50"
Strange Mud is offline   Reply With Quote
Old 09-03-2016, 11:04 AM   #9
Registered Member
Regular
 
stanggtcs's Avatar
 
Join Date: Mar 2016
Location: New London County
Region: Connecticut
Posts: 75
Glad to hear you were able to find the issue. Now get out there and lay down some rubber, safety first
__________________

2014 GT/CS 6spd. with total FR suspension upgrades.
stanggtcs is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Tags
2015 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Mustang GT PP vs 2015 Camaro 1LE Ish416 2015 Mustang GT 111 06-12-2015 05:52 PM
2015 3.7 Vs 2015 2.3 ecoboost 2011 Kona Blue 2015+ Mustang Ecoboost (and V6) 114 01-05-2015 06:16 AM
Ford rumors of SVO mustang to be produced for 2015 mustang Kyle94GT302 General Mustang Discussion 3 10-19-2011 11:02 AM

» Like Us On Facebook



02:27 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.