gauge problem - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > The Bar



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-10-2005, 09:30 PM   #1
Registered Member
Regular
 
red herring's Avatar
 
Join Date: Dec 2004
Region: California
Posts: 298
Send a message via AIM to red herring
gauge problem

Of course everybody here knows I have a different car but let me explain my problem anyway and see if anyone can help. Got in my car to go home after my friends little sisters birthday and immediately after starting the car the OBC screen flashes "brake circuit failure." Being in a hurry, because I'm blocking other people in the driveway, I drive off and notice a couple of yards down the road that my gas gauge isn't working and neither is my temperature gauge. Do I have a short somewhere? WTF?
red herring is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-10-2005, 09:43 PM   #2
n8r
Legacy Member
Legacy
 
n8r's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 3,216
whenever my tach isn't working, i just slam my hand on the dash, works everytime for me
__________________
Quote:
Originally Posted by Brent
Nothing is ever official until its official
n8r is offline   Reply With Quote
Old 07-10-2005, 09:52 PM   #3
Registered Member
Regular
 
Join Date: Apr 2005
Posts: 1,834
Quote:
Originally Posted by n8r
whenever my tach isn't working, i just slam my hand on the dash, works everytime for me
thats how we do it down here in the south


something dont work...........beat the **** out of it.

yesterday the radio at work wouldnt come on so we slammed it down a few times on the back counter in the warehouse and BAM............she works fine now
Kyle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-10-2005, 10:04 PM   #4
Moderator Emeritus
Legacy
Regular
 
SpectorV's Avatar
 
Join Date: May 2003
Region: Alabama
Posts: 26,049
Send a message via AIM to SpectorV
could be a fuse, check all your fuses.
__________________
2003 Cobra Vert (Redfire) #3938 of 5082 @ 05/27/2003
472rwhp/493rwtq -Modification List - Dyno Sheet
2012 Mustang 3.7L M6 (Kona Blue)
2011 Ford Edge Sport (Red Metallic)
SpectorV is offline   Reply With Quote
Old 07-10-2005, 10:58 PM   #5
Registered Member
Regular
 
red herring's Avatar
 
Join Date: Dec 2004
Region: California
Posts: 298
Send a message via AIM to red herring
The tach works fine, just the fuel gague and temp. gague aren't working. I'll check the fuses when light comes tomorrow. any other ideas?
red herring is offline   Reply With Quote
Old 07-11-2005, 02:26 PM   #6
Road Trip!
 
Tbird232ci's Avatar
 
Join Date: Jun 2003
Region: Maryland
Posts: 1,170
Send a message via AIM to Tbird232ci
quite possible that your gauge cluster has its own voltage regulators per gauge, im not sure about your specific vehicle, but it could possibly be a problem
Tbird232ci is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > The Bar

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gauge Help DStang 2011-2014 Mustang GT 14 09-30-2010 08:12 PM
Gauge Wire Routing w/CDC gauge pod tripod_2005 2005-2010 Mustang GT 13 04-30-2010 12:46 PM
1995 convertable 5.0 temp/fuel gauge problem rwb223 1996-2004 Mustang GT 3 03-10-2010 01:55 AM
gauge help iwannagofast 1996-2004 Mustang GT 5 02-20-2008 02:37 AM

» Like Us On Facebook



08:46 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.