Hid help - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > The Bar



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 06-15-2013, 08:05 PM   #1
Registered Member
Regular
 
Slp_loudmouth's Avatar
 
Join Date: Aug 2012
Region: New Jersey
Posts: 566
Hid help

So I have had my hids in for 2 months now and my driver one just won't turn on it did it the other day and I got it to come on after turning them on and off. Everything is hooked up fine just don't know bad bulb or what
Slp_loudmouth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2013, 02:23 AM   #2
Registered Member
Regular
 
1shotkllz's Avatar
 
Join Date: Apr 2012
Region: North Carolina
Posts: 398
Check your connections. Swap your passenger and driver side bulbs to see if it works then. That will let you know if you have a bad bulb. Swap the driver side and passenger side ballast to see if the outtage follows. That will determine if you have a bad ballast or not.
1shotkllz is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > The Bar

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Like Us On Facebook



12:00 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.