What problems have you had with your mustang? - Mustang Evolution

Go Back   Mustang Evolution > Off Topic Forums > The Bar



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-08-2004, 09:31 AM   #1
Registered User
Newbie
 
Join Date: Apr 2004
Posts: 4
Send a message via AIM to mstnglvr Send a message via Yahoo to mstnglvr
What problems have you had with your mustang?

I was curious as to how many of you have had to bring in your mustang to get something fixed.
Post the problem, the year of your car, and if your warranty covered it.

I have a 2001 V6. Latest problem this weekend was my drivers side window wouldn't go up. Needed a new motor. Luckily I have 3 weeks left in my 3yr warranty. Last year, the rack-and-pinion steering had to be replaced. That would have cost me around $700-800 to get fixed, but was covered by my warranty.
mstnglvr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-08-2004, 09:50 AM   #2
Legacy Member
Legacy
 
fast64's Avatar
 
Join Date: May 2003
Region: Georgia
Posts: 3,263
Send a message via AIM to fast64
i've had normal problem associated with a 40 yr old car, and no, warranty didnt cover it, haha
__________________
-Jimmy I drive a station wagon.
GO BRAVES
fast64 is offline   Reply With Quote
Old 07-08-2004, 10:06 AM   #3
Registered Member
Regular
 
KrazyPony's Avatar
 
Join Date: Jul 2003
Region: South Carolina
Posts: 800
Hmmm....none with my 98' v6, just the damn 03 Mach1

Mach1: had bad acid rain on it, and ford didnt wanna fix it...even though my wife works at the dealership, they went through all this BS about it with a ford rep, and he claimed we modified the hood for the shaker scoop! So we ended up spending the money to have it painted the way we wanted and are happy we did....all in all the ford rep was reloacted after he was turned in for his stupidity.
__________________
http://i201.photobucket.com/albums/aa307/KrazyPony/KrazyPonysigBlue.jpg
KrazyPony is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-08-2004, 10:15 AM   #4
Legacy Member
Legacy
 
Danger Dude's Avatar
 
Join Date: May 2003
Region: South Carolina
Posts: 5,187
Send a message via AIM to Danger Dude
Quote:
Originally Posted by KrazyPony
all in all the ford rep was reloacted after he was turned in for his stupidity.
Yeah sure tell them the truth Jeff!! The Rep was called to the front office where he was greeted by 2 Ford Gustapo agents taken out back and shot. He was then put through a paper shreader and spread out in the front flower bed

Boy those flowers are beautiful !!!! MUHAHAHHHAHA
__________________
Danger Dude is offline   Reply With Quote
Old 07-08-2004, 10:19 AM   #5
Registered Member
Regular
 
KrazyPony's Avatar
 
Join Date: Jul 2003
Region: South Carolina
Posts: 800
yes but I think I ran over those flowers at the new house with the massive ebrake usage of 1 aka f150
__________________
http://i201.photobucket.com/albums/aa307/KrazyPony/KrazyPonysigBlue.jpg
KrazyPony is offline   Reply With Quote
Old 07-08-2004, 10:23 AM   #6
Zim
You want to **** me?
Legacy
 
Zim's Avatar
 
Join Date: Jun 2003
Location: Kansas City
Region: Missouri
Posts: 4,043
blew my engine... and now the tranny is about shot
__________________

I like toys
Zim is offline   Reply With Quote
Old 07-08-2004, 12:38 PM   #7
Registered Member
Regular
 
Ponycarman's Avatar
 
Join Date: Aug 2003
Region: Texas
Posts: 349
Other than having the check engine light come on if I don't tighten my gas cap down enough, none.


Steve
__________________
1996 Mustang
1965 Barracuda

Quote:
Originally Posted by slvr2000stang
Holy crap he's right.
Ponycarman is offline   Reply With Quote
Old 07-08-2004, 12:41 PM   #8
Registered Member
Regular
 
Join Date: Apr 2004
Region: California
Posts: 4,272
02 none
STEVE is offline   Reply With Quote
Old 07-08-2004, 12:47 PM   #9
Dom
Registered Member
Regular
 
Dom's Avatar
 
Join Date: Nov 2003
Region: Tennessee
Posts: 2,391
Send a message via AIM to Dom
1998, has my fuel system purged on me one day. cleared the code and no problems since, no warranty.
__________________
- Matthew | matthew98@gmail.com
Dom is offline   Reply With Quote
Old 07-08-2004, 04:47 PM   #10
Registered Member
Regular
 
bluemustang's Avatar
 
Join Date: Jul 2003
Region: Connecticut
Posts: 1,192
Lets see when I had my 2000 V6 that baby was perfect no issues at all. Even when I did modd it to all hell not even a single check engine light ever came on.

Now for my 89 5.0 as of owning it since March I replaced the heater core, 2 sensors, EGR valve, new A/C unit, Vavle cover gaskets, Trans pan gasket and gave it a basic tune up and that my friends she runs like if it were 1989
of course no warrenty BUT since I work for Dodge I just paid for parts and they did all the work for me for free Gotta love Ford lovin mechnics
__________________
1989 5.0 - Mustang Brandy the NOW It can Barely Idle B**ch
http://www.mustangmods.com/ims/u/2019/3437/42512.jpg
1999 Jeep Cherokee Sport 4.0 - Yeah Its Gotta Baby Dick Lift
bluemustang is offline   Reply With Quote
Old 07-08-2004, 04:51 PM   #11
Registered Member
Regular
 
Warfire80's Avatar
 
Join Date: Feb 2004
Region: Illinois
Posts: 798
Send a message via MSN to Warfire80
rear sway bars were loose, took it to the dealer and they tightened it down and works fine now.
__________________
2007 Honda Civic EX
2003 Dodge Ram Hemi 4x4

Quote:
by Lawrence Bell
Show me a man who cannot bother to do little things and I'll show you a man who cannot be trusted to do big things
Warfire80 is offline   Reply With Quote
Old 07-08-2004, 06:35 PM   #12
Registered Member
Regular
 
Join Date: Apr 2004
Region: California
Posts: 4,272
how many sway bars do ya have
STEVE is offline   Reply With Quote
Old 07-09-2004, 04:19 AM   #13
Registered Member
Regular
 
tire's Avatar
 
Join Date: Jul 2003
Posts: 941
Send a message via AIM to tire
not that many complaints. i've been slightly impressed overall with the car.

2000 5spd v6... 50k miles

mach 460 cd player acting wierd, replaced under warranty
pass side seat flipper latch broke off under normal use
ground wire came loose and i spent countless hours trying to find it. it happens, oh well.
heat affects motor more than any other car i've driven, but supposedly this has been reported before.
reverse lights not working...checked fuses and tranny sensor... no dice
the sn95 chassis isn't as stiff as it should be, even with subframe connectors. when i'm jacked up on one side i feel like a i have fox!


all the rest (many many more than the ones posted here) were caused by yours truly.
tire is offline   Reply With Quote
Old 07-09-2004, 04:32 AM   #14
Legacy Member
Legacy
 
97Stallion's Avatar
 
Join Date: Nov 2003
Region: Missouri
Posts: 1,461
Send a message via AIM to 97Stallion Send a message via MSN to 97Stallion
Had my starter go bad. It wouldn't disingage. Warrenty covered that, and that was the only thing i've had go wrong in the last 4+ years I've had my car other than my racing problem. My tranny went bad.
__________________

60' ~ 2.1, 1/8 ~ 9.61 @ 73.4mph
Living one day at a time!

DAMN Those are some old *** numbers!!! I need updated ones!!
97Stallion is offline   Reply With Quote
Old 07-09-2004, 05:57 AM   #15
Legacy Member
Legacy
 
Black95GT's Avatar
 
Join Date: Jul 2003
Region: New Jersey
Posts: 897
Send a message via AIM to Black95GT
None with the GT
On the V6, waterpump gasket went, and my headgaskets blew.
__________________
-Jason
2003 DSG Cobra -2.2L KB, 60lbs Injectors, Single Blade TB, SCT2400 MAF, Kook's LT's, Kook's High-Flow Catted X-Pipe, Magnaflow CB, JLT RAI, MGW Short-Throw, H&R Race Springs, MM CC Plates, MM Bumpsteer, BF IRS Brace, BF Idlers, and AFS 18 Chrome Reps w/ R888s
Black95GT is offline   Reply With Quote
Old 07-09-2004, 08:38 AM   #16
Legacy Member
Legacy
 
V6STANG007's Avatar
 
Join Date: Jan 2004
Region: Florida
Posts: 1,657
Send a message via AIM to V6STANG007 Send a message via Yahoo to V6STANG007
2000 V6
The motor on the driver side window had to be replaced
something in my muffler broke and had to get a new muffler
all was covered by warranty
__________________
Jorge ~

Quote:
Originally Posted by Danger Dude
OK you are right!!! Maybe I am the Old Crazy One
V6STANG007 is offline   Reply With Quote
Old 07-09-2004, 08:46 AM   #17
Registered Member
Regular
 
Join Date: Jun 2003
Region: Iowa
Posts: 414
Send a message via AIM to Horse Send a message via Yahoo to Horse
Lets see, I've had a few problems, some my fault (well, I helped) some not so much.

I took my 2000 in for the e-brake recall and they mangled my dash, shift knob and broke something so that my reverse lights didn't work anymore. Took that in and they said they fixed it. It worked once in the parkinglot and never again. Took it to a different dealership and they fixed it right.

Had 5th gear synchro die for no apparant reason. fixed under warrenty

about a month after I bought it the IAC went band. Fixed under warrenty

after my warrenty ran out my drivers front wheelbearing went bad. Looked like an MFG defect. Fixed it myself.

Differential bearings went out, had to replace them.

Sounds like my passenger side front wheelbearing is junk now. I'll have to fix that now too.

blew a head gasket (Started leaking oil down the side of the block and before I could fix it, it started leaking oil down into my cylinders so it smoked like hell. Fixed that myself.
__________________
4.2L , CAI, BBK 65MM throttle body, 30lb injectors, SSM ported intakes, FLEX 1/2" spacer, RPM big valve heads, Comp roller rockers and cam, ASP-underdrive pulley, GT rear swaybar, & Quad Shocks, Full MM Coilover conversion, 17" Grey Torque Thrust wheels, FMS Aluminum driveshaft 8.8 rear w/ 3.73 gears, Tri-Ax Shorthrow shifter & SPEC stage II clutch w/ aluminum flywheel
Horse is offline   Reply With Quote
Old 07-09-2004, 10:34 AM   #18
Registered Member
Regular
 
Warfire80's Avatar
 
Join Date: Feb 2004
Region: Illinois
Posts: 798
Send a message via MSN to Warfire80
Quote:
Originally Posted by 232stang
how many sway bars do ya have
it is the stock ones that are attatched to the frame on each side.
__________________
2007 Honda Civic EX
2003 Dodge Ram Hemi 4x4

Quote:
by Lawrence Bell
Show me a man who cannot bother to do little things and I'll show you a man who cannot be trusted to do big things
Warfire80 is offline   Reply With Quote
Old 07-09-2004, 10:38 AM   #19
Legacy Member
Legacy
 
fast64's Avatar
 
Join Date: May 2003
Region: Georgia
Posts: 3,263
Send a message via AIM to fast64
the tach on my 93 is starting to freak out, thats the only problem i've had with that car, i've only had it for a month though
__________________
-Jimmy I drive a station wagon.
GO BRAVES
fast64 is offline   Reply With Quote
Old 07-09-2004, 10:39 AM   #20
Registered User
Newbie
 
Join Date: Apr 2004
Posts: 4
Send a message via AIM to mstnglvr Send a message via Yahoo to mstnglvr
Must be a florida thing v6stang007...my window wouldn't go up july 4th. of course it was pooring outside when it happened.
mstnglvr is offline   Reply With Quote
Old 07-09-2004, 11:02 AM   #21
Legacy Member
Legacy
 
V6STANG007's Avatar
 
Join Date: Jan 2004
Region: Florida
Posts: 1,657
Send a message via AIM to V6STANG007 Send a message via Yahoo to V6STANG007
Quote:
Originally Posted by mstnglvr
Must be a florida thing v6stang007...my window wouldn't go up july 4th. of course it was pooring outside when it happened.
oh man that sucks. mine happen a while ago, it stuck half way down and I was afraid of the rain thing happening to me so I immidiately took it to the dealer.
__________________
Jorge ~

Quote:
Originally Posted by Danger Dude
OK you are right!!! Maybe I am the Old Crazy One
V6STANG007 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Off Topic Forums > The Bar

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems With Ford Mustang '95 superman93 1979-1995 Mustang GT 9 12-22-2009 08:07 PM
02 Mustang Possible Transmission Problems TK225 General Mustang Discussion 3 10-07-2008 07:41 AM
Problems with 1991 Mustang GT wmsoccer28 1979-1995 Mustang GT 10 08-20-2007 10:48 PM
mustang problems?? MarcyWK Pre-2005 V6 Mustang 7 05-08-2006 01:54 PM
first mustang 3 days ago and problems already aparker813 1996-2004 Mustang GT 14 08-20-2005 12:10 AM

» Like Us On Facebook



07:40 AM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.