Mustang Evolution

Mustang Evolution (http://www.mustangevolution.com/forum/)
-   1996-2004 Mustang GT (http://www.mustangevolution.com/forum/f280/)
-   -   Need help!!!!!!! (http://www.mustangevolution.com/forum/f280/t306627/)

Mady 06-12-2012 07:05 PM

Need help!!!!!!!
 
K so I got the new CAI from American muscle, and forgot to plug the MAF sensor back in and drove it to the hardware store to plug up the hole ment for the v6 (damn sixers!) so anyway the check engine light came on, any words of advice people?

Ryan7racin 06-12-2012 07:08 PM

Buy a Bama programmer to shut it off.

Mady 06-12-2012 07:09 PM

What exactly happened though?

ab_mach1 06-12-2012 07:15 PM

Quote:

Originally Posted by Mady
K so I got the new CAI from American muscle, and forgot to plug the MAF sensor back in and drove it to the hardware store to plug up the hole ment for the v6 (damn sixers!) so anyway the check engine light came on, any words of advice people?

Plug the connector from the harness for the MAF back into the MAF. The check eng light should go away.

Siendly22 06-12-2012 07:15 PM

[QUOTE="Mady"]What exactly happened though?[/


Remove your negative terminal on the battery for 15 to 20 mins then put it back.. I hope it helps

Mady 06-12-2012 07:17 PM

I did both of what you both said and the check engine light is still on damn

taylor98gt 06-12-2012 07:20 PM

Quote:

Originally Posted by Mady
I did both of what you both said and the check engine light is still on damn

Whenever mine comes on for a o2 sensor or anything I Jus unhook the negative side for bout a hour and it goes off

Mady 06-12-2012 07:22 PM

Maybe the CAI requires a tune?

Siendly22 06-12-2012 07:23 PM

Quote:

Originally Posted by Mady
I did both of what you both said and the check engine light is still on damn

Just remove the negative terminal for a while an hour or two. Dont panic ;-) lol

Ryan7racin 06-12-2012 07:24 PM

Quote:

Originally Posted by Mady
Maybe the CAI requires a tune?

No you shouldn't need a tune. Mine did this on my f150 I just hooked it back up and it went away. On my mustang it wouldn't go away cause of the o2 sensors I got tired of seeing it bought a Bama programmer and it's gone!

Siendly22 06-12-2012 07:25 PM

Quote:

Originally Posted by Mady
Maybe the CAI requires a tune?

Not necessary , I install my K&N CAI without tune woks fine. No check engine light . Then the following month I tune my car. :)

Mady 06-12-2012 07:29 PM

I see well I basically have a cold air intake and magma flow mufflers what next?

Siendly22 06-12-2012 07:31 PM

Quote:

Originally Posted by Mady
I see well I basically have a cold air intake and magma flow mufflers what next?

Change your throttle body 75mm . You will thank me lol

Mady 06-12-2012 07:33 PM

Damn u all now I want engine mods! Granted my CAI was a pain to put in but that's partly due to buying the project kid from AM

2000_gt 06-12-2012 07:45 PM

Unplug negative battery cable for about 10-15 mins and plug your sensor back in then reconnect

ab_mach1 06-12-2012 08:52 PM

Since you need to reset your ECU, you might as well complete the idle re-learn...

Disconnect NEG from battery for 30min

Reconnect and start car, let idle as eng gets to operating temp. Let it idle a little over a minute

Turn on A/C to MAX, let idle little over a minute, turn off A/C

Then drive the car for at least 10 miles

Now you'll have a smooth idle to go along with your new CAI

Vegas97gt 06-12-2012 10:26 PM

Is the check engine light still on? If so check your plugs when I did the one on my dads car it came with an extension and the prong to the extension was broken so it kicked the cel on luckily the plug reached without the extension. If that doesn't work take to an autoparts store that does free scans so you know what the reading is


07:25 AM

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.